proLIGHT 1000
Machining Center
User’s Guide
For Windows
The information contained in this guide was accurate at the time of its printing. Light Machines Corporation reserves the right to change specifications and operational performance of its products without notice. Any changes or corrections to the information contained in this publication will be incorporated in future issues.

This publication (34-7111-0003, November, 1996) corresponds to the proLIGHT1000Machining Center package, including the WPLM1000 Control software.

spectraCAM™ and proLIGHT™ are trademarks of Light Machines Corporation.

All other register marks or trademarks are of their respective holders.
# User’s Guide

## Section A: Installation

**Getting Ready for Installation** ................................................................. A-2
- Check Your Shipment ................................................................. A-2
- Register Your Machining Center .................................................. A-2
- Prepare Your Work Place .......................................................... A-3
- Unpack the Machining Center ..................................................... A-3
- Set Up the Machining Center .................................................... A-3

**Hardware Installation** ................................................................. A-4
- Installing the Interface Card in the PC ..................................... A-4
  - Opening the PC Chassis ....................................................... A-5
  - Unpacking the Interface Card ............................................. A-5
  - Inserting the Interface Card ............................................... A-5
  - Checking Your Installation ................................................ A-6

**Connecting the Machining Center** .............................................. A-6
- Connecting the Machining Center to the Controller Box .......... A-8
- Connecting the Machining Center to the Computer ................. A-8
- Connecting the Computer to the Controller Box .................. A-8
- Connecting Power to the Hardware Components ..................... A-9

**Optional Connections** .................................................................. A-9

**Computer System Requirements** ................................................. A-10

**Software Installation** ................................................................. A-11
- Installing the Control Program .............................................. A-11
- Uninstalling the Control Program .......................................... A-12
- The SETUP Program ............................................................... A-12

**Technical Support** ................................................................. A-13
- Before Calling ................................................................. A-13

**Warranty** ............................................................................... A-13
Section B: proLIGHT 1000 System Hardware

An Introduction to the proLIGHT Machining Center ........................................... B-2
 Features .............................................................................................................. B-2

The proLIGHT Machining Center Components .................................................. B-3

The Main Machine Components ........................................................................ B-3

The Front Panel Components ............................................................................ B-4

The Controller Box ............................................................................................. B-5

The Accessory Kit ............................................................................................. B-5

Options ............................................................................................................. B-6

Low Profile Clamping Kit Installation ............................................................... B-6

Vacuum System Installation ............................................................................. B-6

Air Vise Robotic Interface Installation ............................................................. B-6

Automatic Tool Changer .................................................................................. B-6

Quick Change Tooling Installation ................................................................ B-7

Installing Quick Change Tooling Model ACC-5141 ........................................ B-7

Using the Tool Height Offset Sensor ................................................................. B-9

Maintaining the Machining Center ................................................................. B-10

Ballscrews ....................................................................................................... B-10

The Saddle ....................................................................................................... B-11

Linear Slides .................................................................................................... B-11

Lubrication ....................................................................................................... B-11

Adjustment ....................................................................................................... B-12

Spindle ............................................................................................................ B-13

Spindle Head ................................................................................................... B-13

Spindle Motor ................................................................................................. B-13

Checking for Spindle Shaft Play ..................................................................... B-13

Spindle Fuse .................................................................................................... B-14

Belts ............................................................................................................... B-14

Spindle Belt .................................................................................................... B-14

Axis Drive Belts ............................................................................................... B-15

Checking the Y Axis Drive Belt ....................................................................... B-15

Adjusting the Y Axis Drive Belt ....................................................................... B-16

Checking the X Axis Drive Belt ....................................................................... B-16

Adjusting the X Axis Drive Belt ....................................................................... B-16

Checking the Z Axis Drive Belt ....................................................................... B-17
Section C: Getting to know the Control Program

Starting the Control Program ........................................... C-2
  Starting the Control Program in Simulate Mode ....................... C-2
If You Need Help............................................................. C-3
Exploring the Control Program Screen .................................... C-4
  Menu Bar ................................................................. C-4
  Standard Tool Bar ...................................................... C-4
  Outputs Tool Bar ........................................................ C-6
  Inputs Tool Bar .......................................................... C-7
  Edit Window .............................................................. C-8
  Status Bar ............................................................... C-9
  Machine Info Panel .................................................... C-10
  Position Readout ........................................................ C-11
  Verify Window .......................................................... C-11

Section D: Tutorial: Machining a Sample Part

Safely Running the Machining Center ..................................... D-2
  Safety Rules ............................................................. D-2
  Making Emergency Stops .................................................. D-3
Running a Sample NC Program ........................................... D-5
  Open MILLONE.NC ....................................................... D-5
  Adjust the Verify Settings ............................................. D-6
    Adjust the View ....................................................... D-6
    Adjust the Stock ..................................................... D-7
  Define the Tool ......................................................... D-8
    Add the Tool to the Library ......................................... D-8
    Select the Tool for Verification .................................... D-9
  Verify MILLONE.NC .................................................... D-10
Dry Run the NC Program .................................................. D-11
Mount the Workpiece .................................................. D-13
Run the Program .................................................. D-14

Reference Guide

Section E: Control Program Reference

The WPLM1000 Interface .................................................. E-2
Positioning Screen Components ........................................ E-2
- Positioning Toolbars .................................................. E-2
- Positioning Information Areas ........................................ E-2
- Positioning Program Edit Windows .................................. E-3
Saving the Window Positions .......................................... E-3
Docking and Floating Windows and Toolbars .................................. E-4
  Docked Screen Components .......................................... E-4
  Floating Screen Components .......................................... E-4
Message Bar .......................................................... E-5
Windows .......................................................... E-5
  Program Edit Windows .................................................. E-5
  Verify Window .......................................................... E-6
  Machine Info Window .................................................. E-6
  The Position Window ................................................... E-7
Tool Bars .......................................................... E-8
  Standard Toolbar ..................................................... E-8
  ATC Control Toolbar ................................................... E-9
  Inputs Toolbar ........................................................ E-9
  Outputs Toolbar ....................................................... E-10
Panels .......................................................... E-11
  Jog Control Panel ...................................................... E-11
  Operator Panel ......................................................... E-12
  Status Bar .......................................................... E-13
Menu Bar .......................................................... E-13
  File Menu .......................................................... E-14
New Command ................................................................. E-14
Open Command ............................................................... E-14
Close Command ............................................................... E-15
Save Command ................................................................. E-16
Save As ... Command .......................................................... E-16
Print Command ................................................................. E-17
Print Setup Command ......................................................... E-18
Opening a Recent Program .................................................. E-18
Exit Command ................................................................. E-19

Edit Menu ........................................................................... E-20

Undo Command ................................................................. E-20
Redo Command ................................................................. E-21
Cut Command ..................................................................... E-21
Copy Command ................................................................. E-21
Paste Command ................................................................. E-21
Clear Command ................................................................. E-22
Delete Line Command ........................................................ E-22
Find Command ................................................................. E-22
Replace Command ............................................................. E-23
Goto Line Command .......................................................... E-24
Renumber Command .......................................................... E-24
Insert N Codes ................................................................. E-24
Insert or Remove Spaces ..................................................... E-25
Remove Comments ............................................................ E-26
Remove N Codes ............................................................... E-26
Lock Command ................................................................. E-26
Select Font Command ........................................................ E-27
Font Settings ..................................................................... E-27

View Menu ........................................................................... E-27

Position Command ............................................................ E-27
Machine Info Command ...................................................... E-28
Jog Control Command ........................................................ E-28
Operator Panel Command .................................................... E-28
Verify Window Command ..................................................... E-28
Toolbars Command ............................................................ E-28

Program Menu ..................................................................... E-29
Run/Continue Command ....................................................... E-29
Verify Command .............................................................. E-30
Estimate Runtime Command ................................................. E-31
Pause Command ............................................................... E-32
Feedhold Command ........................................................... E-32
Stop Command ................................................................. E-32
Tools Menu .......................................................................... E-33
  Setup Library Command .................................................... E-33
  Setup Tool Wizard Command .............................................. E-35
  Select Tool Command ...................................................... E-35
  Insert Tool From Command ................................................ E-36
  Configure ATC Command ................................................... E-36
  Operate ATC Command .................................................... E-37
  Initialize Station Location ... Command ............................. E-37
Setup Menu .......................................................................... E-38
  Set Position Command ..................................................... E-39
  Zero Position Command ................................................... E-39
  Jog Settings Command ..................................................... E-39
  Run Settings Command .................................................... E-41
  Verify Settings Command .................................................. E-43
  Verify Type Command ...................................................... E-46
  Set/Check Home Command ................................................. E-46
  Units Command .............................................................. E-47
  Coordinate Systems Command .......................................... E-47
  Goto Position Command .................................................... E-47
  Offsets Command ........................................................... E-49
  Spindle Command .......................................................... E-50
  Backlash Command ........................................................ E-51
  Soft Limits Command ....................................................... E-51
  Preferences Command ...................................................... E-52
Window Menu ......................................................................... E-54
  Cascade Command .......................................................... E-54
  Tile Command ................................................................. E-54
  Arrange Icons Command ................................................... E-54
  Window List Command ..................................................... E-54
Help Menu ............................................................................. E-55
  Help Command ............................................................... E-55
  Index Command .............................................................. E-55
Using Help Command ................................................................. E-55
Save Settings Command ............................................................. E-55
Restore Settings Command ......................................................... E-56
Tip of the Day Command ........................................................... E-56
About WPLM1000 ... Command ................................................... E-56

Selecting Commands .................................................................... E-57

Select a Command Using Pop-Up Menus ..................................... E-57
Program Edit Window Pop-up Menu ......................................... E-57
Position Window Pop-up Menu ................................................ E-58
Verify Window Pop-up Menu ..................................................... E-59
Jog Control Panel Pop-up Menu ................................................ E-60
Select a Command Using Hot Keys ............................................ E-61
Select a Command Using Toolbars .......................................... E-62

The Setup Program ..................................................................... E-63

Welcome Panel ........................................................................... E-63
Interface Card Panel ................................................................. E-64
General Panel ............................................................................ E-64
Control Panel ........................................................................... E-64
Advanced Panel ......................................................................... E-65
More Advanced Panel ............................................................... E-66

Offset Table ................................................................................ E-66

Working in Simulation Mode ...................................................... E-66

Section F: Basic CNC Programming

The Elements of an NC Part Program ......................................... F-2
Categories of NC Code ................................................................. F-3

Incremental Arc Center (%) ....................................................... F-4
Absolute Arc Centers ($) ........................................................ F-4
Skip (\) and Optional Skip (/) .................................................... F-4
Feed Rate (F Code) ................................................................. F-5
Preparatory Codes (G Codes) ..................................................... F-6

The Interpolation Group ........................................................... F-6
The Units Group ................................................................. F-7
The Plane Selection Group ....................................................... F-7
The Wait Group ................................................................. F-8
The Canned Cycle Group ........................................................ F-9
Section G: More CNC Programming

Linear Interpolation Programming ........................................... G-2
Circular Interpolation Programming ......................................... G-3
  Circular Interpolation on Other Planes ................................ G-4
  Helical Interpolation Programming ..................................... G-5
Rapid Traverse Programming ................................................ G-6
Canned Cycle Programming ................................................... G-7
Using G80 ........................................................................................................... G-7
Using G81 ........................................................................................................... G-8
Using G82 ........................................................................................................... G-9
Using G83 ........................................................................................................... G-9
Using G84 ........................................................................................................... G-10
Using G85 ......................................................................................................... G-11
Using G86 ......................................................................................................... G-11
Using G89 ......................................................................................................... G-12

Subprogram Programming ............................................................................... G-13

A Sample NC Subprogram ............................................................................. G-14

**Section H: Advanced CNC Programming**

Using Polar Programming ............................................................................. H-2
Using the Homing Commands ....................................................................... H-3
Using G28 ........................................................................................................ H-3
  Using G28 in an NC Program ................................................................. H-3
  Using G28 Before Setting Soft Limits .................................................. H-4
Using G27 ....................................................................................................... H-4
Using G29 ....................................................................................................... H-5

Using Cutter Compensation ........................................................................ H-6
  Starting Cutter Compensation (G41/G42) .......................................... H-7
  Cutter Compensation with IJK Vectors ............................................... H-10
  Setting Cutter Compensation Offsets (D) ........................................... H-11
  Changing Offset Values ........................................................................ H-12
  Changing Offset Sides .......................................................................... H-13
  Using Corner Offset Circular Interpolation (G39) ................................ H-14
  Canceling Cutter Compensation .......................................................... H-15
    Methods 1 and 4 ................................................................................ H-15
    Methods 2 and 5 ................................................................................ H-16
    Methods 3 and 6 ................................................................................ H-17

Using Scaling and Rotation Codes ................................................................. H-18
  Scaling ....................................................................................................... H-18
    Uniform Scaling .................................................................................. H-18
    Scaling Each Axis .............................................................................. H-19
    Creating Mirror Images with Scaling ............................................. H-20
Section 1: General Machining Information

Feed Rate and Depth of Cut ................................................................. I-2
Spindle Speeds ................................................................................. I-3
Feed Rate and Spindle Speed Selection ........................................... I-3
Lubricants and Coolants ................................................................. I-3
Tool Types ....................................................................................... I-4
   End Mills .................................................................................... I-4
   Center Drills ............................................................................. I-4
   Boring Tools ............................................................................ I-4
Sharpening Tools ............................................................................ I-5
Section J: Safe Machining Center Operation

Safety Rules ................................................................. J-2
Safety Checklist .......................................................... J-6
Lista de Seguridad ......................................................... J-7
Emergency Stops .......................................................... J-8

Section K: proLIGHT G and M Codes

G Codes by Group .......................................................... K-2
M Codes by Group .......................................................... K-5

Section L: Robotic Integration

Robotic Integration .......................................................... L-2
  How it Works .......................................................... L-2
  The Interface Connector ............................................. L-4
  The NC Codes .......................................................... L-5
  A Sample of Mill/Robot Communication ......................... L-6

Index
proLIGHT 1000
Machining Center
User’s Guide

For Windows
User’s Guide

Section A: Installation

Section B: proLIGHT 1000 System Hardware

Section C: Getting to know the Control Program

Section D: Tutorial: Machining a Sample Part
Reference Guide

Section E: Control Program Reference
Section F: Basic CNC Programming
Section G: More CNC Programming
Section H: Advanced CNC Programming
Section I: General Machining Information
Section J: Safe Machining Center Operation
Section K: proLIGHT G and M Codes
Section L: Robotic Integration
WARNING

The operation of rotating machinery should only be attempted by experienced, knowledgeable individuals!

Read the entire contents of this guide before running NC programs on the proLIGHT Machining Center.

To avoid possible injury always observe the safety precautions described in this User's Guide.
Installation

Getting Ready for Installation

Hardware Installation

Computer System Requirements

Software Installation

Technical Support
Getting Ready for Installation

Before you connect and run your new machining center, you should:

1. Check your shipment to make sure you received everything you need.
2. Register your machining center so you are covered by your warranty.
3. Prepare a workspace for your machining center and controller.
4. Unpack and set up your machining center.
5. Install the interface card into the computer.

Once all of these procedures are complete, you can connect the machining center and controller box, then install the Control Program.

Check Your Shipment

The first thing you should do after receiving your Machining Center is inspect the packaging for any visible signs of damage. If there is damage to the outside of the packaging, contact the shipping company as well as Light Machines Corp. After checking the packaging, locate the packing slip. This slip lists all of the items you should have received with your Machining Center. Check all of the items on the list. If any item is missing, contact Light Machines’ Customer Service Department (800/221/2763).

Register Your Machining Center

You’ll find a registration card in the small box with the documentation and software disks. Clearly print all the requested information and return this card to Light Machines Corporation.
Prepare Your Work Place

Make sure you have all the items on hand necessary to perform the installation. To install the proLIGHT Machining Center, you must have:

- A sturdy table on which you’ll place the Machining Center and your computer. Placing the table against a wall provides more stability. Make sure the wall has a 120VAC, 15 amp polarized outlet.

- A personal computer running Windows 95 or Windows NT version 3.5 (or greater). See page A-10 for a complete list of the necessary computer equipment.

- Your PC Owner’s Manual or equivalent documentation.

Unpack the Machining Center

1. Position the pallet near the table on which you’ll set the Machining Center. The table should be located against a wall for maximum support.

2. Remove the staples that attach the bottom of the cardboard container to the pallet.

3. Lift the cardboard container off of the pallet.

4. Inspect the Machining Center chassis for visible signs of damage such as a broken shield, a dent in the chassis or damaged cables.

   If any damage is noted, or if you find any discrepancies between the packing slip and the items received, call Light Machines’ Customer Service Department (800/221/2763).

5. From underneath the pallet, use a 9/16” wrench to remove the four bolts holding the Machining Center base to the pallet. Keep the bolts and other packaging materials.

Set Up the Machining Center

1. Lift the Machining Center off of the pallet and onto the table.

2. Once on the table, position the Machining Center correctly for machining.

3. Remove the protective paper from the safety shield.
Hardware Installation

The following paragraphs review the procedures for installing all the hardware components of the proLIGHT Machining Center. You should already have your personal computer set up in accordance with the directions in the computer owner’s guide.

The first thing you have to do is install the proLIGHT Interface Card in your personal computer.

WARNING

Do not connect power to the Machining Center or the computer until instructed to do so in the following procedures.

Installing the Interface Card in the PC

The following paragraphs describe the procedure for installing the Interface Card in the chassis of your PC. You should have already set up your PC according to the instructions in your Owner’s Manual. The Interface Card can be installed in any full-size slot designated for expansion card use. Refer to your computer owner’s manual to determine particular expansion card restrictions.

WARNING

Do not plug the power cord from the PC chassis into an AC outlet until all installation procedures have been completed and the chassis cover has been closed.
Opening the PC Chassis

To install the Interface Card, you must remove the cover of the personal computer. Refer to the installation instructions supplied with your computer for details on removing the cover. Generally, the cover is secured by four screws through the rear panel; however, some personal computers may have push latches, or screws in different locations.

**WARNING**

Disconnect power from your personal computer before opening its chassis cover!

Turn off the power switch and remove the power cord to assure that no electrical potential is present when the cover is removed.

Set the cover aside and locate the slot where the card is to be mounted. Remove the blank slot cover (if any). Removing the slot cover requires removing a screw at the top rail of the rear panel. You may choose to discard the cover, but save the screw for installing the Interface Card.

Unpacking the Interface Card

The card is shipped inside an anti-static envelope. Be careful not to create any static discharge when removing the card from the envelope; touch a grounded surface such as the PC enclosure first. Slide the card out of the envelope and inspect it for signs of damage, such as bent or broken components or a warped circuit card. If damage is noted, contact Light Machines Corporation immediately.

Inserting the Interface Card

The following procedures describe how to insert and secure the Interface Card in the computer.

1. Grasp the Interface Card at the front and back.
2. Position the card above the bus connector at the chosen slot. The interface connector on the end of the card should face the rear panel of the computer chassis.
3. Slide the card into the bus slot. The connector on the card should protrude from the rear panel of the computer. Carefully wiggle the card back and forth to assure its tightness in the bus. Components on the Interface Card should not touch adjacent cards or other components.

4. Secure the card to the top rail of the rear panel with the screw you saved when removing the blank slot cover.

5. Make note of which slot the Interface Card is plugged into. Do not get it mixed up with the parallel port which uses the same type of connector.

Checking Your Installation

After installing the Interface Card, replace the computer chassis cover. Connect the computer power cord and turn the computer on. The computer should perform an internal check, and run the operating system.

If the PC fails to start-up, turn off the power, open the chassis and check your installation to be sure that the Interface Card is located in an appropriate slot and is properly seated.

When the Windows program is running, turn off the power and install the other hardware components.

Connecting the Machining Center

The following paragraphs review the procedures for connecting your computer with the Machining Center and Controller Box. The Interconnection Diagram on the following page has been provided as a visual aid for the recommended connections.

WARNING

Do not connect power to the Machining Center, the Interface Card, the Controller Box or the computer until instructed to do so in the following procedures.

Never connect or disconnect the cables with the power on! This will cause damage to the Controller Box drive components.

Operate the Machining Center with all cables firmly secured.

Note: It may be beneficial to label the connectors on the back panel of the PC for easy identification.
proLIGHT Machining Center System Interconnection Diagram

(rear view of system)
Connecting the Machining Center to the Controller Box

The interface cables and power cords are long enough to allow the Controller Box to be located up to five feet away from the Machining Center. Make sure the Machining Center is placed on a stable, flat surface and leveled properly.

The Controller Box can be placed beside the Machining Center, or mounted on a shelf beneath the Machining Center. Make sure the power switch on the front of the Controller Box is readily accessible. Keep in mind that you may need to check the fuses on the rear panel of the Controller Box. Locate the Controller Box in an area where it will not be exposed to metal chips or cutting fluid.

1. Route the interface and power cables from the Machining Center to the Controller Box as shown in the Interconnection diagram (page A-7).

2. Insert the 15-pin plug from the Machining Center into the 15-pin receptacle marked A & B AXES on the rear panel of the Controller Box.

3. Insert the 9-pin plug from the top of the Machining Center into the 9-pin receptacle marked C AXIS on the rear panel of the Controller Box.

4. Insert the AC power plug from the Machining Center into the 120 VAC, three-prong receptacle marked SPINDLE on the rear panel of the Controller Box.

5. Make sure all connectors are secured with screw locks.

Connecting the Machining Center to the Computer

Insert the 9-pin plug from the bottom of the Machining Center into the 9-pin receptacle protruding from the LMC Interface Card in the rear of the computer.

Connecting the Computer to the Controller Box

1. Route the 25-pin cable between the Computer and the Controller Box.

2. Connect the end of the cable marked COMPUTER to the 25-pin Interface Card connector protruding from the LMC Interface Card in the rear of the computer. As mentioned before, make sure you are plugging the cable into the Interface Card connector, not the parallel port.

3. Connect the other end of the cable to the 25-pin connector marked COMPUTER on the rear panel of the Controller Box.

4. Make sure all connectors are secured.
Connecting Power to the Hardware Components

Both the Machining Center and the Controller Box must be plugged into a grounded 120VAC, 60Hz, 15A polarized wall outlet, as shown in the Interconnection Diagram on page A-7. This outlet must be capable of supplying up to 12 amps of power to the Controller Box. International users connect to a grounded 220VAC, 50Hz, 8A polarized outlet.

Locate the loose power cord that came with the Machining Center; this is the power cord for the Controller Box. Insert the receptacle end of this cord into the 120VAC three-prong connector on the back of the Controller Box. Insert the plug end of this cord into a grounded, three-hole, 120VAC, 60Hz wall outlet.

Optional Connections

If you have purchased the optional Air Vise, plug the power cord from the solenoid valve on the vise into the receptacle end of the accessory port adapter cable. Plug the other end of the accessory port adapter cable into the receptacle labelled ACC 2 on the rear panel of the Controller Box.

You can attach another 120VAC accessory to your machine. Plug the accessory’s power cord into the receptacle end of another accessory port adapter cable. Insert the plug end of the cable into the receptacle labelled ACC 1 on the rear of the Controller Box; the current draw for such accessories, however, is limited to 3 amps.

A 9-pin male connector (labeled TTL I/O) is provided on the rear panel of the Controller Box for interfacing to an I/O device such as a robot. See Reference Guide: Section L of this manual for details on interfacing with robots.

Note: Remove the protective cap from the plug end of the Accessory Port Adapter Cable before inserting it into the accessory connector on the Controller Box.

To connect an accessory to the Controller Box use the Accessory Port Adapter Cable.
Computer System Requirements

The Control Program runs on a 586 /120MHz personal computer. The computer must have:

- Windows 95 or Windows NT 3.5 or higher. (Windows NT users: see the readme file for the latest information regarding available accessories.)
- 16MB RAM minimum for Windows 95 (24MB is recommended for best performance). 24MB RAM minimum for Windows NT.
- A 3.5 in floppy drive.
- A hard drive with at least 5MB of available space.
- A full length ISA bus slot to install the interface card.
- A VGA graphics controller and monitor.
- A Microsoft-compatible mouse.
Software Installation

The proLIGHT Control Program is shipped on two 3.5", 1.4 MB disks. The control program must be installed on a hard drive running either Windows 95, or Windows NT version 3.5 or higher. You must have at least 5 MB of free space on your hard drive to perform this installation. (See previous page for system requirements.)

Installing the Control Program

The proLIGHT Control Program must be installed on the hard drive on your computer. The following instructions assume that your hard drive is drive C, and your floppy drive is drive A.

1. Turn on the computer. Wait for it to go through its internal checks and for it to complete the start up process.

2. When your Windows desktop appears, insert the proLIGHT disk in the computer floppy drive.

3. Using the Windows Explorer, (Start Menu>Programs>Windows Explorer) open the floppy drive. Note: If you are installing on Windows NT, use either the File Manager to access the floppy drive, or select "Run" from the Program Manager.

4. Double click on Setup.EXE to start the installation.

5. The Welcome screen appears warning you to exit all other running programs. If no other programs are running, click Next.

6. The next screen is the destination directory for the WPLM 1000 program. If you would like it put somewhere other than the default, click on Browse. Otherwise, click Next.

7. A window showing the progress of the installation will appear, and when ready, will prompt you to install the second disk. After the installation is complete, a message will appear asking if you would like to view the Readme file. It is suggested that you do view this file. It contains important information about the software and the machine that may not be included in the manual.

8. After reading the Readme file, remove the disk from the floppy drive. You may run the WPLM 1000 program by double clicking the program icon.
Uninstalling the Control Program

In the event you need to remove the WPLM1000 program from your hard drive, there is an uninstall program included on the Software disks. This uninstall program was copied onto your hard drive when you installed the WPLM 1000 program.

To uninstall the WPLM 1000 software, just double click the Uninstall icon in the WPLM 1000 folder. A message will appear asking if you are sure you want to remove the program and all its files. Click on Yes to uninstall, or Cancel to exit the Uninstall program.

The SETUP Program

The WPLM 1000 software automatically sets most variables for you. You will need to run the Setup program if your machine is equipped with an Automatic Tool Changer, in order to enable and configure the communication port between the ATC and the controller.

If you need to access the Setup Program, see the Reference Guide: Section E in this manual.
Technical Support

Should you require technical assistance, you should contact your local Light Machines dealer. If you are unable to resolve your problem through your local dealer, technical support is available by phone, fax or email from 8:15 A.M. to 5:00 P.M. EST. Technical information is also available on our World Wide Web Site (see below).

Before Calling

Make sure you have the following information gathered before contacting our Technical Support group.

- The product serial number.
- The name of the owner of the product.
- The specifications of your computer (e.g. hard drive size, clock speed, etc.).
- Notes on any Control Program error messages.

When you call, make sure you have access to both your machining center and your computer. This will allow our technical support representatives to walk through the problem with you. Our technical support numbers are:

<table>
<thead>
<tr>
<th>Location</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>U. S.</td>
<td>(800) 221-2763</td>
</tr>
<tr>
<td>Canada</td>
<td>(800) 637-4829</td>
</tr>
<tr>
<td>Fax</td>
<td>(603) 625-2137</td>
</tr>
<tr>
<td>Email</td>
<td><a href="mailto:support@lmcorp.com">support@lmcorp.com</a></td>
</tr>
<tr>
<td>WWW Site</td>
<td><a href="http://www.lmcorp.com/lmcorp">http://www.lmcorp.com/lmcorp</a></td>
</tr>
</tbody>
</table>

Warranty

Light Machines’ products (excluding software) carry a one-year limited warranty from date of purchase. Defective products may be returned for repair or replacement according to the conditions outlined in the Terms and Conditions of Sale agreement. If you need to return a product, call Light Machines and a Technical Support representative will issue you a Return Materials Authorization number (RMA). You must write the RMA and your return address on the outside of the product carton or crate. Failure to do so can result in a delay in the return of your product.
proLIGHT 1000 System Hardware

An Introduction to the proLIGHT Machining Center

Options

Maintaining the Machining Center

Maintaining the Controller Box

Maintaining the PC in a Shop Environment
An Introduction to the proLIGHT Machining Center

The proLIGHT Machining Center is a three-axis tabletop milling machine which you can run directly from your personal computer. The proLIGHT Control Program, which you load onto your computer, accepts standard EIA RS-274D G&M codes that CNC machine tools recognize. You’ll find a comprehensive list of options and accessories for the proLIGHT Machining Center on the last page of this section.

Features

Some of the proLIGHT Machining Center’s most notable features include:

- A one horsepower permanent magnet spindle motor
- An R8 industry-standard spindle taper
- Computer controlled spindle speeds from 200 to 5,000 RPM (500 to 10,000 RPM optional)
- Rapid traverse rates up to 50 ipm on all axes
- EIA RS-274D standard G&M code programming
- Multiple tool programming
- Feed rate and spindle speed override functions
- A built-in full-screen NC program editor
- An on-line help utility
- Simultaneous or simulated, solid or centerline graphic verification
The proLIGHT Machining Center Components

There are, of course, more components on the Machining Center than those shown here, but, to begin, you need only be concerned with the depicted major components.

The Main Machine Components

The Safety Shield encloses the milling area to help protect the operator from flying chips. A magnetic Shield Interlock Switch prevents the machine from operating with the shield open.

The X, Y and Z motion of the machine is performed by Stepper Drive Motors on each axis. There are also Limit Switches (beneath the way covers, next to the drive motor on each axis) to prevent the machine from traveling beyond its limits on each axis.

The Spindle Head supports a 1hp DC permanent magnet Spindle Motor.
The Front Panel Components

The Front Panel provides the operating controls shown here.

You can’t miss the most important control on the machine; the Emergency Stop button. When pressed, this bright red palm button halts machine operation immediately. To resume operation, the button must be pulled back out. It’s important that this button be pressed before performing any manual operations, like changing the stock or the tooling.

The Spindle Speed knob is used to establish the spindle speed when the system is in Manual mode. The minimum and maximum positions on the switch are equivalent to approximately 500 (min) to 5,000 (max) RPM.

Select a Spindle Speed mode with the Manual/CNC mode switch. The CNC setting on this switch gives spindle control to the computer. There must be an S code, or codes, in the NC program to regulate the spindle speed when using the CNC setting.
The Controller Box

The Controller Box houses the power- and interface-related controls for the machine. The power switch and keylock switch are on the front panel of the box. The Key Lock switch keeps unauthorized persons from turning on the machine. Once the Key Lock is in the unlocked position, the Power switch can be turned on. The Power switch lights up when power is turned on.

The rear panel houses the power and interface connectors and the fuses. The machine has five fuses for main power, the spindle, the stepper motors, and the two accessory outlets (labeled ACC 1 and ACC 2). The values for these fuses are clearly printed next to the fuse receptacles. Do not use fuses with amperages other than those shown on the machine.

The interface connectors are used to interface the Controller Box with the Machining Center and your computer. Cables are provided in the Accessory Kit for this purpose. Refer to the User’s Guide: Section A for correct installation procedures.

The Accessory Kit

The Accessory Kit that comes with the Machining Center contains all the tools and hardware necessary for installing and maintaining the Machining Center. It also contains a collet and tools to get you started; other tool holding devices and tools are available as options.
Options

Some hardware options available for the proLIGHT Machining Center are: a Low Profile Clamping Kit, a Vacuum System, an Air Vise Robotic Interface, Four Station Automatic Tool Changer, and Quick Change Tooling.

Low Profile Clamping Kit Installation

The Low Profile Clamping Kit Option maximizes the possible edge machining area by securing a workpiece close to its base; it allows you to mill closer to the edges of the workpiece without impeding the cutting tool motion.

The Low Profile Clamping Kit offers more versatility than a standard vise, however, due to its extremely shallow profile, it has a somewhat lower holding force; therefore, the Low Profile Clamping Kit is most appropriate for soft materials such as machinable wax and plastics.

Vacuum System Installation

The Vacuum System Option uses a quiet vacuum with a hose and nozzle attachment, mounted directly to the spindle head, to remove cutting debris automatically from the workpiece.

Air Vise Robotic Interface Installation

The Air Vise Robotic Interface Option is a pneumatic vise, which is actuated by air pressure regulated through a solenoid valve. When a flow of air is introduced to the vise, the jaws close securely against the workpiece, thus clamping the workpiece in place. When the air flow is interrupted, the spring-loaded jaws of the vise open. The vise is normally closed; therefore, in the event of a power interruption, the jaws close to ensure that the workpiece remains secured. The Air Vise option is generally used for robotic integration.

Automatic Tool Changer

A four-station Automatic Tool Changer (ATC) is available for the proLIGHT 1000. The ATC makes multiple tool programming an easy operation. Tool changes are written into the NC program and executed automatically during machining.
Quick Change Tooling Installation

Installing the Quick Change Tooling Option on the Machining Center is a three-step process; 1) installing the tool body in the machine spindle, 2) attaching the cutting tool to the tool holder, and 3) mounting the tool holder to the tool body.

Installing Quick Change Tooling Model ACC-5141

Refer to the drawing below for the location of parts referenced in the following steps.

Installing and Removing the Tool Body

To install the tool body into the spindle:

1. Insert the draw bolt and washer (from the Machining Center Accessory Kit) into the top opening of the spindle taper.
2. Insert the tool body into the bottom opening of the spindle until it makes contact with the spindle taper.
3. Insert the spindle locking pin (from the Accessory Kit) into the opening on the side of the spindle to keep it from rotating.

CAUTION

End mills and other cutters are very sharp. Use proper protection to avoid severe cuts when handling the tools.
4. Screw the draw bolt into the tool body until secure.
5. Remove the spindle locking pin.

To remove the tool body from the spindle:

1. Insert the spindle locking pin into the opening on the side of the spindle.
2. Loosen the draw bolt approximately two turns.
3. Use a mallet (preferably brass) to hit the top of the draw bolt to release it from the spindle taper.
4. While holding the tool body in place, loosen the draw bolt completely and allow the tool body to drop into your hand.
5. Remove the spindle locking pin.

**Attaching the Cutting Tool to the Tool Holder**

1. Insert the tool into the bottom opening of the tool holder.
2. Tighten the set screw on the side of the tool holder while holding the tool in place. Make sure the set screw is pressing against the flat of the tool.

**Installing and Removing the Tool Holder**

To mount the tool holder to the tool body:

1. Insert the spindle locking pin (from the Accessory Kit) into the opening on the side of the spindle to keep it from rotating.
2. Screw the collar all the way onto the tool body.
3. Now unscrew the collar approximately 1-1/2 turns.
4. Press the tool holder up into the tool body until it seats into place (This occurs when the two indents on the top of the tool holder align with the locking pins inside the tool body.)
5. Tighten the collar just finger-tight. *Do not overtighten!*
6. Remove the spindle locking pin.

To remove the tool holder from the tool body:

1. Insert the spindle locking pin (from the Accessory Kit) into the opening on the side of the spindle to keep it from rotating.
2. Unscrew the collar approximately 1-1/2 turns. Be prepared to catch the tool holder when it drops out.
3. Remove the spindle locking pin.
Using the Tool Height Offset Sensor

A tool height offset sensor is included with every Quick Change Tooling unit. This sensor helps to establish a constant reference point for setting tool offsets for multiple tools. You can use these steps to establish a reference point and offsets, or you may use the Tool Setup Wizard in the Tools Menu.

The battery-powered sensor uses the machine’s frame to provide an electrical circuit. When a tool contacts the sensor the circuit closes, energizing the sensor’s LED indicators. You must place the sensor on a conductive surface, such as the cross slide, for this to take place.

To establish a reference point:

1. Install a tool into the spindle.
2. From the Tools Menu, choose Select Tool. If the tool is not already defined in the pull down menu, see page D-8 in Section D to define the tool.
3. Choose the tool you are using, then click Select Tool.
4. Place the sensor on the cross slide or other conductive surface.
5. Using the Jog Control Panel, jog tool #1 to the tip of the sensor until the lights come on.
6. Select Set Position from the Setup Menu, set the Z axis value to zero, and click OK.

To establish offsets:

1. Install tool #2 in the Quick Change Tooling unit.
2. From the Tools Menu, choose Select Tool. If the tool is not already defined in the pull down menu, see page D-8 in Section D to define the tool.
3. Choose the tool you are using, then click Select Tool.
4. Jog tool #2 to the tip of the sensor until the lights come on.
5. Select Setup, and then Offsets from the pull down menu.
6. Choose the correct tool (the description that matches the tool you installed) from the list, and click on the Current Z button at the bottom of the window. Select OK to save the value.
7. Repeat this process for each additional tool.
Maintaining the Machining Center

Performing preventative maintenance on your proLIGHT 1000 Machining Center ensures a longer, trouble-free life for the machine. We provide instructions for preventative maintenance in the following paragraphs.

Ballscrews

The proLIGHT Machining Center uses pre-loaded ballscrews on all three axes. The screws are lubricated at the factory with a special long-life, waterproof ballscrew lubricant. This lubricant should last for at least 200-250 hours of machine use. After 200 hours, you can apply more lubricant to the screws in a thin film over the length of the screw. The ballscrew lubricant (part number 39-0000-0007) is available from Light Machines Corporation.

To gain access to the ballscrews, jog the cross slide and spindle to the extreme negative end of travel on all axes just before the limits are tripped. Remove the bellows cover by removing the two button head cap screws from the bracket holding the bellows at one end. Use a small brush to apply grease sparingly but evenly along the entire length of the ballscrew.
The Saddle

The saddle engages the linear rods that are attached to the base of the machining center. A ball screw moves the saddle along the Y axis. The linear rods running through the top of the saddle engage the cross slide. A ball screw moves the cross slide along the X axis. The oil ports for the X axis and Y axis linear rods are located on the saddle.

Linear Slides

The linear slides on the proLIGHT consist of linear rods and linear bearings. It is very important that a thin film of lubricant be maintained on the surface of the linear rods to minimize wear. The linear rods will wear very quickly with no lubrication.

Lubrication

We provided a small oil can with your Machining Center. Use 10W engine oil for lubricating the linear rods.

There are thick oil-impregnated felt pads between the bearings in the saddle which keep a thin film of oil on the linear rods. Each rod (there are six) can be lubricated through its own oil port which is located on the saddle for the X and Y axes, and on the spindle head for the Z axis.

Lubricate the rods every 30 days or 100 hours of use, whichever comes first. When applying oil to the oil ports, pull the trigger on the oil gun very slowly to allow the oil to be soaked up by the felt.
Adjustment

You can adjust the linear bearings to remove any play in the saddle or spindle. The bearings are factory-adjusted and should not require adjustment for at least 250 hours of use. Be very careful not to overtighten the bearings. Overtightening can cause overworking and overheating of the motor, and excessive wear to the rods, bearings and ball screws. To adjust the linear bearings, follow the steps below.

**WARNING**
Always unplug the machine before making adjustments.

1. Jog to the extreme positive end of motion on the axis you are adjusting. Stop just before the limit switch trips. Shut off power to the system. Unplug the machine.

2. Remove part of the motor cover for the axis you are adjusting. Loosen the screws but do not remove the portion of the cover that has the wires coming out of it. Do not remove the whole cover at once or you may damage the wiring.

3. Loosen all eight recessed allen setscrews on the axis you are adjusting. They are located on the four sides of the saddle for the X and Y axes, and on the sides of the spindle for the Z axis.

4. Tighten the two setscrews for each bearing while checking the force it takes to turn the ball screw. Tighten the setscrews (applying approximately 3-8 in/lb of torque) until the force it takes to turn the ball screw pulley increases when turning it by hand. (If you need to use excessive force to turn the lead screw, you have adjusted the bearing too tightly.) Then back the setscrews off by 1/8-turn. Repeat this procedure for all four bushings on each axis.

5. Replace the motor cover.
Spindle

Two Piece Spindle Head

Light Machines ships the proLIGHT Machining Center with a factory-aligned two piece Spindle Head. You should not attempt to align the Spindle Head without first contacting Light Machines.

Spindle Motor

The spindle motor on the proLIGHT Machining Center is a 1hp DC permanent magnet motor. The wearing parts on the motor are the ball bearings on the motor shaft and the brushes. The brushes, although replaceable, have a long life-span. The ball bearings are sealed, lifetime-lubricated bearings that do not require special maintenance.

Checking for Spindle Shaft Play

The spindle shaft is preloaded against sealed ball bearings that do not require lubrication or user maintenance. You should, however, check the spindle shaft for both radial play (side to side) and axial play (up and down). If the spindle shaft starts to develop play (or begins to make unusual noises while in operation), contact Light Machines (800-221-2763).

To check for play, grip the spindle shaft and push and pull it in each direction along both axes. The spindle shaft should be firm against your pressure.
Spindle Fuse

There is a 15-amp fuse mounted on the bottom left side of the back (looking from the rear of the machine). If the spindle does not work, check this fuse as well as the spindle fuse on the Controller Box to see if either has blown. If you replace the fuses and the spindle still doesn’t work, call Light Machines’ Technical Support Department.

Belts

Spindle Belt

The spindle motor drives the spindle shaft with a timing belt. If the belt becomes loose, it will wear out quickly. The belt squealing at slow speeds is an indication of a loose or worn belt. Also, if the belt is loose, you can feel backlash between the spindle motor shaft and the spindle shaft. To check for backlash, rotate the spindle shaft back and forth slightly and observe the fan inside the motor. Make sure the fan rotates as soon as you reverse the direction of the spindle shaft. If there is backlash, follow the directions below.

WARNING

Always unplug the machine before making adjustments.

To adjust the spindle timing belt:
1. Make sure all power to the system is shut off. Unplug the machine.
2. Remove the four socket head cap screws from the spindle top cover.
3. Pull the spindle motor up and slide it forward. Remove the spindle motor and cover along with the drive belt. Check the belt for wear such as frayed edges or missing teeth. Replace the belt if necessary. Replacement belts are available from Light Machines.
4. Slide the spindle motor back on the top cover until you have removed all play from the belt.
5. Remount the spindle motor and top cover assembly on the spindle. Make sure you properly put the belt over the two pulleys as you lower the assembly onto the spindle. Fasten all four allen-head screws. If you have to push the spindle top cover backwards with some force in order to get the top cover screws to fit, then you have adjusted the belt too tightly.
6. Turn the spindle shaft to make sure the spindle runs freely by hand and the spindle motor turns. If everything appears all right, try turning on the spindle motor and slowly turning up the spindle speed. Check for excessive vibration.

**Axis Drive Belts**

The axis drive belts are located between the motors and ballscrews on each axis. Normally, they should not need adjustment, but should be checked every 250 hours.

**Checking the Y Axis Drive Belt**

1. Remove the seven button head cap screws on the motor box cover.

2. Lift the cover and rotate it 90 degrees. Be aware of the 2 #10 .060” thickness washers under the cover. These washers are used as spacers in the motor box. Be sure not to lose these washers and remember to re-install them when you are finished checking (and adjusting) the belt.

3. Apply approximately three pounds of force on the center point of the belt. It should deflect no more than 1/8-inch (3mm).
Adjusting the Y Axis Drive Belt
1. Remove the two button head cap screws on the bottom of the motor box.
2. Gently move the box up and down while pulling back until the box comes off the motor mount.
3. Slide the motor box to the left and down until you have access to the four screws holding the motor onto the motor mount.
4. Loosen the four screws.
5. Slide the motor to increase tension on the belt and retighten the screws.
6. Check the deflection again.

Checking the X Axis Drive Belt
1. Remove the two button head cap screws from the top of the motor box and the seven button head cap screws from the bottom of the motor box cover.
2. Pull the motor box back approximately one inch until it comes off the motor mount. Lift the left side of the motor box up and over the motor to expose the drive belt.
3. Apply approximately three pounds of force on the center point of the belt. It should deflect no more than 1/8-inch (3mm).

Adjusting the X Axis Drive Belt
1. Loosen the four screws holding the motor onto the motor mount.
2. Slide the motor to increase tension on the belt and retighten the screws.
3. Check the deflection again.
Checking the Z Axis Drive Belt

1. Remove the two button head cap screws on the front of the motor box and five of the seven button head cap screws on the back. Loosen but leave in place the two bottom screws on the back of the motor box cover.

2. Gently move the box front and back while pulling it up until it is completely off of the motor mount.

Adjusting the Z Axis Drive Belt

1. Loosen the four screws holding the motor onto the motor mount.

2. Slide the motor to increase tension on the belt and retighten the screws.

3. Check the deflection again.
# proLIGHT Machining Center Routine Maintenance Schedule

## Maintenance Period

<table>
<thead>
<tr>
<th>Maintenance Action</th>
<th>After Every Use</th>
<th>Every 50 Hours or every 2 months</th>
<th>After 100 Hours</th>
<th>After 250 Hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lubricate Ball Screws</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lubricate Linear Rod Pads</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Adjust Linear Bushings</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Check Spindle Shaft for Play</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Check Spindle Belt for Play</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Clean Chips Out of Machine</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coat Exposed Surfaces with Light Oil</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Check Limit Switches and Wiring</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>
Maintaining the Controller Box

The proLIGHT Controller Box requires no special maintenance, except that it should be kept in a dust-free environment.

If you are having problems with the AC Outlet function, or if the stepper motors are not running, you may need to change a fuse in the Controller Box. A blown fuse can occur if you overload one of the AC outlets. To change a fuse:

1. Turn the power off, and disconnect the power cords to the Controller Box and the Machining Center.

2. The fuse holders are externally mounted on the rear panel of the Controller Box and are labelled to correspond with each AC outlet. Locate the correct fuse holder.

3. Remove the fuse by turning the fuse cap counterclockwise while pressing slightly inward. The fuse is removed with the cap.

WARNING

Changing Fuses With The AC Power Connected Can Cause Electric Shock!

Always disconnect the main AC power before servicing the Controller Box or Machining Center.
4. Visually inspect the fuse. If the fuse element appears broken, it is probably blown. You can also use an ohm meter to check continuity across the two ends of each fuse.

5. Replace the blown fuse with a standard slow-blow fuse of the appropriate rating. Three-amp (3A) fuses are used for the motor drives, ACC 1, and ACC 2. An five-amp (5A) fuse is used for the spindle, and a twelve-amp (12A) fuse is used for main AC power.

6. Replace the fuse holder cap by pushing inward and turning clockwise.

7. Reconnect power.

---

**Maintaining the PC in a Shop Environment**

There are a few general guidelines for maintaining your personal computer and software in a shop environment. See your owner’s manual for maintenance procedures that are specific to your computer.

---

**Caring for the Computer**

Follow these general rules for computer care.

- Keep the computer and peripherals (mouse, keyboard, external drive, printer) out of direct sunlight and away from sources of heat and in a relatively clean environment (i.e., not right next to the foundry room).

- Keep liquids (soda, coffee, cutting fluid, grease) away from the computer and peripherals.

- Keep oil, grease, metal chips and excess dust away from the computer, keyboard and floppy disks. You should consider erecting a clear plastic shield between the computer and the mill to keep chips off the computer.

- Use grounded, three-prong outlets for the computer and peripherals. Take precautions against current overload. A line-surge suppression unit can be purchased at your local computer store to help alleviate this problem.

- Don’t block the vent holes in the computer or drives; they are required for air circulation.
Caring for Floppy Disks

Floppy disks are simple to use but require a few precautions to maintain their integrity.

- Don’t touch the magnetic disk part of the disk (the shiny, record-like part inside the disk jacket). Dust or grease from your hand can ruin any part of the disk that you touch and can possibly destroy the entire disk.
- Keep disks in a disk box or special disk container instead of spreading them out on your work space.
- Handle disks gently, don’t bend or crease them.
- Don’t write on disk labels with a ball point pen. If you must write on the label, always write very lightly with a felt tip pen.
- Keep disks in a clean, cool environment away from excess amounts of dust, heat, or sun.
- Beware of getting machining fluids on the disks. If you spill a liquid or cutting fluid on a disk, it is 99 percent certain that the disk and all the data on it can never be used again.
- Keep disks away from all magnetic sources including telephones, high-voltage power sources and mill motors.
- Make back-up copies of all NC program disks each time you update them.
- Print copies of all NC programs in case of disk failure or lost disks.

No matter how cautious you are, disks will go bad; they develop bad blocks (unreadable surfaces). If this happens while you are editing a program, the program will be lost. The solution to this disaster is simple—make back-up copies.
Getting to know the Control Program

Starting the Control Program

If You Need Help...

Exploring the Control Program Screen
Starting the Control Program

To start the proLIGHT 1000 Control Program:

From **Windows 95** select Start from the Task Bar, then select “Programs” and the WPLM1000 folder. In that folder, select WPLM 1000 Windows CNC Control. You can also create a Windows 95 shortcut by opening the WPLM1000 directory and dragging WPLM1000.EXE onto your desktop.

From **Windows NT** double-click the WPLM1000 icon in the WPLM1000 Group.

You should have the controller box connected and powered up before starting the control software, unless you are going to be working in the Simulate Mode.

Starting the Control Program in Simulate Mode

If this dialog box appears when you start the Control Program, the interface card that came with your machining center has not been properly installed.

If you do not have the interface card installed you can still edit and verify NC part programs without the machining center by running the Control Program in Simulate Mode.

To start the Control Program in Simulate Mode, select Cancel.

When the next dialog box appears, select Simulate.
If You Need Help...

You can access online help by using the commands under the Help Menu, or by pressing F1.

For information on many of the functions and screens in the WPLM1000 software, you can also see Reference Guide: Section E, Control Program Reference.
Exploring the Control Program Screen

You should become familiar with the main parts of the Control Program screen before you begin using the Control Program to run NC part programs. The following are the default components that make up the screen.

Menu Bar

The Menu Bar contains all of the menu commands for the Control Program. For an explanation of each menu and its relative commands, see the Reference Guide: Section E.

Standard Tool Bar

The Standard Tool Bar provides easy access to the Control Programs most often used commands.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New File</td>
<td>Begin a new NC part program file.</td>
</tr>
<tr>
<td>Open File</td>
<td>Open an existing NC part program file.</td>
</tr>
<tr>
<td>Save File</td>
<td>Save current NC part program file to disk or drive.</td>
</tr>
<tr>
<td>Cut NC Code</td>
<td>Cut selected code from program and place on clipboard.</td>
</tr>
<tr>
<td>Copy NC Code</td>
<td>Copy selected code to clipboard.</td>
</tr>
<tr>
<td>Paste NC Code</td>
<td>Paste code from clipboard to cursor position in program.</td>
</tr>
<tr>
<td>Print File</td>
<td>Send program to printer.</td>
</tr>
<tr>
<td>Help</td>
<td>Access Help program.</td>
</tr>
<tr>
<td>Context Help</td>
<td>Obtain help on selected object.</td>
</tr>
<tr>
<td>3-D Verification</td>
<td>Access 3-D tool path verification.</td>
</tr>
<tr>
<td>Run (green)</td>
<td>Run the current NC part program.</td>
</tr>
<tr>
<td>Pause (yellow)</td>
<td>Pause the currently running NC part program.</td>
</tr>
<tr>
<td>Stop (red)</td>
<td>Halt the currently running NC part program.</td>
</tr>
</tbody>
</table>
**Outputs Tool Bar**

The Outputs Tool Bar is an active tool bar. It provides switches to supply power to the spindle, and the Accessory outlets on the Controller Box. Switches for Robotic outputs 1 and 2 are also provided. Power is on when the buttons are depressed.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spindle Output</td>
<td>Provides power to the spindle.</td>
</tr>
<tr>
<td>Acc1</td>
<td>Provides power to the Acc1 outlet on the Controller Box</td>
</tr>
<tr>
<td>Acc2</td>
<td>Provides power to the Acc2 outlet on the Controller Box</td>
</tr>
<tr>
<td>Robot 1 Output</td>
<td>Provides power to the TTL I/O connector on the Controller Box for Robotic Output 1 (see Reference Guide: Section L).</td>
</tr>
<tr>
<td>Robot 2 Output</td>
<td>Provides power to the TTL I/O connector on the Controller Box for Robotic Output 2 (see Reference Guide: Section L).</td>
</tr>
</tbody>
</table>
The Inputs Tool Bar is an inactive tool bar. It provides information only on the state of the Emergency Stop, the Safety Shield, and the positive and negative limit switches. Indicators for Robotic inputs 1 and 2 are also provided. An input is active (on) when the button is depressed.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-Stop</td>
<td>Indicates when the Emergency Stop is pressed.</td>
</tr>
<tr>
<td>Safety Shield</td>
<td>Indicates when the Safety Shield is open.</td>
</tr>
<tr>
<td>Positive Limit</td>
<td>Indicates when the Positive Limit switch is on.</td>
</tr>
<tr>
<td>Negative Limit</td>
<td>Indicates when the Negative Limit switch is on.</td>
</tr>
<tr>
<td>Robot 1 Input</td>
<td>Indicates when Robotic Input 1 (see Reference Guide: Section L) is on.</td>
</tr>
<tr>
<td>Robot 2 Input</td>
<td>Indicates when Robotic Input 2 (see Reference Guide: Section L) is on.</td>
</tr>
</tbody>
</table>
Whenever you open an NC part program file it appears in its own edit window. These windows have the same characteristics as other Windows 95 windows (scroll bars, minimize/maximize buttons, etc.). You can have multiple edit windows open at a time. The number of which depends on available memory.

By default, each new window is locked; you can not edit a locked window. To unlock the window, use the Lock command under the Edit Menu.

Here is what the edit window for the NC part program MILLONE.NC looks like.
Status Bar

The left side of the Status Bar provides information about the currently selected function. The right side of the status bar provides information on:

- Whether or not the machining center is homed
- Whether or not the Caps Lock key is activated
- Whether or not the Num Lock key is activated
- The line the cursor is on, and the total lines in the program
- Whether or not the current NC part program is locked
- Whether or not the current NC file has been modified
- The current time according to your computer

When the indicator is dimmed, the function is in the off condition.
**Tips:**

- If you wish, you can move the Position Readout to another part of the screen. Hold the Control key down, then click and drag the Position Readout. Once you release the Control key and the mouse key, the Position Readout will stay in the new position. If you move it back to the docking area, it will automatically dock.

- If you want it to remain floating, press the right mouse button in the window, and uncheck “dockable.” The window can only be resized when it is undockable.

- You can double-click on the Position Readout to bring up the Go To Position dialog box.

- For more information on moving and resizing windows, see the Control Program Reference section of this manual.

**Position Readout**

The Position Readout provides information on the current X, Y and Z coordinates of the tool position. The units of measure in the Position Readout are determined by the Units command under the Setup Menu.

<table>
<thead>
<tr>
<th>X</th>
<th>0.0000 in</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y</td>
<td>0.0000 in</td>
</tr>
<tr>
<td>Z</td>
<td>0.1000 in</td>
</tr>
</tbody>
</table>

**Machine Info Panel**

The Machine Info Panel provides information on the current tool, tool diameter, feed rate, spindle speed, number of passes made, coordinate system in use, as well as the current block and total number of blocks in the program.

<table>
<thead>
<tr>
<th>Tool</th>
<th>10</th>
<th></th>
<th>Diam</th>
<th>1.5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed</td>
<td>1.00</td>
<td>Spindle</td>
<td>1500.0</td>
<td></td>
</tr>
<tr>
<td>Pass</td>
<td>000</td>
<td>Coord</td>
<td>Work</td>
<td></td>
</tr>
<tr>
<td>Block</td>
<td>1</td>
<td>of</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

When a part program is running, the Info Panel also provides dynamic display of the elapsed machining time and highlights the block of code that is currently being executed.
Verify Window

The Verify Window displays a simulation of your part program when you select the Verify command from the Program Menu, or when you click the Verify Program button on the Standard Tool Bar.

Tool path verification can be performed in centerline view or solid view. Centerline view is based on the centerline of the tool. Solid view is a solid representation of the tool and workpiece.

Tips:

• If you wish, you can move the Verify Window to another part of the screen. Hold the Control key down, then click and drag the Verify Window. Once you release the Control key and the mouse key, the Verify Window will stay in the new position. If you move it back to the docking area, it will automatically dock.

• If you want it to remain floating, press the right mouse button in the window, and uncheck “dockable.” The window can only be resized when it is undockable.

• You can double-click on the Verify Window to bring up the Verify Setup dialog box.

• For more information on moving and resizing windows, see the Control Program Reference section of this manual.
Tutorial: Machining a Sample Part

Safely Running the Machining Center

Running a Sample NC Program
Safely Running the Machining Center

Like any other power tool, the proLIGHT Machining Center is a potentially dangerous machine if operated in a careless manner. The importance of safely operating the proLIGHT Machining Center, including the need for protection against personal injury and the prevention of damage to the equipment, can not be stressed enough. You will find more information on safe machining in the Reference Guide: Section J.

Safety Rules

The following safety rules should be practiced by all operators of the proLIGHT 1000 Machining Center.

Remove Adjusting Keys and Wrenches
Make a habit of checking that keys and adjusting wrenches are removed from the Machining Center before operating the machine.

Do Not Force a Tool
Select the feed rate and depth of cut best suited to the design, construction and purpose of the cutting tool. It is always better to take too light a cut than too heavy a cut.

Use the Right Tool
Select the type of cutting tool best suited to the milling operation. Don’t force a tool or attachment to do a job it wasn’t designed to do.

Secure the Workpiece
Be certain that you have firmly secured the workpiece on the cross slide and the cutting tool in the spindle before turning on the spindle motor.

Turn the Spindle By Hand Before Starting
Manually turning the spindle allows you to safely determine that the tool will not hit the Machining Center bed, cross slide, or stock on start up.

Tighten All Holding, Locking and Driving Devices
Tighten the work holders and tool holders. Do not over-tighten these devices. Over-tightening may damage threads or warp parts, thereby reducing accuracy and effectiveness.
Making Emergency Stops

Before you run the proLIGHT Machining Center for the first time, you should know how to stop the machine when an emergency situation arises. There are a number of ways an emergency stop can be initiated on the Machining Center: by pressing the Emergency Stop button, by simultaneously pressing the Control and Space Bar keys on the computer keyboard, by activating one of the limit switches, or by activating the safety shield interlock switch.

Stopping with the Emergency Stop Button

There is an Emergency Stop button located on the front panel of the Machining Center; it has an oversized red cap. Before power can be applied to the Machining Center, the Emergency Stop button must be pulled fully out from the front panel. The Emergency Stop button disables the spindle even if the computer is turned off.

In the event that an error occurs, such as a tool crashing into the workpiece, you can immediately kill power to the Machining Center by pushing in the Emergency Stop button. Pushing in the Emergency Stop button terminates the part program. Wait until the Machining Center has completely stopped moving before opening the safety shield.

When the tool crash or other error has been cleared and the Emergency Stop button is released (pulled back out), press Enter on the keyboard to close the error dialog box that appeared when the Emergency Stop button was pressed. Edit the part program to remove the cause of the tool crash before running the program again. You may need to reinitialize (reset the point of origin for all axes) the machining center using the Set Position command from the Setup Menu, and you may need to home the machine again.

The Emergency Stop button should be your first target when a critical error occurs. You do not need to use it in situations where safety or reaction time is not an issue. For example, if you start to run a program but notice that the tool is moving towards the wrong corner of the workpiece, use a software stop to halt the program and reset the origin of the workpiece.

Stopping with the Computer Keyboard

The execution of the part program can be interrupted by pressing keys on the computer keyboard. To stop the part program with the keyboard, press the Control key and Space Bar simultaneously. The cutting stops immediately and the cutting tool remains in position.
To restart the program from a keyboard-generated stop, select the Run/Continue command from the Program Menu. In the Start At Line box, enter the number of the last line executed, then click on the Run Program button. (When you stopped the program, the last line executed is displayed on the Machine Info Panel, and the cursor is placed on that line in the file.)

**Stopping with a Limit Switch**

The proLIGHT Machining Center is equipped with limit switches to sense the end of travel on each axis. If the table travel exceeds the end of travel on any axis, a limit switch is activated and shuts down machine operation.

Once a limit switch is activated, the tool must be jogged away from it using the Jog Control keypad (selected from the View Menu).

To move the cross slide away from the limit switch, you must jog it in the opposite direction. Each axis has a positive and a negative limit. If a positive limit is hit, you must jog away from it in a negative direction. If a negative limit is hit, you must jog away from it in a positive direction. If both a positive and a negative limit are hit, you must jog away in a negative direction.

If the cross slide comes close enough to the end of travel on any axis to activate a limit switch, the following procedure must be followed to restore normal operation.

2. Press the appropriate jog key on the jog keypad, to move the cross slide away from the triggered limit switch.
3. Check your initial machine set up to make sure it was performed correctly.

**Stopping with the Safety Shield Interlock Switch**

Opening the safety shield activates a safety interlock switch which interrupts the NC program and stops machine motion. The cutting stops immediately and the cutting tool remains in position. To restart the program, select Run/Continue from the Program Menu to begin the operation again. However, this is not recommended as the proper method of stopping the machine in an emergency situation. Use the Emergency Stop button.
Running a Sample NC Program

When you installed the proLIGHT Control Program an NC part program file, named MILLONE.NC, was copied into the PLM1000 directory along with the other files. This program is meant to machine a 3” x 2” x 1.5” piece of machinable wax. You will be using this file to create your first workpiece on the machining center.

WARNING

Do not attempt to operate the proLIGHT Machining Center without reviewing all of the safety precautions set forth in Reference Guide: Section J.

Open MILLONE.NC

1. Select the Open command from the File Menu, or click on the Open button on the Standard Tool Bar. The Open dialog box appears.

2. Double-click on the filename, or select the filename then select the Open button. The edit window for MILLONE.NC appears.
After loading the NC program, you need to adjust the Verify Settings for the part you are about to machine. To view the Verify Setup dialog box, double click on the Verify window. You may also select the Program Menu and choose Verify from the pull down menu, or Select Verify from the Standard Toolbar and choose Verify Settings. The Verify Setup dialog box appears.

Adjust the View

1. Select View.
2. Select either Solid or Centerline (for a solid representation or a centerline representation of the tool and workpiece).
3. Select Isometric for a three dimensional view of the part.
Adjust the Stock

1. Select the Stock tab.
2. Enter the stock Dimensions for the MILLONE.NC program. The stock dimensions are X=3”, Y=2” and Z=1.5”.
3. Set the Initial Tool Position to X=0, Y=0 and Z=0.5
4. Set the point of Origin to zero on all three axes.
5. Select OK. The dialog box will close, and you should notice a change in the shape of the workpiece in the Verify Window.

The Stock panel allows you to:
- Enter the dimensions of the workpiece
- Set the initial position of the tool
- Set the point of origin for the workpiece
Define the Tool

To machine this part, you will be using an 1/8” HSS end mill. You will be using the parameters for this particular end mill for the tool path verification as well. To define the tool parameters, first add the tool to the tool library, then select the tool for verification.

Add the Tool to the Library

1. Select Setup Library from the Tools Menu. The Setup Tools dialog box appears. There already is a 1/8” end mill defined, but since the purpose of this exercise is to learn to use the program, we will define another one.

2. In the Tool Library scroll box, scroll down to tool 11, which is undefined at this point. Highlight Tool 11 by clicking on it with your mouse.

3. In the Tool Type pull-down list, select End Mill.

4. Enter "End Mill" in the Description box.

5. Enter 0.125 in the Diameter box.

To define a new tool, you first have to select an undefined tool, as we have here, then select a Tool Type.

Note: You can also enter fractions and let the program calculate the decimal equivalent.
6. Click on the Apply button. You have just defined a new tool in the library. From now on, whenever you need an 1/8” HSS end mill it will be there.

7. Click on OK to exit the Tool Library.

Here is the newly defined tool, an 1/8” HSS end mill that has four teeth and a height offset of 1.5 inches. These are the same tool parameters you will use when actually machining the MILLONE.NC part.

---

Select the Tool for Verification

1. Select Tool from the Tools Menu. The Select Tool for Use dialog box appears.

2. Select Tool 11 from the pull-down list.

3. Click on the Select Tool button.

---
Verify MILLONE.NC

Tool path verification allows you to check for programming errors before actually running the part program on the Machining Center.

1. Select Verify from the Program Menu. The Verify Program dialog box appears. The default starting line for the program is Line 1. When verifying a program for the first time, you should begin at the first block.

2. Click on the Verify Program button, then watch the Verify Window. You will see MILLONE.NC executed on the graphic workpiece.
Dry Run the NC Program

Before you run your part program for the first time, you should perform a dry run (run the program with no stock mounted). This will ensure that all the movements of the Machining Center make sense and that the tool is in no danger of striking any fixtures or crashing into the cross slide. Although you should dry run the program with no stock mounted, you should set the point of origin using the workpiece and then remove it.

Begin with the Emergency Stop button pressed in, and the spindle speed turned all the way down. The vise or other work holding device should be mounted to the cross slide and the tool should be mounted in the spindle.

1. Mount the workpiece in the vise.
2. Close the safety shield and pull out the Emergency Stop button.

4. Use the Jog Keypad to jog the tool to top front left corner of the workpiece.
5. Select Set Position from the Setup Menu. The Set Position dialog box appears.
6. Enter zero in the X, Y and Z boxes.
7. Click on OK. The values in the Position Readout all change to zero.

8. Jog the tool up and away from the workpiece, press the Emergency Stop button, open the Safety Shield and remove the workpiece.

<table>
<thead>
<tr>
<th>X</th>
<th>0.0000 in</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y</td>
<td>0.0000 in</td>
</tr>
<tr>
<td>Z</td>
<td>0.0000 in</td>
</tr>
</tbody>
</table>

9. Return the Safety Shield to the closed position and pull out the Emergency Stop button.


11. Select Programs, and choose Run/Continue.

12. The Run Program dialog box appears. Click on the Run Program button.

13. As the part program runs, observe the tool motion in relation to the vise (and eventually the workpiece). Look for signs of a possible tool crash and be prepared to press the Emergency Stop switch on the Machining Center. Edit the program as required. When you are satisfied that the tool motions are correct, you can mount the workpiece.
Mount the Workpiece

1. Using the Jog Keypad, jog the spindle up and out of the way.

2. Before mounting the workpiece, push the Emergency Stop button in.

3. Mount the workpiece in the vise leaving at least 1/8” of the stock above the jaws of the vise. Take care to position the workpiece parallel to the tool bed. To assure that the piece is flat, place parallel bars underneath to space it upwards within the vise before clamping.

4. Pull the Emergency Stop button out.

5. Jog the tool to position the center of the tool tip at the top of the front, left corner of the workpiece. Jog until the tip of the end mill touches the surface of the workpiece.

6. Select the Set Position command from the Setup Menu and enter zero for all three axes. Select the Operator Panel and check that the spindle speed is set to 100%.

The workpiece is now correctly mounted.
Run the Program

Before executing the MILLONE.NC program, check that all safety precautions have been taken. The Machining Center safety shield should be closed, and you should be wearing safety glasses.

If anything goes wrong, immediately press the Emergency Stop button on the Machining Center to stop the operation. A safety checklist has been provided in the Reference Guide: Section J of this guide. Post a copy of this checklist near the machining center and review it before you run any NC program.

To run the program:

1. After reviewing the Safety Checklist, select the Run/Continue command from the Program Menu. The Run Program dialog box appears.

2. Make sure that the Start Line box is set to line 1 of the program.

3. Click on the Run Settings button. The Run Settings dialog box appears.

4. Make any changes desired in the Run Settings dialog box, then select OK.

5. Click on the Run Program button to begin running your program.

6. After the part is machined, press the Emergency Stop button before opening the safety shield and removing the finished part.
Control Program Reference

WPLM Interface
Positioning Screen Components
Message Bar
Windows
Toolbars
Panels
Menu Bar
Selecting Commands
The Setup Program
Working in Simulation Mode
The WPLM1000 Interface

The WPLM1000 interface (the screen) is composed of several components that allow you to create NC part programs and interact with the machining center.

The WPLM1000 interface components include:

- The Message Bar
- Windows
- Toolbars
- Panels
- The Status Bar
- The Menu Bar

Positioning Screen Components

The WPLM1000 interface is easily configured and optimized by opening, closing, re-sizing, and repositioning the screen components.

Positioning Toolbars

You can reposition any of the toolbars (Standard, Inputs, Outputs or ATC Control) simply by dragging them off their docking areas. Once away from the docking area, the toolbar becomes a floating window, which can be treated the same as any other window (E.G. move it, resize it, close it). To move the toolbar, click on the toolbar background (the area behind the buttons) and drag.

Positioning Information Areas

The information areas (Position, Machine Info, Jog Control, Operator Panel) are initially docked on the docking area on the right side of the screen. If these items are moved away from the docking area, they become floating windows. If the floating windows are moved back to the docking area, they dock around the edit area again. You can prevent dockable windows from ever docking, by right-clicking on the window to be changed, and un-checking the Dockable command. When a window is not dockable, it behaves like a standard window, which can be moved, resized, and closed – it will not dock to the docking area.

The Verify window is initially not dockable.
To move an information area (create a floating window):

1. Press the Ctrl key.
2. Click on the information area with the left mouse button.
3. Hold and drag the area off the docking area.
4. Release the Ctrl key.
5. When the floating window is over its new location, release the mouse button. You can move and close the window as you would any other window.

OR

1. Right-click on the window to display its context-sensitive menu.
2. Un-check the Dockable command. This removes the window from its docked location.

To return a floating window to its docking area (the window must be dockable):

1. Click on the title bar of the floating window.
2. Drag the area back to the docking area.
3. Release the mouse button.

---

**Positioning Program Edit Windows**

Program Edit Windows can be moved, resized or closed just like any other window. The only restriction is that the Edit Windows cannot be moved out of the edit area. For instance, you cannot move an Edit Window to a docking area.

---

**Saving the Window Positions**

After arranging the application’s windows on the screen, you can save their positions. Use the Save Settings command on the Help menu to save the window positions (and any other selected items). To restore your saved window positions, or to restore the default window positions (the factory preset positions), use the Restore Settings command on the Help menu.

The Control Program automatically stores the current window positions when you exit the software, and automatically restores them the next time you run it.
Docking and Floating Windows and Toolbars

Windows and Toolbars can behave in two ways; they can be placed in a stationary state, docked, or they can be in a free-floating state, and moveable.

Docked Screen Components

A docked screen component is fixed in place, unlike a floating component which can be placed anywhere on the screen. When a screen component is docked, the window frame and title disappear.

Floating Screen Components

A floating screen component can be moved to any position on the Control Program screen, unlike a docked screen component, which is fixed in place. When a screen component is floating it has a window frame and title.

To select the Docking/Floating state of a toolbar:

- Click on the background area of the toolbar and drag it away to float it.
- Click on the title bar of the toolbar and drag it to the docking area to dock it.

To select the Docking/Floating state of a window:

1. Position the mouse pointer over the window you would like to dock/float.
2. Click the right mouse button.
3. Select Dockable from the drop-down menu.

When the Dockable command is checked, the window can be dragged to a docking area and docked. Dockable windows can not be resized.

When the Dockable command is not checked, the window will float and can not be docked. Floating windows can be resized.
Message Bar

The Message Bar is located directly beneath the Menu Bar. When an NC program is running or being verified, the Message Bar displays the name of the NC file currently being run, or the most recent operator message. When a program is running, the Message Bar also displays control buttons (Go or Stop). When there is no program running, the Message Bar displays the Control Program copyright notice.

Windows

Windows are used to display information. Windows can be docked or they can be floating windows. Windows are activated or hidden using the commands under the View Menu.

The following windows are available:

Program Edit Windows
Verify Window
Machine Info Window
Position Window

Program Edit Windows

When you open an existing NC part program file, or create a new one, the program appears in a program edit window. Program edit windows have all of the features common to other windows, including a title bar which displays the program file name and controls for minimizing, maximizing, and closing the window.

Program edit windows appear in the Edit Area (the large central area) of the screen. The Edit Area is fixed in position; you cannot close it or move it.

When other windows, panels, and toolbars are closed, the space that their docking areas occupy is given to the Edit Area.

When other windows, panels, and toolbars are open, the space that their docking areas occupy is taken from the Edit Area.

The Edit Area can contain multiple program windows. The Windows Menu has several commands for managing program windows. You may select a particular window from a list of all current program windows, identified by file names.
Verify Window

The Verify Window can be opened and closed by selecting the Verify Window command from the View Menu.

The Verify Window displays a simulation of your part program (tool path verification) when you select the Verify command from the Program Menu, or when you click the Verify Program button on the Standard Toolbar.

Tool path verification can be performed in centerline view or solid view. Centerline view is based on the centerline of the tool.

Solid view is a solid representation of the tool and workpiece.

Tips:

- If you wish, you can move the Verify Window to another part of the screen. Hold the Ctrl key down, then click and drag the Verify Window. If you hold the Ctrl key, the window will not dock, so you can place it anywhere on the screen. If you release the Ctrl key, the window will try to dock to the main window, depending on where you drop the window. To prevent the window from ever docking, right-click on the window and un-check the Dockable command.

- Pressing the right mouse key while in the Verify window displays a pop-up menu with Verify-related commands.

- When the Verify Window is floating (not docked) you can resize it just like any other window.

- You can double-click on the Verify Window to bring up the Verify Setup dialog box.

Machine Info Window

The information displayed in the Machine Info Window varies with the particular operation being performed:

When the machine is idle, the Machine Info Window displays information about the current tool number and diameter, feed rate and spindle speed, the number of passes made for the current program, the coordinate system being used, the current block number, and the number of blocks in the current program. (The passes, current block, and total number of blocks refer to the last program verified or run.)

<table>
<thead>
<tr>
<th>Tool</th>
<th>11</th>
<th>TDim</th>
<th>0.125</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed</td>
<td>10.00</td>
<td>Spnle</td>
<td>1500.0</td>
</tr>
<tr>
<td>Pass</td>
<td>001</td>
<td>Coord</td>
<td>Mark</td>
</tr>
<tr>
<td>Block</td>
<td>5</td>
<td>of</td>
<td>20</td>
</tr>
</tbody>
</table>
When a program is running, the Machine Info Window becomes a dynamic display. In addition to updating the previously mentioned information, each line of code (as it is executed) is displayed along with the previous and next lines of code. Also, a clock provides the elapsed run time for the program.

<table>
<thead>
<tr>
<th>Tool</th>
<th>11</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed</td>
<td>10</td>
</tr>
<tr>
<td>Pass</td>
<td>001</td>
</tr>
<tr>
<td>Block</td>
<td>2</td>
</tr>
</tbody>
</table>

Part Time: 00:13
1 N0001 J1 K682. TOOL APPL. FROM STOCK
2 N0008 X417 Y1.333 MOVE TO START POINT
3 N0215 MO100 SPINDLE ON

When a program is being verified, the Machine Info Window displays the current line of code, plus the previous and next lines. The elapsed time is not indicated.

<table>
<thead>
<tr>
<th>Tool</th>
<th>11</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed</td>
<td>10</td>
</tr>
<tr>
<td>Pass</td>
<td>001</td>
</tr>
<tr>
<td>Block</td>
<td>2</td>
</tr>
</tbody>
</table>

19 N0101 MOVE TO START
20 N0102 END OF PROGRAM

The Position Window

This is a dynamic display. When a program is running or being verified, the current position of the tool is indicated here.

If you double-click on this window, the Goto Position dialog box appears, allowing you to move the tool to specific coordinates.

| X | 0.0000 in |
| Y | 0.0000 in |
| Z | 0.1000 in |

Note: When running the control program in Simulate mode, the Goto command will not move the machine to the specified coordinates. It will simulate movement, showing the tool moving to those coordinates in the Position Window and the Verify Window.
**Tool Bars**

Toolbars carry buttons that correspond to frequently used menu commands. You can click on these buttons to quickly select the associated menu command. Toolbars also generate Outputs and display the state of Inputs. Toolbars can be placed anywhere on your screen, and can be hidden if you do not use them often or want the additional space for program windows. Toolbars are revealed and hidden using the Toolbars command under the View Menu.

**The toolbars include:**

- Standard Toolbar
- Outputs Toolbar
- Inputs Toolbar
- ATC Control Toolbar

**Standard Toolbar**

The Standard Toolbar provides quick-access buttons for the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>New File</td>
<td>Create a new program edit window</td>
</tr>
<tr>
<td>Open File</td>
<td>Open an existing NC program file</td>
</tr>
<tr>
<td>Save File</td>
<td>Save an NC program file</td>
</tr>
<tr>
<td>Cut</td>
<td>Cut text from a program</td>
</tr>
<tr>
<td>Copy</td>
<td>Copy text from a program</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste text into a program</td>
</tr>
<tr>
<td>Print</td>
<td>Print an NC program</td>
</tr>
<tr>
<td>Help</td>
<td>Access Help</td>
</tr>
<tr>
<td>Context Help</td>
<td>This button can help you instantly find</td>
</tr>
<tr>
<td></td>
<td>information on the objects you see on the</td>
</tr>
<tr>
<td></td>
<td>screen. For instance, click on the Context</td>
</tr>
<tr>
<td></td>
<td>Help button, then click on a menu item,</td>
</tr>
<tr>
<td></td>
<td>toolbar button, window or other screen</td>
</tr>
<tr>
<td></td>
<td>element. The Help file for that particular</td>
</tr>
<tr>
<td></td>
<td>item appears.</td>
</tr>
<tr>
<td>Jog Control Panel</td>
<td>Show or hide the Jog Control Panel</td>
</tr>
<tr>
<td>Operator Panel</td>
<td>Show or hide the Operator Panel</td>
</tr>
</tbody>
</table>

*Note: Context-sensitive means the results of your action are dependent on the item you click, or on the operation you are currently performing.*
Verify: Clicking on this button performs the same operation as selecting the Verify command under the Program Menu.

Run: Run the current NC part program

Pause: Pause the currently running NC part program

Stop: Immediately halt the currently running NC program

---

**ATC Control Toolbar**

This toolbar is only available if your Machining Center is equipped with an Automatic Tool Changer. The ATC Control Toolbar provides quick-access buttons for automatically changing tools. The toolbar provides six buttons; one for each tool station, one to operate the drawbar, and one to bring up the Configure ATC dialog box.

The Tool station buttons are in sequence from left to right, from tool station #1 to tool station #4 respectively). Each tool station button displays the number of the tool currently assigned to that particular station.

---

**Inputs Toolbar**

The Inputs Toolbar isn’t really a toolbar in the sense that you can not use it to interact with the various Control Program inputs. Actually, it is a monitoring device that keeps track of the state of the various system inputs.

The state of each input is indicated by the position of its button. If a button is depressed, the input is “on” or “high.” If a button is not depressed, the input is “off” or “low.” You can also check the condition of an input by clicking on it or by holding the mouse over the input button. The state of the input is displayed on the Status Bar at the bottom of the screen.

The inputs on the Inputs Toolbar include:

- **The Emergency Stop** condition. This input is in the “on” condition (depressed) if the Emergency Stop button on the Machining Center is pushed in.
- **The Safety Shield** condition. This input is in the “on” condition (depressed) if the Safety Shield on the Machining Center is open.
- **The Positive Limit** condition. This input is in the “on” condition (depressed) if one of the positive axis limits has been hit.
- **The Negative Limit** condition. This input is in the “on” condition (depressed) if one of the negative axis limits has been hit.

---

*Note: The Automatic Tool Changer is currently not supported under Windows NT.*
The **Robot Input 1** condition. This input is in the “high” condition (depressed) if the secondary robotic input on the TTL I/O connector on the Controller Box is currently in a high state. Refer to Section L of this manual for more information on robotic interfacing.

The **Robot Input 2** condition. This input is in the “high” condition (depressed) if the robotic input on the TTL I/O connector on the Controller Box is currently in a high state. Refer to Section L of this manual for more information on robotic interfacing.

### Outputs Toolbar

The Outputs Toolbar provides quick-access buttons for controlling the system outputs.

The state of each output is indicated by the position of its button. If a button is depressed, the output is “on” or “high.” If a button is not depressed, the output is “off” or “low.” You can also check the condition of an output by holding the mouse over the output button. Clicking on the button will change the state of the output. The name of the output is displayed in a tooltip, and the state of the output is displayed on the Status Bar at the bottom of the screen.

The output controls on the Outputs Toolbar include:

- The **Spindle** control. This button turns the spindle on and off.
- The **ACC1** control. This button turns the Accessory 1 output on and off.
- The **ACC2** control. This button turns the Accessory 2 output on and off.
- The **Robot Output 1** control. This button toggles Robotic Output 1 between high and low conditions. When this button is depressed, it places Robotic Output 1 (on the TTL I/O connector on the Controller Box) in the “high” condition. When this button is not depressed, Robotic Output 1 is in the “low” condition. Refer to Section L of this manual for more information on robotic interfacing.
- The **Robot Output 2** control. This button toggles Robotic Output 2 between high and low conditions. When this button is depressed, it places Robotic Output 2 (on the TTL I/O connector on the Controller Box) in the “high” condition. When this button is not depressed, Robotic Output 2 is in the “low” condition. Refer to Section L of this manual for more information on robotic interfacing.
Panels

The two available panels are used to control machine operation.

Jog Control Panel

The Jog Control Panel is accessed by selecting the Jog Control command under the View Menu, or by clicking on the Jog Control button on the Standard Toolbar. The Jog Control Panel allows you to manually move (jog) the tool on the machining center. Selecting the Keypad button allows you to use the numeric keypad on the keyboard to jog the machine.

Each axis on the machine is represented by buttons. The X and Y axes are represented by the crosspad. The crosspad follows the Cartesian coordinate system standard; -X to +X is left to right, while -Y to +Y is bottom to top. The Z axis is represented by two buttons, one for positive motion and one for negative. Pressing any of the axis buttons moves the tool in the indicated direction as long as the system is not in Simulate Mode.

Jogging occurs in specific increments of speed and distance. The speed and distance values are selected on this panel as well. You can alter the speed and distance parameters for jogging by selecting the Jog Settings command under the Setup Menu, or by double clicking on the Jog Control Panel.

To jog a tool:

1. Define the Speeds and Steps (distances) for jogging by selecting the Jog Settings command under the Setup Menu.
2. Click on the Axis button on the Jog Keypad to move the tool in the desired direction. The tool moves at the speed and distance indicated by the Speed and Step buttons.
3. To move the tool in a continuous motion, select Cont. The tool will continue to move as long as the axis button is depressed.
Tip:
If you wish, you can move the Operator Panel to another part of the screen. Hold the Ctrl key down, then click and drag the Operator Panel. Once you release the Ctrl key, the Operator Panel becomes a floating window which you can place anywhere on the screen.

Operator Panel

The Operator Panel provides controls that are used while running an NC program on the machining center.

----

The Operator Panel controls include:

- **Optional Skip**, when on, allows you to execute or ignore any optional skips (/ codes) you have embedded in the NC program.
- **Optional Stop**, when on, allows you to execute or ignore any optional stops (M01 codes) you have embedded in the NC program.
- **Single Step** causes the NC program to pause after each block is executed. This allows you to check each step of the cutting operation. Single Step is particularly useful after changing the workpiece size.
- **Stop**, when pressed, immediately halts the currently running NC program. This button works the same as the Ctrl + Space Bar combination.
- **Cycle Start** begins running the current NC program from the beginning or from a paused condition.
- **Cycle Stop** pauses the currently running NC program. To continue running the program from a Cycle Stop, press the Cycle Stop button again or press the Cycle Start button.
- **Feed Rate Override** overrides the programmed feed rate.
- **Spindle Speed Override** overrides the programmed spindle speed.
**Status Bar**

The Status Bar displays miscellaneous information about the Machining Center and the computer. The left side of the Status Bar is reserved for operator messages such as the one displayed here.

If any of the following are grayed-out, the feature is considered off.

- The machine homed state: Black if the machine is currently homed.
- The Caps Lock key state: Black if the Caps Lock feature is on. Some NC programmers prefer to type their programs in capital letters. When the Caps Lock feature is on anything you type will be displayed in capital letters. Press the Shift key to type lower case letters.
- The Num Lock key state: Black if the Num Lock feature is on. Some NC programmers prefer to use the numeric keypad on the keyboard to enter figures. The Num Lock feature must be on to do this.
- Current Line : Total Lines: Displays the line the cursor is currently on, and the total number of lines in the program.
- The file locking state: Black if the NC program file is locked.
- The file modified state: Black if the NC program has been modified since being opened.
- The current time (according to your computer).

**Menu Bar**

The Menu Bar is located at the very top of the screen. It lists the categories of commands into which the Control Program operations are grouped.

The available menus are:

The File Menu
The Edit Menu
The View Menu
The Program Menu
The Tools Menu
The Setup Menu
The Window Menu
The Help Menu
File Menu

The File Menu provides typical file management commands and the Exit command.

<table>
<thead>
<tr>
<th>Command</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Create a new program window.</td>
</tr>
<tr>
<td>Open</td>
<td>Open an existing file.</td>
</tr>
<tr>
<td>Close</td>
<td>Close an open program window.</td>
</tr>
<tr>
<td>Save</td>
<td>Save a program.</td>
</tr>
<tr>
<td>Save As</td>
<td>Save a program under a different filename or location.</td>
</tr>
<tr>
<td>Print</td>
<td>Print an open NC program.</td>
</tr>
<tr>
<td>Print Setup</td>
<td>Set up your printer for printing.</td>
</tr>
<tr>
<td>Recently opened files</td>
<td>Open one of the eight most recently used files.</td>
</tr>
<tr>
<td>Exit</td>
<td>Exit the Control Program.</td>
</tr>
</tbody>
</table>

New Command

Use the New command under the File Menu to create a new program edit window.

You can create a new program edit window at any time. The number of program edit windows that you have open at one time is limited by the amount of memory on your computer.

To create a new program window:

Select New from the File Menu, or press Ctrl+N.

A new program window is created. The filename on the Title Bar is “Untitled,” indicating that this is a new program. The program will remain untitled until you save it. You should save your new programs before they are run or verified.

Open Command

Use the Open command under the File Menu to open an existing NC program. The number of program edit windows that you have open at one time is limited by the amount of memory on your computer.
To open an existing NC program:

1. Select **Open** from the File Menu, or press **Ctrl+O**. The File Open dialog box appears.
2. In the dialog box, locate and highlight the desired NC file.
3. Click **OK** or press **Enter**. The selected NC program file is opened. The Title Bar displays the name of the file.

To select a file that is already open:

- If the open file has changed since it was opened, you are prompted to reload the original version of the file or to cancel the opening procedure.
- If the open file has not changed since it was opened, it becomes the active Program Edit Window.

**Close Command**

You can close a program window that is not in use at any time. Unless you have already done so, you will be prompted to save any changes made to the program file.

To close a program window:

1. Make sure the program window you want to close is selected.
2. Select one of several ways to close the open window:
   - Select the **Close** command from the File Menu.
   - Single-click the icon on the far left of the Title Bar and select **Close** from the drop-down menu. (If the Edit window is maximized, the icon will be at the far left of the Menu Bar.)
   - Double-click the icon on the far left of the Title Bar. (If the Edit window is maximized, the icon will be at the far left of the Menu Bar.)
   - Click on the **Close** button on the far right of the Title Bar. (If the Edit window is maximized, the icon will be at the far right of the Menu Bar.)
   - Press **Ctrl+F4**.
3. If there are unsaved changes to the current program, the File Save dialog box appears, prompting you to save the changes. Click one of the buttons in the dialog box:
   - Click **Yes** to save the changes.
   - Click **No** to discard the changes.
   - Click **Cancel** to exit the dialog box without saving the changes or closing the program window.
**Save Command**

Use the Save command under the File Menu to save the current program as an NC file.

If the current NC program was previously saved, selecting Save saves the changes to the same file. If the current program is new (and still has the name “Untitled”), selecting Save brings up the Save As dialog box, in which you name, choose a location for, and save the new program.

**To save a program:**

Select **Save** from the File menu, or press **Ctrl+S**.

The current program is saved to a file. If this is a new program, the Save File As dialog box appears. Choose a name and location for the new file.

**Save As ... Command**

Use the Save As command under the File Menu to save the current program to an NC file using a new name or location.

**To save a program using a new name or location:**

1. Select **Save As** from the File Menu. The Save As dialog box appears. It displays the name and location of the current program file.
2. Choose a new drive and directory for the file, if desired.
3. Type in a new file name, if desired.
4. Click **OK** to save the file, or **Cancel** to exit the dialog box.

**Save As Dialog Box**

The Save As dialog box is the same in the Control Program as in other Windows applications.

**To use the Save As dialog box:**

1. Select a destination for the file using the **Save in:**; **Up one level** and **Create new folder** buttons.
2. Enter a filename in the **File Name:** field.
3. Select a file type in the **Save as type:** field.
4. Click **OK** or press **Enter** to save the file.
5. Click **Cancel** or press **Esc** to cancel and exit the dialog box.
Print Command

Use the Print command under the File menu to print the current NC program.

To print the program:

1. There are several ways to print an NC program:
   - Click the Print button on the toolbar.
   - Select the Print command from the File Menu.
   - Press Ctrl+P.

2. The Print dialog box appears. Choose the desired print options in the dialog box. Clicking Setup opens the Print Setup dialog box.

3. Click OK to print, or click Cancel to exit the Print dialog box without printing the NC program.

You can print to any printer that is supported by Windows 95. See your printer manual or Windows documentation for more information on installing and using printers with Windows.
Print Setup Command

Use the Print Setup command under the File Menu to select a printer. The Print Setup dialog box allows you to establish parameters for printing your NC part programs.

To choose print settings:

1. Select Print Setup from the File Menu. The Print Setup dialog box appears.
2. Select the desired print settings, including:
   - The destination printer.
   - The size of the paper.
   - The paper tray.
   - The orientation of the paper.
3. Click OK to print, or click Cancel to exit the Print dialog box without setting the printing parameters.

Opening a Recent Program

You can use the numeric (1, 2, 3, ... 8) commands under the File menu to open any of the eight most recently opened files.

The names and paths of the eight most recent files appear as file 1 (the file last opened) through file 8 (the eighth most recent).

To open one of the eight most recently opened programs:

Select 1, 2, 3, 4, 5, 6, 7 or 8 from the File menu.

The recent program you selected is opened. The Title Bar displays the name of the program file.
Exit Command

Use the Exit command under the File Menu to exit the Control Program. You should always exit the Control Program before you exit Windows.

To exit the Control Program:

Select the Exit command from the File Menu.
- Single-click the icon on the far left of the Control Program Title Bar. Select Close from the drop-down menu.
- Double-click the icon on the far left of the Control Program Title Bar.
- Click on the Close button on the far right of the Title Bar.
- Press Alt+F4.

If there are unsaved changes to any program window, a dialog box appears for each unsaved program window, prompting you to save the changes.
- Click Yes to save the changes and exit.
- Click No to ignore the changes and exit.
- Click Cancel or press Esc to cancel the Exit command and return to the Control Program.
Edit Menu

The Edit Menu provides typical text editing commands. Before you can edit the text in an NC program, you must select it.

Command: Used to:

Undo Undo the most recent editing command.

Cut Cut selected text to the Windows clipboard.

Copy Copy selected text to the Windows clipboard.

Paste Paste text from the Windows clipboard into the current NC program.

Clear Delete selected text.

Delete Line Delete the line the cursor is currently on.

Find Locate a sequence of characters in an NC program.

Replace Replace one sequence of characters with another, one or more times.

Goto Line Jump to a particular line in the NC program.

Renumber Modify or insert N codes in an NC program.

Lock Lock or unlock the Program Edit Window to prevent or allow modification to the NC program.

Select Font Change the font currently being used.

Undo Command

The Undo command reverses the most recent editing action taken. It is useful for recovering from accidental deletion or inclusion of a block of text.

To undo the last change:

Select Undo from the Edit menu, or press Ctrl+Z.

- If your last editing action was to delete selected text, the text is restored.
- If your last editing action was to delete a character, the character is restored.
- If your last editing action was to paste text, the text is removed.
- If your last editing action was to type a character, the character is removed.
- If Undo is grayed-out in the Edit menu, no changes can be undone.
Redo Command

The Redo command redoes the edit command performed before the undo command. If you deleted a part of the text, and then decided to undo that deletion, the Redo command will perform the original delete again.

Cut Command

Use the Cut command under the Edit Menu to remove text from the NC program (the text is copied to the Windows clipboard). The text can then be pasted anywhere in the current program, into another program, or into another application such as Notepad. The text remains in the Windows clipboard until it is replaced by another Cut or Copy operation.

To cut text to the Clipboard:
1. Select the text you wish to cut.
2. Select Cut from the Edit Menu, or press Ctrl+X.

Copy Command

Use the Copy command under the Edit Menu to duplicate selected text in an NC program.

To copy text to the Clipboard:
1. Select the text you wish to copy.
2. Select Copy from the Edit Menu, or press Ctrl+C. The selected text is copied to the Clipboard.

Paste Command

You can use the Paste command to insert text from the Windows clipboard into your NC program.

To paste text from the Clipboard:
1. Place the cursor at the point in the NC program where you wish to insert text that has been previously cut or copied to the Windows clipboard.
2. Select Paste from the Edit menu, or press Ctrl+V. The contents of the clipboard are inserted into the program. If this menu command is grayed-out, there is no text on the clipboard to paste.
Clear Command

Use the Clear command under the Edit Menu to delete selected text from your NC program. The text is not copied to the Windows clipboard. You can also use the Delete key on your keyboard to achieve the same effect.

To delete text using the Clear command:

1. Select the text you wish to delete.
2. Select the Clear command from the Edit menu. The selected text is deleted.

Delete Line Command

Use the Delete Line command under the Edit Menu to delete an entire line of NC code from a program without selecting it first.

To delete a program line using the Delete Line command:

1. Place the cursor anywhere on the line of code you wish to delete.
2. Select the Delete Line command from the Edit Menu, or press F2. The line of code is deleted.

Find Command

Use the Find command under the Edit Menu to locate a particular sequence of characters within an NC program.

To use the Find command:

1. Select Find from the Edit Menu, or press Ctrl+F.
2. Enter the character sequence you are looking for in the Find: box.
3. Check off the Match Case box to restrict the search to finding only those text strings that match the case (upper or lower) of the text that you entered.
4. Select Up or Down from the Direction box to search through the text before or after the cursor position, respectively.
5. Click Find Next or press Alt+S to begin the search. Click Cancel or press ESC to exit the Find dialog box without performing the search.

To find the same character string again, use the Find Next button.
Replace Command

Use the Replace command under the Edit Menu to replace an existing character string with a new character string.

To use the Replace command:

1. Select Replace from the Edit menu.
2. Enter the existing character string in the Find What: box.
3. Enter the new character string in the Replace With: box.
4. If you select Match whole word only the program will only find and replace text that matches your entry. When you select Match case, it will find and replace those text strings that match the case (upper or lower) of the text you entered.
5. Select one of the buttons depending on how you wish to replace text.
   - Find Next will find the next occurrence of the text.
   - Replace will replace the selected text with the new text.
   - Replace All will replace all occurrences of the text with the new text.
   - Close will close the dialog box.
Goto Line Command

Use the Goto Line command under the Edit Menu to move the cursor to a specific line in the NC program. This command is also available using the Program Edit Window Pop-up Menu.

To use the Goto Line command:
2. Enter a line number in the Jump To Line box. The cursor moves to the specified line. If the line number entered is larger than the number of lines in the program, the cursor is moved to the end of the program.

Renumber Command

Use the Renumber command under the Edit Menu to alter the N codes in your NC program.

The Renumber command can be used to:
- Insert N codes in a program that doesn’t have any.
- Remove N codes from a program.
- Renumber N codes in a program.
- Insert, remove or ignore spaces between NC commands.
- Remove comments from the program.

Insert N Codes

To insert or renumber the N codes in your program:
1. Select Renumber from the Edit Menu. The Renumber/Format Program dialog box appears.
2. Select Renumber N Codes or press Alt+N.
3. Click on the Start N Code box (or press Alt+T), then enter the number of the first N code. The default starting block number is N1.
4. Click on the Increment box (or press Alt+I), then enter the increment you wish to use.
For instance, if you wish to have each N code numbered in increments of 5, enter 5 in the Start N Code box and enter 5 in the Increment box. The N code sequence will then be: N5, N10, N15, N20… and so on.

This option is useful if you are renumbering a portion of the program to be inserted into another program. Using increments greater than 1 allows you to insert additional numbered lines without having to renumber the whole program.

5. Select Do It, or press Alt+O, to execute the Renumbering options you selected. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format Program dialog box without altering the NC program.

Renumbering and Subprograms

Although the Renumber command automatically changes P codes used with (M99) codes, it does not renumber P codes used with M98 codes, nor does it renumber O codes. Although O codes are not altered, the lines which they occupy are counted. So, the very next N code is numbered as though the O code has been renumbered, too.

For instance,  
N41X
N42X…
O25G…
N44…

In this example, although the O code has not been renumbered, the line it resides on has been counted. The N code on the following line reflects the next number in the sequence.

Insert or Remove Spaces

To insert or remove spaces between the NC words in your program:

1. Select Renumber from the Edit Menu. The Renumber/Format Program dialog box appears.

2. Choose a Spaces option.
   - Insert Spaces inserts a space between each NC word (to the left of the comment code).
   - Remove Spaces removes any spaces between NC words (to the left of the comment code).
   - Ignore Spaces ignores any spaces in the NC program.

3. Select Do It, or press Alt+O, to execute the Spaces options you selected. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format Program dialog box without altering the NC program.
Remove Comments

To remove comments from your program:

1. Select Renumber from the Edit Menu. The Renumber/Format Program dialog box appears.
2. Select Remove Comments.
3. Select Do It, or press Alt+O, to execute the Remove Comments command. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format Program dialog box without altering the NC program.

Remove N Codes

To remove the N codes from your program:

1. Select Renumber from the Edit Menu. The Renumber/Format Program dialog box appears.
2. Select Remove N Codes or press Alt+R.
3. Select Do It, or press Alt+O, to execute the Remove N Codes command. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format Program dialog box without altering the NC program.

Lock Command

Use the Lock command under the Edit Menu to prevent or allow changes to your NC programs. If a check mark appears next to this command, the current NC program is locked.

When an NC program is unlocked, it can be modified by the commands on the Edit Menu. When an NC program is locked, the program cannot be changed by any commands. By default, when you open a file it is automatically locked to prevent accidental changes. You can change this in the Preferences dialog box.

If you have multiple program edit windows open, each is individually locked or unlocked. The state of the currently selected NC program, locked or unlocked, can be easily checked by looking at the Lock Indicator on the Status Bar.

To use the Lock command to lock or unlock your NC program:

Select Lock from the Edit Menu, press Ctrl+L, or double-click the Lock Indicator on the Status Bar.
Select Font Command

Use the Select Font command under the Edit Menu to change the font settings for open NC programs. Font Settings are intended for viewing and printing purposes only. They do not affect the NC program in any way and are not stored within the program file. All open program windows use the same font settings.

To use the Select Font command:

1. Select the Select Font command from the Edit Menu.
2. Select a font from the Font list.
3. Select a font size from the Size list.
4. Click OK to change the font, or click Cancel or press Esc to exit the Font dialog box without changing the fonts.

Font Settings

The font settings control the font and font size used in the program edit window. The fonts listed are the true type fonts already installed on your system.

View Menu

The View Menu commands control the display of windows and toolbars.

<table>
<thead>
<tr>
<th>Command</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>Open or close the Machine Position Window.</td>
</tr>
<tr>
<td>Machine Info</td>
<td>Open or close the Machine Info Window.</td>
</tr>
<tr>
<td>Jog Control</td>
<td>Open or close the Jog Control Panel.</td>
</tr>
<tr>
<td>Operator Panel</td>
<td>Open or close the Operator Panel.</td>
</tr>
<tr>
<td>Verify Window</td>
<td>Open or close the Verify Window.</td>
</tr>
<tr>
<td>Toolbars</td>
<td>Open or close one of the toolbars.</td>
</tr>
</tbody>
</table>

Position Command

Use the Position command on the View Menu to open or close the Position Window.

To open or close the Position window:

Select Position from the View Menu. A check mark appears next to the Position command when the Position Window is open.
Machine Info Command

Use the Machine Info command on the View Menu to open or close the Machine Info window.

To open or close the Machine Info window:

Select Machine Info from the View Menu. A check mark appears next to the Machine Info command when the Machine Info Window is open.

Jog Control Command

Use the Jog Control command on the View Menu to open or close the Jog Control Panel. You can also use the Jog Control button on the Standard Toolbar.

To open or close the Jog Control window:

Select Jog Control from the View Menu. A check mark appears next to the Jog Control command when the Jog Control Panel is open.

Operator Panel Command

Use the Operator Panel command on the View Menu to open or close the Operator Panel.

To open or close the Operator Panel:

Select Operator Panel from the View Menu. A check mark appears next to the Operator Panel command when the Operator Panel is open.

Verify Window Command

Use the Verify Window command on the View Menu to open or close the Verify Window.

To open or close the Verify Window:

Select Verify Window from the View Menu. A check mark appears next to the Verify Window command when the Verify Window is open.

Toolbars Command

Use the Toolbars command on the View Menu to show or hide the Toolbars.

To show or hide a toolbar:

1. Select Toolbars from the View Menu. The list of available toolbars is displayed. Toolbars that are visible have a check mark beside them.
2. Select the toolbar that you wish to show or hide.
Program Menu

The Program Menu commands allow you to Run, Verify, or Stop an NC program.

<table>
<thead>
<tr>
<th>Command:</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run/Continue</td>
<td>Start running or resume running the current NC program.</td>
</tr>
<tr>
<td>Verify</td>
<td>Verify the current NC program.</td>
</tr>
<tr>
<td>Estimate Runtime</td>
<td>Estimate the runtime of the current NC program.</td>
</tr>
<tr>
<td>Pause</td>
<td>Pause the currently running NC program.</td>
</tr>
<tr>
<td>Feedhold</td>
<td>Stop movement of all axes.</td>
</tr>
<tr>
<td>Stop</td>
<td>Immediately halt the currently running NC program.</td>
</tr>
</tbody>
</table>

Run/Continue Command

The Run/Continue command under the Program Menu runs the current NC program on the Machining Center. When you select Run/Continue from the Program Menu, the Run Program dialog box appears, allowing you to select the program, the start block, run settings, and verify settings.

While a program is running, the Machine Info Window and the Message Bar keep you informed by providing information on:

- The name of the NC program.
- Which block is currently being executed.
- How many blocks are in the program.
- Which tool is being used.
- The number of passes made.
- The tool diameter.
- The spindle speed.
- Operator messages such as which block paused the program or the error that caused the program to stop.
Run Program Dialog Box

The Run Program dialog box allows you to select an NC program to run, to set the line from which to begin running the program, and to access the Run Settings and Verify Settings dialog boxes.

1. Select an NC Program.

If you have more than one NC program open, use the Program drop-down list, or press Alt+P, to select the program you wish to run.

2. Select a starting line.

When you are running an NC program for the first time, it is wise to start the program from the first line. When you start at a line other than one, the control program parses through the program to the specified start point. As it parses, it performs operations such as turning the spindle on, but it will not execute a Dwell or Pause command, and it will not move the tool.

To specify a starting line, click on the Start at Line box, or press Alt+L, and enter the line number.

3. Set the Run Settings

To bring up the Run Settings dialog box click on the Run Settings button, or press Alt+U.

4. Set the Verification Settings

To bring up the Verify Settings dialog box click on the Verify Settings button, or press Alt+E.

5. Run the Program

To start running the program, click on the Run Program button, or press Alt+R. To cancel running the program, click on the Cancel button, or press Esc.

Verify Command

The Verify command allows you to view tool path verifications of your NC part programs. When you select Verify from the Program Menu, the Verify Program dialog box appears.
This dialog box allows you to select a program to verify from a pull-down list of currently open NC part programs. Prior to verifying the part program, you may wish to alter the Run Settings, alter the Verification Settings, or select a starting block in the program. The default starting block is line one.

Begin the verification by pressing the Verify Program button. If the Verify Window is not already open, it will open automatically.

Tool path verification is displayed in the Verify Window. The workpiece and tool are displayed according to the choices you made in the Verify Settings dialog box.

![Diagram of tool path verification](image)

Here is an example of how the Verification may appear for the part program MILLONE.NC.

**Estimate Runtime Command**

Use the Estimate Runtime command to calculate the approximate amount of time the proLIGHT 1000 requires to machine your part and the approximate distance the machine travels while machining your part.

The Estimate Runtime command accounts for Dwell times and subprograms when calculating estimated run time, but it cannot account for stops that have indefinite length of stop time. These program stops include:

- Pause (G05/M00)
- Chain (M20)
- Skip (G31)
- Wait for input high/low (G25/G26)
- Write to file (M22)
- Rerun (M47)

The Estimate Runtime command treats M47 Rewind codes as M2 End of Program codes.

This command also verifies the syntax of your NC programs while calculating the estimated run time. If an error is found, the Estimate Run Time command alerts you with a dialog box, and places the cursor near the error.
Pause Command

Use the Pause command to pause a running NC program. Pause may also be used during tool path verification. The pause is not immediate; it takes effect after the current NC block has been executed.

To use the Pause command:

Select Pause from the Program menu, or click the Pause button on the Standard Toolbar.

To resume running a program after a pause:

Press F5, click the Run button on the Standard Toolbar, or click the Go button on the Message Bar.

Feedhold Command

The Feedhold command is very similar to the Pause command. It is used to pause a running NC program. The differences between a Pause and a Feedhold are:

- A Feedhold pause the NC program immediately; it does not wait until the current block is executed.
- Feedhold does not work during tool path verification.

To use the Feedhold command:

Select Feedhold from the Program menu.

To resume running a program after a Feedhold:

Press F5, click the Run button on the Standard Toolbar, or click the Go button on the Message Bar.

Stop Command

You can use the Stop command under the Setup Menu to halt a running NC program. The Machining Center immediately halts cutting and the current tool position is stored by the computer.

To use the Stop command:

1. Select Stop from the Program Menu, press Ctrl+Space, or click the Stop (red) button on the Standard Toolbar.

2. A message box appears. Clear the box by clicking OK or pressing Enter. You are automatically returned to the Edit mode.

To restart a program after a Stop performed through the Control Program:

1. Manually jog the tool so it is above the workpiece to avoid a tool crash.

2. Select the Run/Continue command to restart the NC program. You will not have to reset the initial tool position (assuming the first block of your program moves the tool to the start position).
**Tools Menu**

The Tools Menu commands allow you to select tools, set up and use a tool library, and configure, operate, and initialize the Automatic Tool Changer (only available on systems equipped with an ATC).

<table>
<thead>
<tr>
<th>Command:</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Library</td>
<td>Define tools used with the machining center.</td>
</tr>
<tr>
<td>Setup Tool Wizard</td>
<td>Aid in establishing tool lengths for use with multiple tool programs.</td>
</tr>
<tr>
<td>Select Tool</td>
<td>Select a tool for use on the machining center.</td>
</tr>
<tr>
<td>Insert Tool from ...</td>
<td>Automatically change tools using the Automatic Tool Changer.</td>
</tr>
<tr>
<td>Configure ATC</td>
<td>Assign particular tools for use with the Automatic Tool Changer.</td>
</tr>
<tr>
<td>Operate ATC</td>
<td>Control the draw bar and individual tool stations, and monitor related inputs.</td>
</tr>
<tr>
<td>Initialize Station Location ...</td>
<td>Allows you to initialize each tool used with the Automatic Tool Changer.</td>
</tr>
</tbody>
</table>

**Setup Library Command**

Use the Setup Library command under the Tools Menu to assign parameters to multiple types of tools used on the machining center. When you select the Setup Library command, the Setup Tool Library dialog box appears.
You can create a new tool two ways:

- Use the Copy and Paste buttons to copy an existing tool in the Tool Library box and paste it into the Tool Library box under an unassigned tool number. Assigned tool numbers are displayed with a tool icon. Unassigned tool numbers have no tool icon.

- Manually create a tool using the features available in the Setup Tool Library dialog box.

To create a new tool:

1. Select an unassigned tool number from the Tool Library list.
2. Select a tool type, such as End Mill, from the Tool Type drop-down menu.
3. Enter a name for the tool in the Description field.
4. Select a Station for the tool. Station numbers are provided for those systems that are equipped with an Automatic Tool Changer. If you do not have an Automatic Tool Changer, select Station #1.
5. Enter the number of teeth (Num Teeth) on the tool.
6. Enter the Material Type from which the tool should be made.
7. There is a secondary library for tool materials. You can use this library to create new materials or edit existing materials. To do this, click on the Edit Tool Materials button.
   a) Enter a material Name.
   b) Select a Material Class.
   c) Enter a Multiplier. This should be set to “1” for now. This is used when integrating with CAM for calculating feed rates and spindle speeds when generating tool paths.
   d) Click on the Add button.
   e) Click on the Delete button to remove tool materials you no longer need.
   f) Press Enter or click on OK to accept the new material. Click on Cancel to exit the Tool Material Type dialog box without changing the material library.
8. Enter a tool Diameter.
9. Enter a tool Height/Offset value. You may also click on the Current Z button to establish the current Z axis position of the tool as the Height/Offset.
10. Enter a Diameter Offset.
11. Apply the new parameters to the selected tool number by clicking the Apply button.
12. Press Enter or click on OK to accept the new tool information. Click on Cancel to exit the Tool Library dialog box without changing the tool library.
To alter an existing tool:

1. Select an existing tool from the Tool Library list.
2. Make the desired changes to the tool parameters, then click on the Apply button.
3. Press Enter or click on OK to accept the new tool information. Click on Cancel to exit the Tool Library dialog box without changing the tool library.

**Setup Tool Wizard Command**

Use the Setup Tool Wizard as an aid in establishing tool heights for use with multiple tool programs. The Wizard can be used if you are manually changing tools, or if you are using an Automatic Tool Changer.

To use the Setup Tool Wizard:

1. Select Setup Tool Wizard from the Tools Menu. This starts the Wizard.
2. Follow the Wizard’s instructions very carefully!

**Select Tool Command**

Use the Select Tool command under the Tools Menu to select a tool for use on the machining center.

To select a tool:

1. Select the Select Tool command from the Tools Menu. The Select Tool for Use dialog box appears.
2. Select a tool from the drop-down Tool list. The tool parameters appear in the window to the right of the list.
3. Select an action to exit the dialog box:
   - Click Select Tool button if the tool is already in the mounted spindle.
   - Click Insert Tool to perform a tool change cycle. The Machining Center moves to its tool change position (maximum Z axis height) and you are prompted to insert a tool into the spindle. After you insert the tool and press F5, the Machining Center returns to its original position.
   - Click Cancel to exit the Select Tool for Use dialog box without selecting a tool.
Insert Tool From Command

Use the Insert Tool From command under the Tools Menu to automatically change tools using the Automatic Tool Changer. When you select the Insert Tool From command, a fly-out menu appears. The menu contains a list of the available tool stations, one through four. If you select Station 1, the Machining Center automatically inserts the tool located in Station #1 of the ATC.

If your Machining Center is not equipped with an Automatic Tool Changer, the fly-out menu will be grayed out (the station commands are unavailable).

Configure ATC Command

The Configure ATC command under the Tools Menu allows you to select a particular tool for use in a specific tool station on the Automatic Tool Changer. You must use the Configure ATC dialog box to tell the software which tools have been placed in each station. Each tool station has its own list of tools. The tools are assigned to a particular station by using the Station entry in the Tool Library dialog box.

To assign a tool to a station:

1. Select the Setup Library command from the Tools Menu.
2. Select the icon for the tool you wish to use from the Tool Library list.
3. Using the Station pull-down list, select the station in which you intend to place the tool.
4. Select OK, or select Apply then assign other tools.
5. Once you have exited the Tool Library dialog box, select Configure ATC from the Tools Menu.
6. Using the pull-down lists, select a tool for each station. Select the tool that is actually in the station. If the station is empty and that station's tool is not the one in the spindle, select the empty tool holder icon from the list.
7. If one of the tools is currently held in the spindle, select the **In Use** button for that station.

8. Press **Enter** or click on **OK** to accept the new configuration, or click on **Cancel** to exit the Configure ATC dialog box without changing the configuration.

---

**Operate ATC Command**

The Operate ATC command under the Tools Menu allows you to change the state of each tool station (raised or lowered) and the draw bar (clamped or unclamped). It also allows you to monitor the state of the inputs, including whether:

- There is a tool in the spindle.
- The current tool is in the correct position for a tool change.
- The spindle is currently rotating.
- There is sufficient air pressure.
- The ATC hardware is locked.

When you are finished, select the **Close** button to exit the dialog box.

---

**Initialize Station Location ... Command**

The Initialize Station Location command under the Tools Menu allows you to initialize each tool used with the Automatic Tool Changer. Each time you initialize a tool, you should follow this sequence:

1. Home the Machining Center.

2. Insert a tool gauge plug into the draw bar.

3. Jog the cross-slide to position the station being set so that the tip of the plug touches the top of the tool holder in the station.

4. Select the **Initialize Station Location** command and select the tool number from the fly-out menu.

Repeat this sequence for each tool station you are using.
Setup Menu

The Setup Menu commands control the parameters for setting up tool positioning, jogging, running and verifying programs, coordinate systems, tool offsets, etc.

<table>
<thead>
<tr>
<th>Command</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Position</td>
<td>Establish the X, Y and Z position of the tool.</td>
</tr>
<tr>
<td>Zero Position</td>
<td>Set the current tool position to X0, Y0, Z0.</td>
</tr>
<tr>
<td>Jog Settings</td>
<td>Establish speed and distance parameters for jogging the tool.</td>
</tr>
<tr>
<td>Run Settings</td>
<td>Establish options for running an NC part program.</td>
</tr>
<tr>
<td>Verify Settings</td>
<td>Establish options for verifying an NC part program.</td>
</tr>
<tr>
<td>Verify Type</td>
<td>Select centerline or solid view for tool path verification.</td>
</tr>
<tr>
<td>Set/Check Home</td>
<td>Establish or check a fixed known position on the machine.</td>
</tr>
<tr>
<td>Goto Position</td>
<td>Automatically move the tool to a specific set of coordinates on the machining center.</td>
</tr>
<tr>
<td>Units</td>
<td>Select Inch or Metric units of measure.</td>
</tr>
<tr>
<td>Coordinate Systems</td>
<td>Define multiple coordinate systems or select a new coordinate system.</td>
</tr>
<tr>
<td>Offsets</td>
<td>Modify the table of Offset values used for certain NC codes.</td>
</tr>
<tr>
<td>Spindle</td>
<td>Specify a spindle speed if you have not used an S code in your NC program.</td>
</tr>
<tr>
<td>Backlash</td>
<td>Define the amount of play in the Machining Center turning screws.</td>
</tr>
<tr>
<td>Soft Limits</td>
<td>Establish software limits for each axis that are different than the actual fixed hardware limits on the machining center.</td>
</tr>
<tr>
<td>Preferences</td>
<td>Establish defaults for saving files and security features.</td>
</tr>
</tbody>
</table>
Set Position Command

Use the Set Position command under the Setup Menu to set new X, Y and Z positions for the tool. This command establishes a Work Coordinate System in relationship to the Machine Coordinate System. Setting the X, Y and Z coordinates for the tool also defines the zero point of the coordinate system for absolute motion.

This command is also available under the Position Window Pop-up Menu.

To set a new position:

1. Move the tool to the desired position.
2. Select Set Position from the Setup Menu.
3. Enter a new X position.
4. Enter a new Y position.
5. Enter a new Z position.
6. Press Enter or click on OK.

The new position is displayed in the Position Window.

Zero Position Command

Use the Zero Position command under the Setup Menu to reset the point of origin (0,0,0) at any position on the Machining Center. Since the tool length and the workpiece position on the cross slide may vary from one tooling set up to another, the zero position must be initialized each time set up is changed.

This command is also available under the Position Window Pop-up Menu.

To set the zero point:

1. Move the tool to the point on the workpiece you intend to establish as the zero point.
2. Select Zero Position from the Setup Menu. The new position (0,0,0) is displayed in the Position Window.

Jog Settings Command

Use the Jog Settings command to enter speed and distance values for the Jog Control Panel. This command is also available through the Jog Control Panel Pop-up Menu.
To set jog parameters:

1. Select Jog Settings from the Setup Menu.
2. Enter the desired jog speeds and distances.
3. Select OK or press Enter. The new values are applied to the Jog Control Panel.

**Jog Speed**

The jog speed is the rate at which the tool moves along the X, Y, or Z axes. Select the speed by pressing the appropriate button. The speed can be Slow, Medium or Fast.

**Default Values for Speed**

- 1 ipm for Slow
- 15 ipm for Medium
- 25 ipm for Fast

These feed rates can be set as high as 50 inches per minute.

**Jog Distance (Steps)**

Distance values determine how far the tool moves each time a key is pressed. Referred to as Steps, the distance is selected by pressing the A, B or C buttons. The distance can be set at a low value (for instance 0.0005 inch) to move the tool for a precise cut, or at a high value (e.g. 0.5 inches) to position a tool.

Pressing the Continuous (Cont.) button moves the tool continuously as long as the axis button is depressed. Once the axis button is released, the tool stops.

**Default Values for Steps**

- 0.001 inch for Step A
- 0.01 inch for Step B
- 0.1 inch for Step C
Run Settings Command

Use the Run Settings dialog box to set or clear options for running your NC program. The available options are:

- Single Step
- Optional Skip
- Optional Stop
- Enable Subprograms
- Arc Centers Incremental
- Treat Warnings as Errors
- Restore Unit Mode When Done
- Verify While Running

Single Step

This option inserts a Pause after each block of the NC program. To move on to the next block in the program, you can:

- Click the Run button on the Standard Toolbar.
- Click the GO button on the Message Bar.
- Press F5.
- Press Enter.
- Select Run/Continue from the Program menu.

Optional Skip

Use this option to enable or disable the optional skip code. The optional skip code allows you to skip blocks of code as the NC program is run.

Make sure to check off the Optional Skip box in the Run Settings dialog box or activate the Optional Skip button on the Operator Panel. Then place a forward slash ( / ) in front of each line in the NC program you want to skip.

With Optional Skip off, each skip code is ignored and each block of code is executed. With Optional Skip on, each skip code is recognized and each block of code that has been tagged with a skip code is skipped.

To execute particular blocks every nth pass, place a number after the optional skip. For example: /5G28; Home every fifth pass
Optional Stop

Use this option to enable or disable the optional stop code (M01). The optional stop code allows you to place an optional stop in your NC program.

Make sure to check off the Optional Stop box in the Run Settings dialog box or activate the Optional Stop button on the Operator Panel. Place an M01 on the line of code where you would like to pause.

With the Optional Stop option on, the M01 works like a G05. With Optional Stop off, the M01 code is ignored, the other codes on the block are executed as usual.

Enable Subprograms

Use this option to enable or disable the use of subprograms. With this option disabled, M98 commands generate an error. Running or verifying a program with subprograms enabled takes longer to start because the software parses the entire file for subprogram information. This extra delay should only be noticeable with large programs.

Arc Centers Incremental

Use this checkbox to specify the default mode for programming arc centers. If this box is checked, the default mode is the Fanuc mode, in which arc centers are always incremental. If this box isn’t checked, the default mode is EIA-274, in which arc centers follow the general programming mode: absolute when the mode is absolute, and incremental when the mode is incremental.

Treat Warnings as Errors

This command is used for special applications, such as laser welding, where you don’t want any unexpected pauses in the program execution. For example, when a warning is displayed and the program pauses, waiting for your input before it continues.

When this item is checked, any warning will halt the program, performing a program Stop. When motion is stopped, all outputs are turned off.

Restore Unit Mode When Done

If you normally work in one unit mode (inch or metric) but would like to run a program in another mode without disrupting your default settings, check this box.

Select a specific unit mode by using one of the G20/G21 or G70/G71 commands at the beginning of your NC program.
Once the NC program is executed, your default unit mode will be restored.

For instance, if you normally work in Inch Mode, but have a particular program you would like to run in Metric Mode, check the **Restore Unit Mode When Done** box. Place a G21 code at the beginning of your program, then run it. When the program is finished, the default for your system will still be Inch Mode.

**Verify While Running**

If this box is checked, the Verify window will display the program verification while the program is running. The verification does not show exactly what is happening on the machining center. There is a delay between each tool motion. You will see each tool motion on the screen, but the verification screen will pause until the machine finishes the motion and the next program block is read.

**Verify Settings Command**

Use the Verify Setup dialog box to control the appearance of the tool path verification. You can also access this dialog box using the Verify Window Pop-up Menu.

The Verify Settings dialog box is tabbed, with the settings organized into three groups: View Panel, Stock Panel and Options Panel.
View Panel

The View panel allows you to control the view style and zoom factor. It also offers a selection of preset views.

Style

Use these radio buttons to select between Solid and Centerline views of the stock.

Zoom

Use these buttons to control the size of the stock in the Verify Window. You can click on the buttons or use Alt key combinations (Alt++, Alt++, and Alt+A). Each mouse click or key combination used zooms by an increment of one.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Zoom in on the stock.</td>
</tr>
<tr>
<td>-</td>
<td>Zoom away from the stock.</td>
</tr>
<tr>
<td>All</td>
<td>Fit the stock into the window.</td>
</tr>
</tbody>
</table>

Preset View

Use these buttons to select a perspective, then use the Preview Window to fine-tune the angle:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Front</td>
<td>View the stock directly from the front. The stock appears as a rectangle along the X, Z axes.</td>
</tr>
<tr>
<td>Top</td>
<td>View the stock directly from above. The stock appears as a rectangle along the X, Y axes.</td>
</tr>
<tr>
<td>Isometric</td>
<td>View the stock at an angle, in three dimensions.</td>
</tr>
</tbody>
</table>

Stock Panel

All stock values are interpreted according to the Units Mode in effect at the time they are set. To quickly see which Units Mode is currently in effect, check the Position window.

Stock Dimensions

Use this area to set the dimensions of the stock used in the verification process. You will see the stock in the Preview Window change as soon as you enter a dimension.

Origin

Use this area to adjust the verification for different workpiece setups. Most NC programs set the 0,0,0 point at the top of the front-left corner of the stock. Occasionally, however, you may want to use a different origin (the center of the stock, for example). In this case, you must enter a different origin to properly verify your program. The values entered should correspond to the coordinates of the left corner of the stock relative to the 0,0,0 point for the program.

For instance, if the origin for the program is the center of a 3x2x1 piece of stock, set the origin to -1.5, -1.0.
Initial Tool Position

You can select a tool start point using Initial Tool Position. The Initial Tool Position is only used for verification, not actually running a program. The position is used when you verify a program; when verifying while running, the actual position of the tool is used as the initial tool position.

Options Panel

The Verify Options control certain aspects of the solid and centerline verification display.

Solid Options

Auto-refresh automatically refreshes the solid display of the workpiece if something changes during verification, such as resizing the verify window, changing the view, or changing the stock dimensions. When Auto-refresh is disabled, you will need to manually cause the verify window to update by selecting the Redraw command from the window’s context menu. This setting only affects refreshing the window when no verification is in progress.

Centerline Options

Auto-refresh automatically refreshes the centerline display of the workpiece if something changes during verification.

Show Tool controls whether or not the tool is displayed in the Verify Window.

The Preview Window

The Preview Window appears in each of the above groups. The Preview Window shows you approximately what the Verify Window will look like. The Preview Window always depicts the stock in Centerline view.

In addition to depicting how the Verify Window will look, you can use the preview box to change the orientation of the stock:

- Use the slider bars on the side of the Preview Window to rotate the stock along the X, Y plane and along the Z plane. There are two ways to control the sliders:
  1. Select the slider button by clicking on it with the mouse. Hold the left mouse button down while sliding the button along the bar until the stock is in the desired position.
  2. Select the slider button by tabbing to it. The button will blink to indicate it is selected. Use the arrow keys on the keyboard to move the slider button along the bar until the stock is in the desired position.
- Use the mouse to rotate the stock in all planes simultaneously. “Grab” the stock by clicking and holding it with the mouse. Move the stock with the mouse until the stock is in the desired position.
Buttons

The **OK** button at the bottom of the dialog box applies the changes you have made and closes the dialog box.

The **Cancel** button closes the dialog box without applying any of the changes you have made.

The **Help** button brings up the Help topic.

Verify Type Command

The Verify Type allows you to choose between a solid view and a centerline view in the Verify Window.

Set/Check Home Command

Use the Set/Check Home command under the Setup Menu to establish or check a fixed known position on the machine. This command is also available through the Jog Control Panel Pop-Up Menu.

Home

This option moves the machining center’s spindle, cross slide and saddle to the ends of travel along each axis and sets the Machine Coordinate System to -X0, +Y0, +Z0.

Quick Home

This option is for homing when you have lost position slightly, or when you start the machine at the beginning of the day and the machine hasn’t moved. Using this option, the Control Program assumes that it is close to being homed (that it knows approximately what the machine position is). The Control Program rapids the machine to a short distance from the limits before homing; this is much faster than feeding in at the normal slow rate. The Quick-Home feature is particularly useful for homing the machine after hitting a limit or after pressing the Emergency Stop while the machine is moving at a high speed.

Check Home

This option checks the reference point, identical to using a G27 code. It compares the reported position against zero to see if any position has been lost.
Goto Position Command

The Goto Position command opens the Goto Position dialog box. Use the Goto Position dialog box to move the tool to a particular coordinate position on the machining center.

This command is also available under the Position Window Pop-Up Menu and Jog Control Panel Pop-up Menu.

To use the Goto Position command:

1. Enter the coordinates for the new tool position.
2. Enter the feed rate at which you would like the tool to travel.
3. Click on the Go button. The tool moves to the new position at the defined feed rate.

Units Command

Use the Units command under the Setup Menu to select the unit of measure for the application. When you select the Units command, a fly-out menu appears allowing you the option of using Inch (standard) or Metric measurement.

Important Note:

Machine coordinates are established by Homing the system to establish a point of origin at the ends of travel on the Machining Center. Once established, these coordinates remain fixed. Each time you turn on the machining center, the current machine position is stored as the machine coordinate system X0, Y0, Z0.

Work coordinates are different. When you use the Set Position command to set a point of origin on the workpiece, you are actually entering a position that is offset from the fixed machine position. The same thing occurs when you use a G92 code.

(Continued next page)
Work Coordinates are not fixed; they can be established anywhere on the system by using either the Set Position command or the G92 code.

Within the Work Coordinates you can set separate coordinate systems using the codes G54 through G59, or the Setup Coordinate Systems dialog box.

If you reset the Work Coordinates either with a G92 code or in the dialog box, the G54-G59 Coordinate System offsets will change accordingly.

If you Home the machine while using Coordinate systems, the offsets will not be affected.

3. Select a coordinate system, then enter and apply the offsets.
   a) Select a CS from the System box.
      The system titled “Work CS” contains the current values for the work coordinate system. This is like adding a G92 code to your NC program. You can change the default for the work coordinate system by entering new values in the Offsets boxes. These values are an offset from the true origin of a coordinate system and affect all coordinate systems.
   b) Select the offsets for a user coordinate system by:
      - Entering X, Y and Z offset values in the Offsets boxes.
      - Clicking the Current Pos button to establish offset values based on the current tool position.
      - Selecting a Marker in the Preview Area for the coordinate system and dragging it to the desired position.
      - Copying offsets from one CS to another using the Copy Offsets and Paste Offsets buttons.
   c) Make the currently selected CS the active CS by selecting the Make Active button.
   d) Use the Goto Offset button to move the tool to the currently selected offset coordinates.
   e) Apply the coordinates or exit the dialog box:
      - The OK button applies the changes you have made and closes the dialog box.
      - The Cancel button closes the dialog box without applying any of the changes you have made since clicking the Apply button.
      - The Apply button applies the changes you have made and leaves the dialog box open in case you wish to make more changes (you can still cancel changes once they have been applied by selecting the Cancel button).
Offsets Command

Use the Offsets command under the Setup Menu to compensate for variations in the cutting tools being used. The offset values are used for tool length offset, cutter compensation, and tool offset adjustment NC codes. For information on setting tool length offsets for multiple tool programming, see the Tool Setup Wizard, on page E-35.

To enter a compensation offset:

1. Select Offsets from the Setup Menu.

2. Click on an Offset Number (the numbers 1 through 199 are available). This number only acts as a designation (a name) for the offset.

3. Enter an Offset Value in the Value box, or select the Current Z button to use the current Z position (also useful for defining tool heights if you are using G43 or G44 to specify tool heights).

4. Press Enter or click on OK. The Offset Value has been associated with the Offset Number. The next time you open the Offsets table, you will see the new offset.

The Offset Table

The Offset Table stores up to 200 values which are used in several operations including tool offset adjustment, cutter compensation, and tool length compensation to ensure uniform application of an offset value. The numbers are stored as unit-less values; their interpretation depends on the Units currently in effect.

Set the values in the Offset Table using the Offsets command under the Setup Menu. The Offsets are stored in the WPLM1000.ini file when running with a machine, and in TESTCTL.INI when running in simulation mode.
Spindle Command

Use the Spindle command under the Setup Menu to specify a spindle speed if you have not used an S code in your NC program.

The spindle speed is primarily determined by the Mode Switch on the Machining Center front panel. If the Mode Switch is set to Manual Mode, spindle speed is controlled by the Spindle Speed Control Knob, also on the front panel. If the Mode is set to CNC, spindle speed is determined by an S code in the NC program. If there is no S code in the NC program, spindle speed is determined by the Setup Spindle dialog box.

To specify a spindle speed:

1. Select the Spindle command from the Setup Menu. The Spindle Setup dialog box appears.
2. Select a spindle speed by entering a value in the RPM box, or by using the slider and arrow buttons.

Also in this dialog box:

- Reset the spindle override value to 100% by clicking on the Reset Override to 100% button.
- Change the On/Off state of the spindle using the On and Off buttons in the Spindle State area.
- Disable spindle operation by selecting the Disable option. This is useful if you have a device mounted in the spindle that cannot withstand being rotated, such as a wired probe.
- Select Done to close the dialog box.
Backlash Command

Use the Backlash command under the Setup Menu to define the amount of play in the Machining Center turning screws. The system default is set at a backlash value of 0.0 on all three axes, with a feed rate of 10 ipm.

To establish new backlash parameters:

1. Select Backlash from the Setup Menu.
2. Enter the desired backlash distances and feed rate.
3. Press Enter or click on OK to accept the new backlash parameters, or click on Cancel to exit the Setup Backlash dialog box without setting new backlash parameters.

Soft Limits Command

Use the Soft Limits command under the Setup Menu to establish software limits for each axis. The limits that are different than the actual fixed hardware limits on the machining center. Soft limits can confine the tool travel to an area smaller than the normal maximum travel.

The Machining Center shuts down if it trips a soft limit, just as it does when it trips one of the limit switches. This is helpful when working with devices such as robots, or when you have installed fixtures within the normal work area that you don’t want the tool to hit.

To establish software limits on the machining center:

1. Select Soft Limits from the Setup Menu.
2. Enter the coordinates that define the software perimeter you wish to establish.
3. Click on the Enable Soft Limits option to enable soft limits. Use this option to turn soft limits on or off as you need to use them.
4. Press Enter or click on OK to accept the new soft limit parameters, or click on Cancel to exit the Setup Soft Limits dialog box without setting new soft limit parameters.
Preferences Command

Use the Preferences command under the Setup Menu to establish defaults for saving files and setting security features.

To alter the system preferences:

1. Select the Preferences command from the Setup Menu.
2. Select either the Editor preferences tab or the Security preferences tab.

Editor Preferences

The Editor preferences allow you to automatically save your NC program files at regular intervals, and establish a default directory in which to store your files. When you select the Editor tab in the Preferences dialog box, the Editor panel appears.

To select AutoSave features:

- Select Save when idle and enter a value in the Every: ___ minutes box to save your NC programs automatically at the specified time increment.
- Select Save Before Running to save changes to your NC program prior to running it for the first time with the changes.
- Select Prompt Before AutoSaving if you wish to be prompted by the Control Program before it automatically saves the NC program at the specified time increment.

To select File Default features:

- Enter an Extension for your NC part program files. The default is “NC.”
- Select Lock Files When Opened to have your NC programs locked by default. Deselect this feature to have your NC programs unlocked by default.
- Select the Set button to specify a target directory in which to save your NC program files. The default directory appears in the Directory box.
To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on Cancel to exit the Preferences dialog box without setting new Editor or Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.

Security Preferences

The Security preferences allow you to control which features others may use. When you select the Security tab in the Preferences dialog box, the Security panel appears.

The Security preferences panel offers two modes, User and Administrator. Administrator Mode allows a supervisor, such as a teacher in a classroom, to turn commands on or off using the Allowed Commands list. User Mode does not have access to this feature.

To secure the software using Administrator Mode:

1. Set the Default Mode to User. (This will not change the current mode.)
2. Use the Change Password button to create a password. The default password is blank - no password.
3. Select the Allowed Commands. Double-click on the listed commands to enable or disable them. If the commands are enabled, they are marked with an X. A description of each selected command is displayed on the right side of the panel.
4. Use the Change Mode button to change to User Mode.
5. Select OK or press Enter to exit the Preferences dialog box.

The software is now running in User Mode. The next time you open the Preferences dialog box, the Security preference panel is displayed in User Mode. In this mode it is not possible to turn commands on or off.

To return to Administrator Mode:

1. Use the Change Mode button to toggle the Mode from User to Administrator. A dialog box appears, prompting you to enter your password.
2. Enter your password and press Enter or click on OK.

To change your password:

1. Click on the Change Password button.
2. Enter your current password.
3. Enter the new password.
4. Enter you new password again to verify that it is correct.
To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on Cancel to exit the Preferences dialog box without setting new Editor or Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.

---

**Window Menu**

The Window Menu commands allow you to manipulate the arrangement of the Program Edit Windows.

<table>
<thead>
<tr>
<th>Command</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Layer the open edit windows.</td>
</tr>
<tr>
<td>Tile</td>
<td>Tile the open edit windows.</td>
</tr>
<tr>
<td>Arrange Icons</td>
<td>Arrange any minimized edit windows along the bottom of the edit area.</td>
</tr>
<tr>
<td>Window List</td>
<td>Display and select between the currently open NC programs by their file names.</td>
</tr>
</tbody>
</table>

**Cascade Command**

Similar to the standard Windows/Cascade command. Places the open Program Edit Windows in a layered format, cascading down to the right with the currently selected window on top.

**Tile Command**

Similar to the standard Windows/Tile command. Places the open Program Edit Windows in a tiled format, filling the Edit Area from top to bottom.

**Arrange Icons Command**

When you minimize a Program Edit Window, it becomes a small icon. The Arrange command under the Window Menu arranges these icons along the bottom of the edit area.

**Window List Command**

Lists the currently open Program Edit Windows. The currently selected window is designated with a check mark. You may select any window by clicking on the window itself, or by selecting the window name from this list.
Help Menu

The Help Menu commands allow you to navigate through the Help files, to save or restore parameters set throughout the current session, and provides handy tips and other information about the Control Program.

<table>
<thead>
<tr>
<th>Command</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>Display Help for the current task or command.</td>
</tr>
<tr>
<td>Index</td>
<td>List Help topics.</td>
</tr>
<tr>
<td>Using Help</td>
<td>Display instructions about how to use Help.</td>
</tr>
<tr>
<td>Save Settings</td>
<td>Saves the current machine and application settings.</td>
</tr>
<tr>
<td>Restore Settings</td>
<td>Resets the machine and application settings from defaults.</td>
</tr>
<tr>
<td>Tip of the Day</td>
<td>Display a Tip of the Day.</td>
</tr>
<tr>
<td>About WPLM1000</td>
<td>Display program information, version number and copyrights.</td>
</tr>
</tbody>
</table>

Help Command

Use the Help command to access the Help contents. You can also press the F1 key to get information about the currently highlighted command on a drop-down or pop-up menu.

Index Command

Use the Help Index command access an index of available Help topics.

Using Help Command

Use the Using Help command to obtain information on how to use the Help utility.

Save Settings Command

The Save Settings command allows you to retain current library, security, screen and control settings as defaults.

- Click on a particular setting(s) to tag it, then click on the Save button to save the selected items and exit the dialog box.
- Click on the Save All button to save all settings without having to select each one.
- Click on the Cancel button to exit the Save Defaults dialog box without changing the existing defaults.
**Restore Settings Command**

The Restore Settings command allows you to restore all or some of the current settings to the defaults you set using the Save Settings command (User Defaults) or to the factory set defaults.

- Click on a particular setting(s) to tag it, then click on a Restore From option. Click the **Restore** button to restore the selected items and exit the dialog box.
- Click on the **Restore All** button to restore all settings without having to select each one.
- Click on the **Cancel** button to exit the Restore Defaults dialog box without changing the existing defaults.

**Tip of the Day Command**

This command brings up information about the operation of the machining center, tips & tricks for using the Control Program and NC programming ideas.

**About WPLM1000 ... Command**

This command simply brings up an information box. Included is information on the Control Program version number, the release date, and copyright information.
**Selecting Commands**

There are a few different ways to select commands in the Control Program. Use the method that is most convenient for you.

**Select a Command Using Pop-Up Menus**

Clicking the right mouse button on certain windows or panels brings up a pop-up menu. Each pop-up menu is context-sensitive. Commands which cannot be performed at that time are grayed out.

**To select a pop-up menu command:**

1. Position the cursor on the window or panel.
2. Click and hold down the right mouse button. The context-sensitive menu appears.
3. Highlight a command by moving the mouse pointer over it, then release the right mouse button.

**The following windows have pop-up menus:**

- Program Edit Window
- Position Window
- Verify Window
- Jog Control Panel

The Machine Info Window and Operator Panel only provide the Dockable and Hide commands on their Pop-up menus.

**Program Edit Window Pop-up Menu**

The Program Edit Window Pop-Up Menu contains different combinations of these commands, depending on whether the file is running or being verified, and whether or not text is selected.

**Cut Command**

Cut is the same as selecting the Cut command from the Edit Menu.

**Copy Command**

Copy is the same as selecting the Copy command from the Edit Menu.

**Paste Command**

Paste is the same as selecting the Paste command from the Edit Menu.
Clear Command

Clear is the same as selecting the Clear command from the Edit Menu.

Goto Line Command

Goto Line is the same as selecting the Goto Line command from the Edit Menu.

Renumber Command

The Renumber command is the same as selecting Renumber from the Edit menu. A dialog box appears that allows you to alter the N codes in the NC program.

Save Command

Saves the current program.

QuickRun Command

The QuickRun command is a shortcut that runs the currently selected NC part program. When you click the right mouse button on this command, the program behaves as though you had selected the Run/Continue Command from the Program Menu with the following exceptions:

- You do not have the option of selecting a starting line.
- You do not have the option of changing any settings.

QuickVerify Command

The QuickVerify command is a shortcut that verifies the currently selected NC part program. When you click the right mouse button on this command, the program behaves as though you had selected the Verify Command from the Program Menu with the following exceptions:

- You do not have the option of selecting a starting line.
- You do not have the option of changing any settings.

Estimate Runtime

This command performs the same function as the Estimate Runtime command under the Program Menu.

Position Window Pop-up Menu

The Position Window Pop-Up Menu contains these commands:

Inch Command

Automatically switches the units of measure for the application to inch units.
**Metric Command**
Automatically switches the units of measure for the application to metric units.

**Coordinate Systems Command**
Produces a fly-out menu that allows you to set up and select coordinate systems.

**Set Position Command**
Opens the Set Position dialog box.

**Zero Position Command**
Sets the current tool position to zero on all axes.

**Goto Command**
Opens the Goto Position dialog box.

**Dockable Command**
The Dockable command toggles the window between being a dockable window and being undockable. See Docking and Floating Windows for more information.

This command is available on all pop-up menus for the windows and panels available under the View Menu.

**Hide Command**
The Hide command closes the window. To open the window again, select it from the View Menu.

This command is available on all pop-up menus for the windows and panels available under the View Menu.

**Verify Window Pop-Up Menu**
The Verify Window Pop-Up Menu contains these commands:

**Solid Command**
Switches the verification to a solid view.

**Centerline Command**
Switches the verification to a centerline view.

**Redraw Command**
This command repeats the most recent tool path verification simulation.

**Stop Redraw Command**
This command will interrupt a redraw currently in progress.
Reset Command

This command resets the Verify Window; it clears the tool path lines and resets the tool to the starting position.

Dockable Command

The Dockable command toggles the window between being a dockable window and being undockable. See Docking and Floating Windows for more information.

This command is available on all pop-up menus for the windows and panels available under the View Menu.

Hide Command

The Hide command closes the window. To open the window again, select it from the View Menu.

This command is available on all pop-up menus for the windows and panels available under the View Menu.

Jog Control Panel Pop-up Menu

The Jog Control Panel Pop-Up Menu contains these commands:

Setup Command

This command opens the Jog Settings dialog box.

Goto Command

This command opens the Goto Position dialog box.

Set/Check Home Command

This command opens Machine Home/Reference Point dialog box.

Dockable Command

The Dockable command toggles the window between being a dockable window and being undockable. See Docking and Floating Windows for more information.

This command is available on all pop-up menus for the windows and panels available under the View Menu.

Hide Command

The Hide command closes the window. To open the window again, select it from the View Menu.

This command is available on all pop-up menus for the windows and panels available under the View Menu.
## Select a Command Using Hot Keys

Some menu commands have one or more key designations next to them; those are the *hot keys* for that command. Pressing the hot key(s) selects the corresponding command.

**To select a command using hot keys:**

Press the hot key for the desired command. For example, press Ctrl+S to save your drawing.

Here’s a list of the available hot keys:

<table>
<thead>
<tr>
<th>Key(s):</th>
<th>Menu/Command:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+C</td>
<td>Edit Menu/Copy</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Edit Menu/Find</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Edit Menu/Goto Line</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Setup Menu/Set/Check Home</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Edit Menu/Lock</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>File Menu/New</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>File Menu/Open</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>File Menu/Print</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Setup Menu/Run Settings</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>File Menu/Save</td>
</tr>
<tr>
<td>Ctrl+Space</td>
<td>Program Menu/Stop</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>Tools Menu/Setup Library</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Edit Menu/Paste</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Edit Menu/Cut</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Edit Menu/Redo</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Edit Menu/Undo</td>
</tr>
<tr>
<td>Ctrl+Shift+Z</td>
<td>Setup Menu/Zero Position</td>
</tr>
<tr>
<td>F1</td>
<td>Help Menu/Help</td>
</tr>
<tr>
<td>F2</td>
<td>Edit Menu/Delete line</td>
</tr>
<tr>
<td>F5</td>
<td>Program Menu/Run/Continue</td>
</tr>
<tr>
<td>F6</td>
<td>Program Menu/Verify</td>
</tr>
<tr>
<td>F8</td>
<td>Setup Menu/Goto Position</td>
</tr>
<tr>
<td>Ctrl+KeyPad+</td>
<td>Increase Feed rate Override</td>
</tr>
</tbody>
</table>
Ctrl+KeyPad- Decrease Feed rate Override  
Ctrl+Backspace Edit Menu/Undo  
Shift+Delete Edit Menu/Cut  
Shift+F1 Help Menu/Context Help  
F4 Activate Jog Control  
Ctrl+F5 QuickRun  
Ctrl+F6 QuickVerify  
Ctrl+TAB Next Edit Window  
Ctrl+Insert Edit Menu/Copy  
Shift+Insert Edit Menu/Paste  
Pause Edit Menu/Pause

---

**Select a Command Using Toolbars**

The Tool Bars contain buttons that correspond to frequently used menu commands. Clicking a button on a toolbar is equivalent to selecting the same command from a menu, and is usually quicker. The WPLM1000 Control Program provides Standard, ATC, Input, and Output toolbars. Use the commands under the View Menu to control whether each tool bar is displayed or hidden.
The Setup Program

The Setup Program allows you to set program and hardware defaults. In order to access the Setup Program, you must first exit the WPLM1000 program. Locate the WPLM1000 folder on your hard drive, (default install is in the C:\Windows\Programs folder) and double click the Setup Icon. The program will start and you will see the Welcome screen. You may choose from the file tabs to view the defaults for each category.

The Setup Program provides defaults under the following categories:

- Welcome
- Interface Card
- General
- Control
- Advanced
- More Advanced

Welcome Panel

This panel provides one option, Units Default. This option sets the default unit of measure for the Control Program and the Setup Program. When running the Control Software, you can change the default using the Units command under the Setup Menu.
Interface Card Panel

This panel allows you to change the Interface Card Address. Once you have installed the Interface Card and software, and performed the initial Setup, this address should not change. The only time you might consider changing the address is if there is a hardware conflict.

General Panel

This panel allows you to alter several software defaults.

- **Run Offline** starts the Control Program in Simulate Mode without checking for a machine connection.

- **Decimal Places for Inch Values** controls the display of values in dialog boxes. When in Metric mode, the software displays 1 less than the specified number of decimal places.

- **Tool Shaft Height** controls the tool shaft length in the Preview Window (in the Verify Settings dialog box) and the Verify Window. The control software uses this value to ensure that the tool with the smallest length offset is verified with a length at least as large as this value.

- **NC Programming Settings** controls several programming options:
  
  - The maximum number of subprograms.
  - The maximum depth of subprograms; the number of nested subprograms.
  - The maximum arc radii deviation; the allowable difference between the two radii, r1 and r2, of an arc before being considered an error.
  - The default L-factor; the angle at which a line segment approximates a portion of an arc.
  - The default feed rate; the initial feed rate when running or verifying an NC program; used until a feed rate is specified in the NC program.

Control Panel

The **New Controller Box** option lets the software know which version of Controller electronics you are using. The **How Do I Tell** button explains the difference between the controllers.

The **Reference Point Tolerance** option is used for Homing. Initially, when a machine is homed, the position is set to zero. When the machine is homed again it should travel to the same position, plus or minus this value.
The **Spindle Settings** option allows you to set delays between the time the spindle turns on and the next command is executed, and from the time the spindle is turned off and the next time it is turned on. These values should not be changed.

The **ATC Settings** option is only valid if you have an Automatic Tool Changer on your system. The settings include a parallel port selection and the maximum number of times you can attempt to unlock the hardware. If you select the Use Automatic Tool Changer checkbox but do not have an ATC connected, or if it is connected to a different parallel port, you will get an error when you run the control software. You should only need to change the Unlock Retries value if you continue to get errors while trying to unlock the ATC hardware when the ATC is connected properly.

---

**Advanced Panel**

These features are **Not for Novice Users**! They are provided for troubleshooting purposes only.

The **Spindle Settings** allow you to change the maximum spindle speed, the conversion slope and the conversion offset. If the programmed feed rate (or the feed rate entered in the Setup Spindle dialog box) are not close enough to the actual feed rate you require, you may fine tune the spindle speed using these values.

The **Feed Rate Settings** allow you to change the maximum rapid traverse feed rate, the minimum machining feed rate and the maximum machining feed rate. This is not the same as the default feed rate on the General panel. The default feed rate is the feed rate that is automatically used if no feed rate is specified in the NC program. The minimum and maximum machining feed rates define the feed rate range for the machine.

The **Resonance Settings** allow you to set the low end and high end of the resonance range; the range in which stepper motors can resonate and lose position. The software prevents loss of position by slowing down the programmed feed rate of the machine until the component feed rates for all axes are outside of this range. If you are using a New Controller Box (as selected on the Control panel), the High End value is used to help eliminate resonance electrically rather than by modifying feed rates.
More Advanced Panel

These features are meant for Advanced Users Only! They are provided for troubleshooting purposes.

The Tool Change Settings allow you to alter the distance that the spindle retracts in order to perform a tool change (if you are using an ATC). It also allows you to alter the feed rate at which the tool is moved when retracted for a tool change.

The Other Settings Axis SPU option is used to alter the ratio of steps per unit on the machine; the number of stepper motor steps required to move the cross slide one inch.

Offset Table

The Offset Table stores 200 values which are used in several operations including tool offset adjustment, cutter compensation, and tool length compensation to ensure uniform application of an offset value. The numbers are stored as unit-less values; their interpretation depends on the Unit mode currently in effect. Offset zero is always 0.0 and cannot be modified. Using Offset zero for most compensations cancels that compensation.

Set the values in the Offset Table using the Offset command under the Setup Menu. The Offsets are stored separately for the machine, and for Simulation Mode.

Working in Simulation Mode

Simulation mode is provided to allow the WPLM1000 Control Program to be used when your computer is not connected to a PLM1000 Machining Center. This is primarily to support the off-line development of NC programs.

NC program verification and running is supported in Simulation Mode. Programs will Run in the same amount of time that they would if a machine were attached (excluding stops that have indefinite length of stop time, see Estimate Runtime).

The principal difference between Simulation Mode and Normal Mode is, since no machine is available to send and receive data, there are no Inputs and Outputs. The Inputs and Outputs buttons on the toolbars are inoperable. If your program contains commands to wait for certain input values that are not the default, the events will never occur. If the values are the default, the wait will occur immediately.
Reference Guide: Section F

Basic CNC Programming

The Elements of an NC Part Program

Categories of NC Code

General Programming Suggestions
The Elements of an NC Part Program

Part programs generally incorporate two types of instructions: those which define the tool path (such as X, Y and Z axis coordinates), and those which specify machine operations (such as turning the spindle on or off). Each instruction is coded in a form the computer can understand.

An NC program is composed of blocks (lines) of code. The maximum number of blocks per program is limited by the memory (RAM) on your computer. You can, if necessary, chain programs together to form very large part programs.

Each block contains a string of words. An NC word is a code made up of an alphabetic character (called an address character) and a number (called a parameter). There are many categories of address characters used in NC part programs for the proLIGHT Machining Center (see Categories of NC Code).

Each block of NC code specifies the movement of the cutting tool on the Machining Center and a variety of conditions that support it. For example, a block of NC code might read:

\[ \text{N0G90G01X.5Y1.5Z0F1} \]

If the machine is currently set for inch units, the individual words in this block translate as:

- **N0** This is the block sequence number for the program. Block 0 is the first block in the program.
- **G90** This indicates absolute coordinates are used to define tool position.
- **G01** This specifies linear interpolation.
- **X.5** This specifies the X axis destination position as 0.5”.
- **Y1.5** This specifies the Y axis destination position as 1.5”.
- **Z0** This specifies the Z axis destination position as 0”. The cutting tool will move to the absolute coordinate position (0.5,1.5,0).
- **F1** This specifies a feed rate of 1 inch per minute, the speed at which the tool will advance to the specified coordinate points.
### Categories of NC Code

There are many categories of NC code used for programming the proLIGHT Machining Center. Here is a list of the NC codes (designated by the address character) supported by the proLIGHT 1000 Machining Center.

<table>
<thead>
<tr>
<th>Code</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>%</td>
<td>Incremental Arc Centers (Fanuc).</td>
</tr>
<tr>
<td>$</td>
<td>Absolute Arc Centers (LMC).</td>
</tr>
<tr>
<td>\</td>
<td>Skip.</td>
</tr>
<tr>
<td>/</td>
<td>Optional skip.</td>
</tr>
<tr>
<td>D</td>
<td>Compensation offset value.</td>
</tr>
<tr>
<td>F</td>
<td>Feed rate in inches per minute; with G04, the number of seconds to dwell.</td>
</tr>
<tr>
<td>G</td>
<td>Preparatory codes.</td>
</tr>
<tr>
<td>H</td>
<td>Input selection number; Tool length offset.</td>
</tr>
<tr>
<td>I</td>
<td>Arc center, X axis dimension (circular interpolation).</td>
</tr>
<tr>
<td>J</td>
<td>Arc center, Y axis dimension (circular interpolation).</td>
</tr>
<tr>
<td>K</td>
<td>Arc center, Z axis dimension (circular interpolation).</td>
</tr>
<tr>
<td>L</td>
<td>Loop counter; Program cycle (repeat) counter for blocks and sub-programs; homing tolerance, arc interpolation control.</td>
</tr>
<tr>
<td>M</td>
<td>Miscellaneous codes.</td>
</tr>
<tr>
<td>N</td>
<td>Block number (user reference only).</td>
</tr>
<tr>
<td>O</td>
<td>Subprogram starting block number.</td>
</tr>
<tr>
<td>P</td>
<td>Subprogram reference number (with M98 or M99); Uniform scale multiplier (with G51).</td>
</tr>
<tr>
<td>Q</td>
<td>Peck depth for pecking canned cycle.</td>
</tr>
<tr>
<td>R</td>
<td>Arc radius for circular interpolation (with G02 or G03); Starting reference point for peck drilling (with canned cycle codes); Rotation angle for coordinate rotation.</td>
</tr>
<tr>
<td>S</td>
<td>Spindle speed.</td>
</tr>
<tr>
<td>T</td>
<td>Tool specification.</td>
</tr>
<tr>
<td>U</td>
<td>Incremental X motion dimension for absolute dimensioning.</td>
</tr>
<tr>
<td>V</td>
<td>Incremental Y motion dimension for absolute dimensioning.</td>
</tr>
<tr>
<td>W</td>
<td>Incremental Z motion dimension for absolute dimensioning.</td>
</tr>
<tr>
<td>X</td>
<td>X axis motion coordinate.</td>
</tr>
<tr>
<td>Y</td>
<td>Y axis motion coordinate.</td>
</tr>
<tr>
<td>Z</td>
<td>Z axis motion coordinate.</td>
</tr>
<tr>
<td>;</td>
<td>Comments.</td>
</tr>
</tbody>
</table>
Incremental Arc Center (%)

The incremental arc center code selects the Fanuc mode for programming arc coordinates. This mode is selected for the entire NC program as well as for any chained programs.

In the Fanuc mode, arc centers are always incremental, regardless of whether the system is in G90 (absolute) or G91 (incremental) mode. In contrast, arc center specifications in EIA-274 mode follow the selected programming mode, absolute or incremental.

You can specify the default arc center mode in the Run Settings dialog box. This character must stand alone on the first line of the NC program in which it appears.

Absolute Arc Centers ($)

The absolute arc center code selects the EIA-274 mode of programming arc coordinates. This mode is selected for the entire NC program as well as for any chained programs.

In the EIA-274 mode, the mode of programming arc centers follows the selected programming mode; absolute (G90) or incremental (G91). In contrast, arc center specifications in Fanuc mode are always incremental, regardless of whether the system is in absolute or incremental mode.

You can specify the default arc center mode in the Run Settings dialog box. This character must stand alone on the first line of the NC program in which it appears.

Skip (\) and Optional Skip (/)

The Skip and Optional Skip codes allow you to skip particular lines of code in your program.

To use the Skip code (\):

Place the code at the beginning of the line you wish to skip. When you run the NC program, the specified line will be skipped.

To use Skip code (\) with a parameter:

Use the Skip code with a parameter to instruct the Control Program to execute the line of code every nth pass. Place the code at the beginning of the line you wish to skip.

Note: The optional skip (\) code works only when the Optional Skip parameter from the Run Settings dialog box is on.
The syntax is: \( n \), where \( n \) is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place \( 5 \) as the first code at the beginning of the block.

**To use the Optional Skip code (/):**

1. Place the code at the beginning of the line you wish to skip.
2. Select the Optional Skip option from the Run Settings dialog box or the Operator Panel.

When you run the NC program, the specified line will be skipped. If you do not select the Optional Skip option in the Run Settings dialog box, the skip code is ignored and the line is executed normally.

**To use the Optional Skip code (/) with a parameter:**

Use the Optional Skip code with a parameter to instruct the Control Program to execute the line of code every \( n \)th pass. Place the code at the beginning of the line you wish to optionally skip.

The syntax is: \( /n \), where \( n \) is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place \( /5 \) as the first code at the beginning of the block.

---

**Feed Rate (F Code)**

Use the F code to:

- Specify the rate of speed at which the tool moves (feed rate) in inches per minute (ipm). For example, F3 equals 3 ipm.

  The feed rate should be set to a low value (up to 50 ipm) for cutting operations. Feed rate values are in millimeters per minute (mpm) when using metric units. The Control Program limits the programmed feed rate so it doesn’t exceed the maximum allowed by the machining center.

- Specify the number of seconds to dwell when used with the G04 code.
Preparatory Codes (G Codes)

G codes take effect before a motion is specified. They contain information such as the type of cut to be made, whether absolute or incremental dimensioning is being used, whether to pause for operator intervention, and so on.

More than one G code from different groups can appear in each NC block. However, you may not place more than one G code from the same group in the same block.

The G codes supported by the Control Program fall into the following groups:

- The Interpolation Group
- The Units Group
- The Plane Selection Group
- The Wait Group
- The Canned Cycle Group
- The Programming Mode Group
- The Preset Position Group
- The Compensation Functions Group
- The Coordinate System Group
- The Polar Programming Group

The Interpolation Group

The Interpolation Group allows you to specify the type of motion for interpolation. These G codes are retained until superseded in the NC program by another code from the Interpolation Group.

The supported interpolation G codes are:

- **G00**   Rapid traverse
- **G01**   Linear interpolation (default)
- **G02**   Circular interpolation (clockwise)
- **G03**   Circular interpolation (counterclockwise)

Note: More than one G code from different groups can appear in each NC block. However, you may not place more than one G code from the same group in the same block.
The Units Group

By default, an NC program is interpreted using the units of measure (inch or metric) specified using the Units command on the Setup Menu.

The codes in the Units group, G70 (inch) and G71 (metric), are used to override the Units command for the entire program.

If the code is placed at the beginning of the program before any tool motions are made, that unit of measure is assumed for the entire program. Otherwise, it affects the rest of the program following the code. You can use these codes to switch between inch and metric modes throughout your program at your convenience.

The Fanuc equivalents, G20 (inch) and G21 (metric), can also be used.

The Plane Selection Group

This group of codes allows you to select different planes for circular interpolation. G17 is the Control Program default.

The supported Plane Selection Group codes are:

G17  Select the X,Y plane for circular interpolation. The arc center coordinates are given by I for the X axis and J for the Y axis.
G18  Select the X,Z plane for circular interpolation. The arc center coordinates are given by I for the X axis and K for the Z axis.
G19  Select the Y,Z plane for circular interpolation. The arc center coordinates are given by J for the Y axis and K for the Z axis.
The Wait Group

Wait Group codes apply only to the block in which they appear. The program does not continue until the wait conditions are satisfied.

The supported Wait Group codes are:

G04  Dwell (wait): Pause between motions on all axes for the number of seconds specified by the F code, then continue the program. Because the F code is used to specify the number of seconds, you cannot also specify a new feed rate in the same block.
Example: G04F10; Wait for 10 seconds

G05  Pause: Used for operator intervention. Stop motion on all axes until the operator manually resumes program execution using the Run/Continue command.

G25  Wait until TTL input #1 (Robot 1 or user input 5) goes high before executing the operations on this block. Used for robot synchronization (see Section L for more information). Use the H code to specify an input other than the default, H5.

G26  Wait until TTL input #1 (Robot 1 or user input 5) goes low before executing the operations on this block. Used for robot synchronization (see Section L for more information). Use the H code to specify an input other than the default, H5.

G31  Linear move to specified coordinate; used with H code to specify both input number and the High or Low condition for stop (designated by the operator input, + or -). The move occurs until an input is triggered or until the specified end point is reached. The move stops short if specified input goes High (if H is positive) or Low (if H is negative). The default is input 5 (Robot 1) High.
You can have the control program go to a specified block (N Code number) if the input meets the required condition. Use a P code to specify the destination, as with the M98 code.
For example, G31X5Y5H6P50000 instructs:
Move (using the current programming mode) to the X5 and Y5.
If input 6 (Robot 2) goes low during the move, stop the motion and jump to block number 50000.
If input 6 (Robot 2) doesn’t go low, complete the move and continue with the next block in the program.

G35  Wait until TTL input #2 (Robot 2 or user input 6) goes high before executing the operations on this block. Used for robot synchronization (see Section L for more information). This is the same as using the codes G25 H6.

G36  Wait until TTL input #2 (Robot 2 or user input 6) goes low before executing the operations on this block. Used for robot synchronization (see Section L for more information). This is the same as using the codes G26 H6.
The Canned Cycle Group

Canned cycle codes allow you to perform a number of tool motions by specifying just one code. Canned Cycle codes are typically used for repetitive operations to reduce the amount of data required in an NC program. Canned cycle codes are retained until superseded in the program by another canned cycle code.

The supported Canned Cycle codes are:

- **G80**: Canned cycle cancel
- **G81**: Canned cycle drilling
- **G82**: Canned cycle straight drilling with dwell
- **G83**: Canned cycle peck drilling
- **G85**: Canned cycle boring
- **G86**: Canned cycle boring with spindle off (dwell optional)
- **G89**: Canned cycle boring with dwell

Refer to Section G for more information on these functions.

The Programming Mode Group

Programming mode G codes select the programming mode, absolute (G90) or incremental (G91). These codes remain in effect until superseded by each other. The default code on program start up is G90.

With absolute programming, all X, Y and Z coordinates are relative to origin of the current coordinate system. With incremental programming, each motion to a new coordinate is relative to the previous coordinate.

The supported Programming Mode codes are:

- **G90**: Absolute programming mode
- **G91**: Incremental programming mode

The Preset Position Group

The preset position G codes move the tool to a predetermined position, or affect how future motions will be interpreted.

The supported Preset Position codes are:

- **G27**: Check reference point: This code moves the machine to its home position and compares the reported position against zero to see if any position has been lost. The difference between the reported position and zero is compared to a tolerance value specified using the Setup Program. Use the L code in this block to override the tolerance value from the Setup Program.
- **G28**: Set reference point: This code moves the machine to its home position and sets the machine position to 0,0,0. The G28 code performs an automatic calibration of the axes.
G92  Set position: This code works like the Set Position command under the Setup Menu. The X, Y and Z coordinates following a G92 code define the new current position of the tool.

G98  Rapid move to initial tool position after canned cycle complete.

G99  Rapid move to point R (surface of material or other reference point) after canned cycle complete.

The Compensation Functions Group

Use the cutter compensation NC codes to automatically compensate for the variations in a cutting tool’s radius and length. Refer to Reference Guide: Section H for more information on using cutter compensation.

The supported Compensation codes are:

G39  Corner offset circular interpolation.
G40  Cancel cutter compensation.
G41  Left cutter compensation: Enables cutter compensation to the left of programmed tool path.
G42  Right cutter compensation: Enables cutter compensation to the right of programmed tool path.
G43  Tool length offset: Shifts Z axis in a positive direction by a value in the Offset Table, specified by an H code.
G44  Tool length offset: Shifts Z axis in a negative direction by a value in the Offset Table, specified by an H code.
G45  Tool offset adjust: Increases the movement amount by the value stored in the offset value memory.
G46  Tool offset adjust: Decreases the movement amount by the value stored in the offset value memory.
G47  Tool offset adjust: Increases the movement amount by twice the value stored in the offset value memory. Refer to the User’s Guide for more information.
G48  Tool offset adjust: Decreases the movement amount by twice the value stored in the offset value memory.
G49  Cancels tool length offset.
G50  Cancels scaling.
G51  Invokes scaling.
G68  Invokes rotation.
G69  Cancels rotation.
The Coordinate System Group

Use the coordinate system codes to establish multiple coordinate systems on one or more workpieces to create multiple parts.

For instance, you can run a part program using a typical coordinate system (with the point of origin on the surface of the front left corner of the workpiece), then select another coordinate system which has its origin at a different point on the surface of the workpiece.

There are seven coordinate system codes. One of these codes (G53) is used to rapid to specified machine coordinates. The other six codes allow you to make up to six individual parts on the same workpiece by specifying different work coordinate systems for each part.

The coordinate system codes are G54 through G59, referring to coordinate systems 1 through 6 respectively. These coordinate systems may be set through the Coordinate Systems command on the Setup Menu.

The Polar Programming Group

The polar programming codes allow you to perform polar programming operations, based on polar coordinates. The polar coordinates are defined by X (radius) and Y (angle in degrees) when programming for the X, Y plane.

Refer to Section H for more information on using polar programming.

The supported Polar Programming codes are:

G15 Polar programming ON
G16 Polar programming OFF

Compensation Offset Value (D Code)

The D code is used to select a value from the Control Program’s Offset Table. For example, D1 selects entry number 1 from the Offset Table. Selecting offset 0 (D0) cancels cutter compensation.

Use the D code with:

- Cutter compensation codes to specify the tool radius.
- Tool offset adjust codes to specify a consistent increase or decrease in the commanded movement.

Use the Offsets command under the Setup Menu to view and manage the Offsets Table.
Input Selection Number/Tool Length Offset (H Code)

The H code has multiple uses. It can be used to specify inputs, input state changes, outputs, and offset amounts.

Use the H code in conjunction with:

- The wait codes G25 and G26, to specify the input number. If the H code is NOT used with these G codes, input 5 is assumed.
- The wait code G31, to specify input change to high or low. If the H code is NOT used with this G code, input 5 High is assumed.
- The tool length offset codes G43 and G44, to specify the amount of Z axis shift. The Offset Table you use for Tool Length Offset H values is the same table you use for Cutter Compensation and Tool Offset Adjust D values.
- The transmit codes M25 and M26 for interfacing with robots or other external devices, to specify the output number. If the H code is not used with these M codes, output 4 (Robot 1) is assumed.

H Code Inputs | H Code Outputs
--- | ---
H1 Emergency Stop | H1 Spindle
H2 Safety Shield | H2 Acc1
H3 +Limit | H3 Acc2
H4 -Limit | H4 Robot 1
H5 Robot 1 | H5 Robot 2
H6 Robot 2

X Axis Coordinate of Center Point (I Code)

In absolute programming mode (G90), the I code specifies the X axis coordinate of the center point of an arc or circle when using circular interpolation. In incremental mode (G91), the I code specifies the X axis distance from the start point of motion to the center point of the arc for circular interpolation.

If no I code is specified, the system uses the current X axis location as the X axis center of the arc.

In Fanuc mode, all arc centers are incremental.

The I code is also used with the G51 code to specify the scale factor for the X axis when performing scaling functions, including scaling each axis and mirror scaling. Refer to Reference Guide: Section H for more information on using scaling.
Y Axis Coordinate of Center Point (J Code)

In absolute programming mode (G90), the J code specifies the Y axis coordinate of the center point of an arc or circle when using circular interpolation. In incremental mode (G91), the J code specifies the Y axis distance from the start point of motion to the center point of the arc for circular interpolation.

If no J code is specified, the system uses the current Y axis location as the Y axis center of the arc.

In Fanuc mode, all arc centers are incremental.

The J code is also used with the G51 code to specify the scale factor for the Y axis when performing scaling functions, including scaling each axis and mirror scaling. Refer to Reference Guide: Section H for more information on using scaling.

Z Axis Coordinate of Center Point (K Code)

In absolute programming mode (G90), the K code specifies the Z axis coordinate of the center point of an arc or a circle when using circular interpolation. In incremental mode (G91), the K code specifies the Z axis distance from the start point of motion to the center point of the arc for circular interpolation.

If no K code is specified, the system uses the current Z axis location as the center of the arc.

In Fanuc mode, all arc centers are incremental.

The K code is also used with the G51 code to specify the scale factor for the Z axis when performing scaling functions, including scaling each axis and mirror scaling. Refer to Reference Guide: Section H for more information on using scaling.

Angle of Arc Resolution, Loop Counter (L Code)

The L code specifies the angle of arc resolution in circular interpolation programming. When the system executes a circular motion, it actually splits the arc into a series of line segments to approximate the circle. The L code specifies the angle in degrees which a line segment approximates a portion of the arc. The smaller the angle, the smoother the cut. A negative value for L will generate a normalized L factor (degrees x radius [in inches]) so larger radii have smaller degree values. For example, with the default L factor of -1:

An arc with a radius of 1 inch will have line segments approximating every 1 degree of the arc.
An arc with a radius of .5 inches will have line segments approximating every 2 degrees of the arc (Degrees = -L/R, or Degrees = -(1) / .5, which is 2).

Note that the line segments generated by a normalized L code are always approximately the same length regardless of the arc’s radius (The length of the arc segment being represented by each line segment is exactly the same).

The default setting for the Machining Center is -1, and typically this will work quite well. You may notice the Machining Center hesitating on arcs if the resolution is too fine. The L code can be a fraction of a degree (such as L.5), but it must be large enough so the Machining Center will move at least the minimum motion (.0005”) on each of the straight line motions.

Use the L code with:

- The M98 code as a loop counter for subprograms.
- The M47 code as a program cycle counter, to repeat a program a finite number of times.
- The G27 code to specify tolerance with homing commands (this is an LMC-specific NC language extension). The difference between the current position and 0 is compared to a tolerance value specified using the Setup Program; use the L code to override this tolerance value.
- An L code that is not used by one of these codes is used as an Arc Resolution factor.

### Miscellaneous Codes (M Codes)

M codes control a variety of Machining Center functions while a part program is running. Only one M code should be specified per NC block. M codes and motion commands should be placed on separate blocks to avoid confusion over whether an M code is activated during or after a motion command.

The supported M codes are:

- **M00** 
  Pause: Allows you to place a pause in your code. Acts like a G05 pause.

- **M01** 
  Optional Stop: Allows you to place an optional pause in your code. Place an M01 in the block of code where you would like to pause. There are switches to activate or deactivate the Optional Stop code in the Run Settings dialog box and on the Operator Panel. With Optional Stop on, the M01 works like a G05 pause. With Optional Stop off, the M01 code is ignored, and the other codes on the block are executed as usual.

- **M02** 
  End of Program: Takes effect after all motion has stopped; turns off drive motors, and all outputs, including the spindle and the accessory outlets.
M03  Spindle Motor On: Activated concurrently with motion specified in the program block; remains in effect until superseded by M05.
M05  Spindle Motor Off: Activated after the motion specified in the program block; remains in effect until superseded by M03.
M06  Tool Change: Pauses all operations, turns off spindle, retracts spindle for tool change. If you are using an ATC, this performs the complete tool change cycle.
M08  Accessory #1 On: Turns on ACC 1 accessory AC outlet concurrently with the motion specified in the program block; remains in effect until superseded by M09. This is the same as using the M25 H2 codes.
M09  Accessory #1 Off: Turns off ACC 1 accessory AC outlet after the motion specified in the program block is completed; remains in effect until superseded by M08. This is the same as using the M26 H2 codes.
M10  Accessory #2 On: Turns on ACC 2 accessory AC outlet concurrently with the motion specified in the program block; remains in effect until superseded by M11. This is the same as using the M25 H3 codes.
M11  Accessory #2 Off: Turns off ACC 2 accessory AC outlet after the motion specified in the program block is completed; remains in effect until superseded by M10. This is the same as using the M26 H2 codes.
M20  Chain to Next Program: This code is used to chain several NC files together. It appears at the end of a part program and is followed on the next line by the file name of another program which is executed when all motion stops. Here’s an example of a part program chain to another program:
   N37 Z.2
   N38 M20
   PROGRAM2.NC; Chain to PROGRAM TWO
If the two programs you are chaining are not in the same directory on your computer, you must specify the full path name for the next program file. If the software cannot locate the specified file, you will be prompted to find it.
M22  Output current position to file
M25  Set TTL output #1 (Robot 1 or Output 4) On: Used for robot synchronization (see Sections K and L for more information). Use the H code to specify an output other than the default, H4.
M26  Set TTL output #1 (Robot 1 or Output 4) Off: Used for robot synchronization (see Sections K and L for more information). Use the H code to specify an output other than the default, H4.
M30  End of program: Same as M02.
M35  Set TTL output #2 (Robot 2, or Output 5) On: Used for robot synchronization (see Sections K and L for more information).

M36  Set TTL output #2 (Robot 2, or Output 5) Off: Used for robot synchronization (see Sections K and L for more information).

M47  Rewind: Restarts the currently running program; takes effect after all motion comes to a stop. Typically used with an L code to repeat a program a set number of times.

M98  Call to subprogram. Use the P code to specify the subprogram starting block number. Use the L code to specify the number of times the subroutine is executed. You can nest subprogram calls to a depth of 20.

M99  Return from Subprogram; Goto

M105 Operator Message (LMC)

**M22: Output Current Position to File**

The M22 code is used to write information to a file while a program is running. Typically, this code is used when digitizing to write the current X, Y, and Z machine coordinates to a file. The proper format for using this code is:

M22(filename) Data to Write to File. The first time the Control Program encounters an M22 code, it opens the specified file. You must enclose the name of the file in parentheses for the Control Program to recognize it. If you do not specify any DataToWriteToFile text, the default data is output. This default is the current position, equivalent to specifying `X@X Y@Y Z@Z`. Notice that the @X,@Y,@Z 'macros' are replaced by the actual machine position when the data is written. Each M22 code automatically adds a linefeed to the end of its output so the next M22 starts on a new line.

If the file name is followed by “,A” (e.g., test.nc,A), the Control Program does not delete previous information from the file, it appends the information to the end of the existing information. If the file does not exist, it is created.

If you use more than one M22, only the first occurrence must have the file name in the parentheses. The remaining M22’s may have empty parentheses, ( ), or may specify a different file.

If you want to generate more than one file at a time, you must include the filename each time you specify M22. If a filename is not specified, the first file opened is used.

**Example:**

```
...; code to move to position
; Open my1.xyz, discard contents, write coordinates
M22(my1.xyz)
```
Information about digitizing is provided with the digitizing package. For additional information, please call Light Machines Technical Support.

Special codes that can be used with M22 to generate run-time reports.

- @X Current X position (in current coordinate system).
- @Y Current Y position (in current coordinate system).
- @Z Current Z position (in current coordinate system).
- ~ (tilde) New Line (starts a new line in the file).
- @TD Time of Day (12hour) “11:59:59AM”
- @TC Time (elapsed) for cycle “99:11:59” (0’s trimmed from left)
- @TT Time Total (program run) “99:11:59”
- @TA Time Average (per cycle) “99:11:59” (“???:??” if first part)
- @TL Current Tool #. “5”
- @C Cycle # (Current Pass) “3”
- @D Date “12/31/94”
- @FN Current File (w/o path) “PART.NC” (“UNTITLED.NC” if untitled)

\t TAB
\\ Outputs a single ‘\\’ character.

Example:

; Start of file
... ; Process a single part
; Output part time statistics to file c:\Reports\Stats.txt
(c:\Reports directory must exist)
M22 (c:\Reports\Stats.txt,A) Part #@C processed in @TC.
M47 L50 ; We want to process 50 parts.

M99: Return from Subprogram, Goto

The M99 code has two specific uses; it can be used as a command to return from a subprogram or it can be used as a goto command.

Using M99 with subprograms:

When used in a subprogram, this code returns you to the block following the last M98 (Call to Subprogram) command. If the M98 used an L code to specify multiple calls to the subprogram, the M99 will return to the block containing the M98 until all the specified number of subprogram calls have been made; then it will proceed to the block following the M98.
You can use the P code plus a block number to override the block returned to; however, if this feature is used from a nested subprogram call, all return targets are discarded. The rules for a Goto target block apply to this use as well.

Using M99 as a Goto command:

This command can be used in the main NC program as a Goto command to jump to a block on a line before the first subprogram (as denoted by the O code).

Use the P code to identify the block number being jumped to. Control is transferred to the first occurrence of this N code; it cannot be used to transfer control between chained programs (see M20).

This command can be used anywhere in the program to change the flow of program execution. It is good programming practice to place this command on a line by itself to improve the program’s readability.

M105: Operator Message

This command is used to display messages in the Control Program. It provides a way to display messages to the operator on the message bar while an NC program is running. You can also pause the program with a custom message. This is a non-standard, Light Machines code.

By default, the message is centered, displayed as a Normal Message, and is persistent (not cleared until the program clears it or until the next message is displayed).

The correct format for using this code is:

M105(the message);comment

For instance, the following line of code displays a simple message:

M105(End of Roughing Segment);Normal Message; doesn’t pause

Messages can be altered by using the following alternate characters:

^ Displays the message and performs a pause requiring operator intervention to continue.
~ Displays the message as a Warning Message.
\b Beeps when the message is shown.

The format for using the M105 code with an alternate character is:

M105(alternate character plus the message) ;comment
For example:
M105(~-WARNING);Warning Message , doesn’t pause

Here are some other examples of how to use this code:
M105( ); clears current message
M105(^Please stop and read this!); Normal Message, pauses
M105(~^I MEAN IT!); Warning Message, pauses
M105(^b^b^b); Clears current message, beeps 3 times, and doesn’t pause

### Block Number (N Code)

N codes have two uses:

- To provide destinations for Gotos (M99) elsewhere in the program.
- To clearly show the organization of the code and improve readability.

Using the N code is optional; however, when you do use the N code, it must be the first character in the block.

Other than for the above stated uses, N codes are ignored by the Control Program. Their presence, absence, or sequential value does not affect the execution of the NC program in any way (unless the target of a goto is missing).

You may have N codes on some blocks and not on others. N code sequence numbers do not have to be in order, but regular sequential order does make it easier to follow and reference sections of the program. The Control Program can change the N codes in a program by inserting, removing, or renumbering them.

### Subprogram Block Number (O Code)

The O code is used to indicate the start of a subprogram, and must be followed by a number which identifies the subprogram. The O code replaces the N code in the first block of the subprogram.

To call a subprogram, use the M98 code; use the P code to specify which subprogram to execute. To return from the subprogram, use the M99 code.

Only the first block in the subprogram contains the O code. The remaining blocks may contain N codes. The O and N code numbers may be used to help identify and set apart the subprogram to improve readability, for example:

M98 P50000 ;call to first subprogram
…;after first subprogram is finished, M99 code returns to this point
...
M98 P60000 ;call to second subprogram
…;after second subprogram is finished, M99 code returns to this point
…
Subprogram Reference Number (P Code)

Use the P code with:

- The G31 code to reference a goto target block.
- The G51 code to specify a uniform scaling factor.
- The M98 code to reference a subprogram using the subprogram block number.
- The M99 code to specify a return block number as a goto target.

Peck Depth (Q Code)

The Q code is used with the G83 code in canned cycle peck drilling to specify the incremental depth of each peck.

Radius of Arc, Drilling Start Location (R Code)

As an alternative to specifying the center point of an arc (I Code, J Code, or K Code) you can specify the arc radius. Use the same value for the radius in both absolute and incremental programming modes.

G02 or G03 specifies the direction of motion.

Positive values for R (radius) are specified for arcs up to 180°. Negative values are used for arcs greater than 180°. Full circle arcs cannot be performed with an R code. Split the circle into two arcs, or use center point (I, J, and K) values for full circles.

Use the R code in canned cycles to specify a Z axis reference point for peck drilling. The point can be at the material surface or at another reference point. The R code is also used to specify the rotation angle, in degrees, with the G68 code.
Spindle Speed (S Code)

Use the S code to set the spindle speed from within the NC program. Spindle speed is specified by the address character “S” followed by a parameter that represents the speed in RPMs. For example, S750 is the designation for a spindle speed of 750 RPMs. For the spindle speed to have affect the spindle must be turned on by the M03 command. If the spindle is off, the spindle speed is stored and used when the spindle is turned on again within the program. Use the M05 command to turn the spindle off.

Tool Selection (T Code)

T codes specify the tool offset (number) in the Tool Library in multiple tool machining operations. They do not specify the Automatic Tool Changer (ATC) tool number, but they do have an ATC station associated with them. Tools are specified by the address character “T” followed by a parameter that represents the number of the tool. For example, T3 is the designation for tool number three.

X Axis Coordinate (X or U Code)

An X code specifies the coordinate of the destination along the X axis. A U code is used in absolute programming mode (G90) to specify an incremental X motion. You cannot use the U code to mix incremental and absolute programming in the same block.

Y Axis Coordinate (Y or V Code)

A Y code specifies the coordinate of the destination along the Y axis. A V code is used in absolute programming mode (G90) to specify an incremental Y motion. You cannot use the V code to mix incremental and absolute programming in the same block.
Z Axis Coordinate (Z or W Code)

A Z code specifies the coordinate of the destination along the Z axis (spindle axis). A W code is used in absolute programming mode (G90) to specify an incremental Z motion. You cannot use the W code to mix incremental and absolute programming in the same block.

Comment Codes

The Control Program allows you to add comments to your NC blocks. The Control Program recognizes two comment codes:

- A semicolon “;”
- An open parenthesis “(“

These two comment codes are equivalent. The use of either of these codes at the end of an NC block indicates that a comment follows.

Comments must follow all other NC codes in the block. Comments are ignored when the part program is executed. Comments can be placed on a block without any NC codes to document what is occurring within a program. NC programmers use these comments to annotate their programs.

Here is an example of an NC block with a comment:

```
X0Y0Z0;MOVE TO ZERO POINT
```

The comment tells us that the X, Y and Z codes in this block command the cutting tool to move to the zero point (coordinate 0,0,0).

Comments can be combined with the G05 pause and the M06 Tool Change codes to display messages to the operator during program execution. Here is an example of an NC block with a pause coded comment:

```
G05(ROUGH DIAMETER SHOULD BE 0.5 in.)
```

When the program pauses, the program line, and thus the comment, is displayed on the message bar, telling the operator to verify the diameter of the workpiece before continuing. The M105 code provides a more versatile and powerful message facility.

The Control Program can strip the comments from a program with a single command; however, comments cannot subsequently be replaced automatically.
General Programming Suggestions

The following rules should be followed when writing NC part programs.

1. The sequence of words (address characters plus parameters) in an NC block must appear in the following order: \( /, N (O), G, X (U), Y (V), Z (W), A, I, J, K, R, Q, H, L, F, S, T, M, P, ; \) A different order may cause unpredictable results.

2. In many cases, a word need not be repeated in the next block (line). The system assumes no change in codes unless a new code appears. This does not apply to: N words, I, J, and K, G04, G05, G25, G26, G92, F used for dwell, M02, M20, M25, M26, M30, M47, M98 or M99.

3. You can use more than one G code in a block; however, you can use only one G code from any one group in a single block.

4. N codes (sequence numbers) are not required in a part program; however, they can be useful in identifying a block when editing a long NC part program.

   An O code is required to mark the beginning of a subprogram and does not have to be in sequence with the N codes.

5. The first instruction in a part program should move the tool to the starting position. This makes restarts much easier.

6. The last block of a program should move the tool back to the starting position. The tool will then be in position to start cutting another part.

7. Part programs should reference the zero point with Z0 at the point where the tool just touches the work piece. This convention allows for standardization of programming.

8. Before running an NC part program:
   a. Look for the typical coding error that places two X codes, two Y codes, or two Z codes in the same block.
   b. Be sure that all required coordinates have been written into appropriate blocks.
   c. Verify the part program to discover any program errors.
   d. Run the part program without mounting stock in the Machining Center to see if the tool movements are logical.

9. The first portion of a part program should turn on the spindle and establish the feed rate and spindle speed.

10. M codes should be placed on separate blocks to avoid confusion over whether an M code is activated during or after a motion command.

11. Double-check all program blocks against your coding sheet to locate and correct typographical errors.
More CNC Programming

Linear Interpolation Programming
Circular Interpolation Programming
Rapid Traverse Programming
Canned Cycle Programming
Subprogram Programming
Linear Interpolation Programming

Linear interpolation is the movement of the tool in a line from its current position to a coordinate location specified by an NC block. Here’s a typical block of NC code using linear interpolation:

\[ \text{N5G90G01X.7Y1.2F2} \]

Broken down into individual words:

- **N5** The block sequence number is 5
- **G90** Coordinates are given using absolute dimensioning
- **G01** Linear interpolation is specified
- **X.7** X axis coordinate of end point = .7
- **Y1.2** Y axis coordinate of end point = 1.2
- **F2** Feed rate is 2 inches per minute

The G01 code is required when switching from circular interpolation or rapid traverse positioning back to linear interpolation. If we assume the current position of the tool is X.5, Y.5, the tool movement generated by the above block is something like this:

An equivalent movement is achieved with incremental dimensioning (G91):

\[ \text{N5G91G01X.2Y.7F2} \]
Circular Interpolation Programming

Circular interpolation moves the cutting tool along an arc from the starting point specified in one block, to an end point specified in the next block. The curvature of motion is determined by the location of the center point (I, J, or K), which must also be specified in the second NC block.

The direction of rotation from the starting point determines the actual shape of the arc relative to the spindle axis. A G02 code moves the tool in a clockwise (CW) motion from the starting point. A G03 code moves the tool in a counterclockwise (CCW) motion from the starting point.

Here are two typical blocks of NC code using circular interpolation:

N9G90X1Y0; SET START POINT
N10G03X0Y1I-1J0F2; COUNTERCLOCKWISE TO X0,Y1

The first block defines the starting point. The second block defines the end point and the center of the arc. Broken down into individual words, the second block reads:

N10 The block sequence number is 10
G03 The tool will proceed in a counterclockwise direction from the starting point to specified (X, Y) coordinates; center point of arc is specified by (I, J) coordinates
X1 X axis coordinate of end point = 0
Y0 Y axis coordinate of end point = 1
I-1 I coordinate of center point of arc = -1 (relative to start point)
J0 J coordinate of center point of arc = 0 (relative to start point)
F2 Feed rate is 2 inches per minute
The tool path generated by the preceding block is something like this:

An equivalent movement is achieved with incremental dimensioning (G91):

```
N9G91X1Y0; SET START POINT  
N10G03X-1Y1I-1J0F2
```

In this NC block, the X and Y values are the distance the tool is to move from its current position. In both cases, the I and J values are equal to the X and Y distance from the start point to the center point.

---

**Circular Interpolation on Other Planes**

To perform circular interpolation on a plane other than the X, Y plane, use a G18 code to select the X, Z plane, or use a G19 code to select the Y, Z plane. This feature is rarely used in manual part programming, but may be used by CAM systems to generate surfaces of revolution. The G17 code is used to return to the X, Y plane. An example of circular interpolation on the X, Z plane is:

```
N9X0Z0  
N10G90G18G03X0Z1I0K.5F2
```

In this NC block, the X and Z values are the destination position of the tool. The I and K values are the incremental location of the center point of the curvature of motion.
Helical Interpolation Programming

Helical interpolation is performed when the axis not used in circular interpolation is commanded to move. For example (assuming a start point of 0,0,0):
N10G90G03X0Y1Z1I0J.5F2
This block would cause the Z axis to move at a constant feed to Z1 while the X and Y axes move in a circular path, resulting in a helical motion. Helical interpolation works with circular motion on the X,Z and Y,Z planes as well.
Here is an example of an NC program using helical interpolation.
G90M03S1500
G0X0Y0Z0.070
G0X2Y2
G1Z-0.5F10
G02X0Y2Z0I-1J0F10
M02
Rapid Traverse Programming

On the proLIGHT Machining Center, the rapid traverse code (G00) can move the tool at the maximum available feed rate (50 ipm) to specified coordinates. Rapid traverse is used to reposition the tool before ending a program, or in preparation for the next cut.

**WARNING**

The tool should not be engaged in a cutting operation while traversing to a new location!

Rapid traverse can be used for all tool positioning motions. This will reduce the run time for the part program. The G00 code remains in effect until linear (G01) or circular (G02, G03) interpolation is again specified. Linear or circular interpolation resumes at the feed rate last specified prior to the rapid traverse motion(s) unless you specify a new feed rate.

Here’s a sequence of typical NC blocks using rapid traverse:

- **G90G01X1F2;** MOVE IN A STRAIGHT LINE TO X = 1 AT 2 IPM
- **G00X2;** RAPID TRAVERSE TO X=2
- **X3;** RAPID TRAVERSE TO X=3
- **G01X4;** MOVE IN A STRAIGHT LINE TO X=4 AT 2 IPM
Canned Cycle Programming

Canned cycle commands allow you to perform drilling operations by specifying just a few codes. They are typically used for repetitive operations to reduce the amount of data required in an NC program. Canned cycle codes are retained until superseded in the program by another canned cycle code. The supported canned cycles codes are:

- **G80**  Canned cycle cancel
- **G81**  Straight drilling
- **G82**  Straight drilling with dwell at bottom
- **G83**  Peck drilling
- **G85**  Boring cycle
- **G86**  Boring cycle with spindle off (dwell optional)
- **G89**  Boring cycle with dwell

These codes are used in conjunction with canned cycle codes:

- **G98**  Rapid to initial position after canned cycle complete; this is the system default
- **G99**  Rapid to point R after canned cycle complete

**Q Code**  Specifies the depth of cut. In peck drilling each peck uses the same Q value. The Q value is always positive. If a negative value is specified, it is converted to a positive value.

**R Code**  Used for specifying a starting reference point for peck drilling. The point can be at the material surface or at another reference point.

Using G80

To cancel a canned cycle, use the G80 code. This code cancels the currently running canned cycle and resumes normal operation. All other drilling data is canceled as well. You can also cancel canned cycles by using a G00 or G01 code; a G80 is automatically performed before the G00, G01, G02, or G03.
**Using G81**

The G81 code performs straight drilling operations. By specifying an R value of zero, the tool will return to the initial point after drilling to point Z. Here is a sample G81 program.

```
G0X1Y1Z.1;RAPID TO 1, 1, .1
G81G98Z-.5R0F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL POINT
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
```

This program will generate tool motions similar to this:

If we specified a G99 here instead of a G98, the tool would rapid to point R instead of the initial point.

More than one canned cycle can be accomplished by specifying only X and Y coordinates. For example:

```
G0X1Y1Z.1;RAPID TO 1, 1, .1
G81G98Z-.5R0F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL POINT
X.5Y1;PECK AT NEW X,Y COORDINATES
X.25Y1;PECK AT NEW X,Y COORDINATES
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
```
Using G82

A G82 works just like a G81, except it is used when you wish to incorporate a dwell (P code) at the bottom of the hole (point Z). A block of code utilizing the G82 and P code, and the tool motion it creates are shown below.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G82G98Z-.5R0P5F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL POINT AFTER A DWELL OF FIVE SECONDS
G80;CANCEL CANNED CYCLE
M2;END PROGRAM

If we used a G99 with the G82 instead of a G98, the tool would rapid to point R instead of the initial point.

Using G83

The G83 code is used for peck drilling cycles. By adding a Q depth to the code block, you can specify drilling increments. For instance, the following code will peck drill to a depth of -.5 in .1 increments. The tool will rapid back to point R after each peck drill. Also, before each peck the tool will rapid to .005 (.13mm) above the start point.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G83G99Z-.5R0Q.1F3;PECK DRILL TO DEPTH OF -.5, RAPID TO R
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
G99 returns the tool to point R. Use G98 with the G83 to return the tool to the initial point at the end of the canned cycle.

---

**Using G84**

A G84 is used for tapping threads. You specify the depth of the tapped hole. When the tap reaches that depth, it is pulled out in at a rate 1.6 times the rate of insertion (60% faster). The G84 tells the computer to calculate the insertion/extraction ratio. You must use a tapping head with a reversing mechanism when using G84.

G0X1Y1Z1;RAPID TO 1, 1, .1
G84G98Z-.5R0F2;TAP TO DEPTH OF -.5, RAPID TO INITIAL POINT
G80;CANCEL CANNED CYCLE
M2;END PROGRAM
Using G85

A G85 specifies a boring cycle. After the tool plunges, it retracts at the same feed to point R. This sometimes gives a better surface finish on the hole. Then the tool rapid to the initial point.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G85G98Z-.5R0F2;BORE TO DEPTH OF -.5, RAPID TO INITIAL POINT FROM POINT R
G80;CANCEL CANNED CYCLE
M2;END PROGRAM

If G99 were specified instead of G98, the tool would not rapid back to the initial point. It would remain at point R.

Using G86

A G86 works like a G82 except the spindle stops at the bottom of the hole. The dwell (optional) allows the spindle to come to a complete stop before the tool rapid back to the initial point.

G0X1Y1Z.1;RAPID TO 1, 1, .1
G86G98Z-.5R0P5F2;DRILL TO DEPTH OF -.5, SHUT OFF SPINDLE, RAPID TO INITIAL POINT AFTER A DWELL OF FIVE SECONDS
G80;CANCEL CANNED CYCLE
M2;END PROGRAM

If a dwell is not specified (P code not used), a G05 pause is executed after the spindle stops at the bottom of the hole.
If G99 were used with the G86, the tool would not rapid back to the initial point. It would go to point R.

Using G89

The G89 code works like the G85 except it utilizes a dwell at the bottom of the hole.

G0X1Y1Z.1; RAPID TO 1, 1, .1
G89G98Z-.5R0P5F2; BORE TO DEPTH OF -.5, PAUSE FOR FIVE SECONDS THEN RAPID OUT FROM POINT R
G80; CANCEL CANNED CYCLE
M2; END PROGRAM
Subprogram Programming

Subprograms are used to execute repetitive routines in an NC program. Since a subprogram can be called again and again, you don’t have to enter the same data more than once. This is especially useful if the machining operation you wish to repeat is lengthy or complex. The NC codes used for subprogramming on the proLIGHT Machining Center are:

- **M98** Call to subprogram.
- **M99** Return from subprogram.
- **P Code** The P code is used to reference the first block of the subprogram (which begins with an O code). The P code immediately follows an M98.
- **L Code** The L code is used as a loop counter when used in subprogramming. The computer executes the subprogram as many times as defined by the L code. For instance, if the code is L5, the subprogram is executed five times. (Optional)
- **O Code** The O code replaces the N code on the first block of a subprogram.

A subprogram is called by an M98 and a P code. When an M98 calls the subprogram, the main program is interrupted while the subprogram is executed. The P code references the subprogram’s address (the first block of the subprogram). The first block of the subprogram uses an O code instead of an N code for block numbering.

When the M99 is executed, the main portion of the NC program continues to execute from the block after the subprogram was called.

Subprograms can also be nested within other subprograms. This means that while a subprogram is being executed, it can call another subprogram. The default number of levels that subprograms can be nested is 20 levels deep. You can change the default by using the Setup Program (click on the Setup icon in the WPLM1000 program group).
A Sample NC Subprogram

G05
M03S1000
; SAMPLE OF SUBPROGRAM
; USE 7.25 X 3.00 STOCK FOR VERIFY
G0X1Y1Z.1; RAPID TO 1, 1, .1
M98P1000L4; RUN SUBPROGRAM 1000 FOUR TIMES
G90G0X0Y0Z.1
M2; END OF MAIN PROGRAM
O1000; SUBPROGRAM TO MILL SQUARE AND MOVE TO NEXT POINT
G90G1Z-.1F2; PLUNGE AT CURRENT LOCATION
G91; INCREMENTAL COORDINATE
X1F5; FIRST MOVE, FEED RATE 5
Y1; SECOND MOVE
X-1; THIRD MOVE
Y-1; FOURTH MOVE
G90G0Z.1; RAPID UP ABOVE WORK
G91X1.5; RAPID TO START OF NEXT SQUARE
M99; RETURN FROM SUBPROGRAM

The M98 calls the subprogram that begins on block O1000 (referenced by P1000) and tells it to repeat four times.
Advanced CNC Programming

Using Polar Programming
Using the Homing Commands
Using Cutter Compensation
Using Scaling and Rotation Codes
Using Tool Length Offset Codes
Using Tool Offset Adjust Codes
Using Polar Programming

Using polar coordinates allows you to specify a radius and an angle by specifying a G16 code (polar programming on), then X and Y codes. The X code specifies the radius. The Y code specifies the angle in degrees. A G15 is used to cancel the polar programming mode. This programming method can be used in both absolute and incremental programming.

Polar programming is especially useful when writing programs for machining bolt holes. An L code can be used as a multiplier for the angle value. For instance, this bit of code:

G0X0Y0Z0.07
M03
G16
G91X2Y0
M98P1L12
M2
O1Y30
G81Z-.1R0
G80
M99

combines the use of polar programming with a canned cycle and a subprogram to drill a hole at 30° increments. The L value was determined by dividing 360 degrees by 30.

You can also cut an arc using code similar to:

G16
G91X2Y0
M98P1L360
G15
M2
O1Y1
M99

In polar programming, the center point is the origin if you specify G90 and the radius (X code). The center point is the current center if you specify only the angle (X and Y codes). The center point is the current point if you specify G91 and the radius (X code).
Using the Homing Commands

The Homing commands allow you to establish a point of origin at the ends of travel on the Machining Center. The Machining Center uses this point as a reference for all machine coordinate movements. This allows the machine to move consistently to the same location.

Using G28

The G28 code “homes” the machine: it moves the Machining Center’s spindle, cross slide, and saddle to the ends of travel along each axis and sets the Machine Coordinate System to (0,0,0). This zero point is located at the positive limits of the Y and Z axes, and the negative limit of the X axis. Use G28 to automatically initialize the machine every time it’s turned on. See the sample NC program below for one use of the G28 code.

Using G28 in an NC Program

Here is an example of an NC program using Homing Commands (the Homing Commands and related commands are in bold):

```
G28; HOMING THE MACHINE
M3S1000; SPINDLE MOTOR ON SPEED 1000
G54; USE COORDINATE SYSTEM ONE
G0X0Y0Z0; RAPID TO O,O,O
G1z-0.070F5; CUTTING THE PIECE
G1X3
G1Y4.25
G1X0
Y0
G0Z0.070
M2
```

The G28 Code homes the machine and sets the Machine Coordinates and World Coordinates to zero. Use a G27 if you want to check the home position, but do not want to set that position to zero.

The G54 calls up coordinate system one, which contains the offset values relative to the machine’s home position. These are the values you entered.
for coordinate system one in the Offset from Machine Zero dialog box under the Set Coordinates dialog box. The coordinates in the Position Window on the screen change to the coordinates of coordinate system one.

The next line (G0X0Y0Z0) calls for the machine to perform a rapid traverse motion from the Home position to point 0,0,0 in coordinate system one.

The remaining lines of code instruct the machine to cut a square in a piece of stock.

**Using G28 Before Setting Soft Limits**

Remember, Soft Limits are based on Machine Coordinates. You can not use Soft Limits until you have set the machine to the reference point using the G28 code or pressing the Home button in the Set or Check Reference Point dialog box (access using the Set/Check Home command under the Setup Menu).

---

**Using G27**

After you have set a reference point (using either the Set Reference Point button in the Setup Coordinate System dialog box or a G28 code), you can use the G27 code to check the actual machine position against the expected machine position. This command causes the machine to perform a homing-like function, moving each axis independently from its current position to the reference point. The Control Program then compares the current position to the one set by the G28. If the deviation is larger than a threshold you can specify in the SETUP file, the Control Program reports an error is after all axes are checked. If there is no deviation, the program continues.

G27 also takes an optional position specified by XYZ. This position is called the *intermediate position*. You do not need to specify all axes for the intermediate point, but for each axis that you specify the current coordinate for the intermediate point is updated to that value. Only axes that have specified coordinates move when you specify an intermediate point. For example, if the first intermediate point commanded is G27Z.6, the
intermediate point motion is only to move the Z axis to .6. The machine first moves to the current intermediate point at rapid traverse, then performs the reference point check.

**Using G29**

The G29 code moves the tool at a rapid traverse rate to a coordinate specified by XYZ. If you have set an intermediate point on one or more axes, the machine first rapids from the current position to the intermediate point then continues to the specified destination. If you command a G29 code in Incremental mode, your specified XYZ point is relative to the intermediate point. If you have not specified an intermediate point, your specified XYZ point is relative to the current position. Use the G29
Using Cutter Compensation

Cutter compensation automatically adjusts the proLIGHT 1000 to compensate for variations in a cutting tool's radius. It uses values from the Offset Table (tool radius values) to determine the compensation offset value. Use the following codes for cutter compensation:

- G39  Inserts an arc at the corner of compensated path
- G40  Cancels cutter compensation
- G41  Invokes left cutter compensation
- G42  Invokes right cutter compensation

D  Compensation offset value (Tool Radius Value)

Determine left and right cutter compensation in relation to the direction of the tool path. Use left compensation when you need to move the tool...
Cutter compensation mode begins when the following are met:

- A G41 or G42 code is commanded.
- The specified offset number is not 0.
- A move in any of the axes in the offset plane is commanded. The move is not 0.
- No arc commands are commanded in the start up block.

You can start cutter compensation by inserting a G41 (for left compensation) or G42 (for right compensation) into your NC program. In the example below, left cutter compensation is enabled and the compensation value is equal to offset value 1 from the Offset Table.

```
G0X0Y0
G91; INCREMENTAL
G41D1; CUTTER COMP ON
G1X.25Y.25; MOVE TO P1
G1X0Y1; MOVE TO P2
G1X.75Y0; MOVE TO P3
G1X.25Y-.25; MOVE TO P4
```

1. This is the programmed tool path before cutter compensation is enabled. The tool sits at the start point waiting for the first motion command.

Select compensation offset values for D from the Offset Table. You can store 200 offset values in the table. Remember, however, that these offset values are the same values you use for adjusting tool length offsets.

**Starting Cutter Compensation (G41/G42)**

You can start cutter compensation by inserting a G41 (for left compensation) or G42 (for right compensation) into your NC program. In the example below, left cutter compensation is enabled and the compensation value is equal to offset value 1 from the Offset Table.
2. Because segment 1 begins before cutter compensation is enabled, the start point of segment 1 is on the original tool path. When cutter compensation is enabled, the Control Program creates Offset Vectors perpendicular to each segment of the programmed tool path to determine the compensated tool path.

Point A is located at the intersection of the Offset Vector of segment 2 and a point offset by the value of D on the Offset Vector of segment 1. Point A is located on a path parallel to the tool path, offset by the value of D.

Before beginning each motion, the Control Program looks ahead to the next motion in the NC code to determine the compensated end point of the first motion.

Using this method, the Control Program determines that point A is the end point of the first motion. The tool moves to point A on the compensated tool path.

3. The tool moves to the end point of segment 2 (point B) on the compensated tool path. Point B is the intersection of lines drawn perpendicular to the Offset Vectors of segments 2 and 3 with an offset value of D from the programmed tool path.
4. The tool moves to the end point of segment 3 (point C), which is located at the intersection of lines drawn perpendicular to the Offset Vectors of segments 3 and 4 with an offset value of D. The tool then begins travel towards point D, the end point of segment 4.

5. The tool moves to the end point of segment 5 (point E) on the compensated tool path. Point E is a point on the compensated path. (See Canceling Cutter Compensation in this section for more information.)
G1X0Y-.75; MOVE TO P5

The following illustrations show how the Control Program constructs the compensated tool path for the NC code above:

Note: When specifying an IJK vector, you must include the G41 or G42 code on the same line.

Cutter Compensation with IJK Vectors
Any G41 or G42 command can include an IJK vector, which defines the endpoint direction vector and the endpoint offset vector. For example, if, for segment 3 of the previous illustration, we had specified the compensated tool path would look like this:

\[ \text{G41 X.75 I1 J1} \]

The IJK Vector represents an incremental direction (the length of the vector is not important. For example, I1J2<>I3J6. By default, the end direction vector is tangent to the segment.

Note: You cannot assign a value to offset number 0. The offset value for offset number 0 is always zero.
Setting Cutter Compensation Offsets (D)

Select Setup Offsets from the Setup Menu to set the value for D (the cutter compensation offset value). The following dialog box appears:

Select an offset from the list to modify. Change its value in the Value Edit box, or use the Current Z button to use the current Z position.

Changing Offset Values

While cutter compensation is active, you can change offsets by specifying a new offset number with the D-code. For example:

N1G91
N2G41D1X.25Y.25
N3Y.25

In this example: D1 = .01 and D3 = .03
N4X.25D3; USE OFFSET #3
N5Y-.25
...

In this example, the offset number changes from 1 to 3 in line N4. Because the value of offset 3 is greater than the value of offset 1, the compensated path moves farther away from the programmed path and is at the new offset value by the time the tool reaches point C.

Changing Offset Sides

You can change the side of compensation sides during cutter compensation. For example, you can start cutter compensation to the left then change to the right while in cutter compensation:

G91
G41D1X.25Y.25; LEFT CC ON
Y.25
G42X.25; RIGHT CC ON
Y-.25
... In this example, left cutter compensation is on at point A, but right cutter compensation begins as the tool moves towards point B. In this case, the offset value (D) is the same for both left and right cutter compensation.

The same situation would occur if you made the offset value negative. For the example above, changing the D value from .01 to -.01 would produce the same result as changing from G41 to G42.

**Using Corner Offset Circular Interpolation (G39)**

The G39 code inserts an arc at the corner of a cutter compensated tool path. The G39 instructs the cutter compensation function to complete the current segment by moving to its default endpoint (the endpoint of the Offset Vector). It then creates an arc (with a radius equal to the offset
value), starting at the buffered segment’s default endpoint, and ending at the endpoint of the offset vector (IJ). Here is an example of an NC program using G39:

G91
G41D1...
...
Y.25
X.25
G39I0J-1; CORNER OFFSET

---

**Canceling Cutter Compensation**

Use the G40 code to cancel cutter compensation. G40 is effective for only one move. There are six methods for cancelling cutter compensation.

1. G40
2. G40XYZ
3. G40XYZIJK
4. D0
5. D0XYZ
6. G41/42D0XYZIJK

With methods 4 through 6 above, setting the offset number to zero has the same effect as cancelling cutter compensation. However, cutter compensation is still active.
Methods 1 and 4

With method 1 the G40 code cancels cutter compensation. The cutter moves from the offset path to the programmed end point. The same occurs with method 4, where you set the D value to zero.

G91G41D1

... X.25 Y-.25 Z.2; RETRACT G40; OR D0 X-.5Y-.25
Methods 2 and 5

With methods 2 and 5, the G40 (or the D0) cancels the cutter compensation, but a subsequent motion (X-.5Y-.25) is included in the program. The tool moves towards the programmed path in the direction of X-.5Y-.25.

G91G41D1
...
X.25
Y-.25
Z.2; RETRACT
G40X-.5Y-.25
M2

Methods 3 and 6

With these methods an IJK vector specifies the direction of movement after cutter compensation is cancelled.
G91G41D1
...
X.25
Y-.25
Z.2; RETRACT
G40X-.5Y-.25I-.5J-.25
M2

Using Scaling and Rotation Codes

Scaling codes and rotating codes can be used separately or they can be combined. Each of these functions is described in the following paragraphs.

Scaling

Use the scaling codes to scale one or more axes of a part from a fixed scaling origin. You can scale the entire piece uniformly, or set different scaling factors for each axis. Use the following codes for scaling:

- G50  Cancels scaling
- G51  Invokes scaling
- P    Uniform scale multiplier

Uniform Scaling

Use a P Code to scale an entire piece uniformly along each axis. When you specify a value for P, subsequent motions are scaled by that value, starting from the scaling center. The Control Program measures the distance from the scaling center to the start and end points of the shape, then multiplies those values by the P value.
In this example, a uniform scaling factor for all axes produces a shape scaled from the original.

The NC program below creates a half-circle then scales those motions by two to create a larger, uniformly-scaled half-circle (the scaling codes are in bold print):

```
N0G0Z.5
N1X1Y1.5
N2G1Z-.1F10
N3G2Y.5J-.5
N4G0Z1
N5G51X1Y1Z0P2; SUBSEQUENT MOTIONS SCALLED BY 2
N6G0Z.5
N7X1Y1.5
N8G1Z-.1F10
N9G2Y.5J-.5
N10G0Z1
N11G50; CANCEL SCALING
```

The values for X, Y, and Z in line N5 represent the absolute position of the scaling center. The P value represents the scale factor. In this example, the entire part is scaled by two. The G50 in line N11 cancels the scaling.

**Scaling Each Axis**

You can scale each axis by different magnifications. The following NC program uses scaling to change the proportions of a motion by scaling each axis separately (the...
Performing Z axis mirroring is an advanced operation. Use extreme caution when machining negative Z values.

Note: If you do not specify a scale factor for an axis, the value of that axis defaults to a factor of 1.

In this example, negative I and J values create a mirror image of the original shape.

CAUTION

The values for X, Y, and Z in line 5 represent the absolute position of the scaling center. The I, J, and K values represent the scale factors for the X, Y, and Z axes respectively. When scaling each axis individually, you do not use a P code.

Creating Mirror Images with Scaling

You can create mirror images of shapes by specifying negative values for I, J, and K. The NC program below uses negative I and J values to create a mirror image of the original shape on the XY plane (the scaling codes are in bold print):

N0G0Z.5
N1X1Y1.5
N2G1Z-.1F10  
N3G2Y.5J-.5  
N4G0Z1  
**N5G51X1Y1Z0I-1J-1K1; SCALING ON**  
N6G0Z.5  
N7X1Y1.5  
N8G1Z-.1F10  
N9G2Y.5J-.5  
N10G0Z1  
**N11G50; CANCEL SCALING**

The values for X, Y, and Z in line 5 represent the absolute position of the scaling center. The I, J, and K values represent the scale factors for the X, Y, and Z axes respectively. Notice the negative I and J values for mirroring on the XY plane. Remember that performing Z axis mirroring is an advanced operation. Use caution when machining negative Z values.

---

**Rotation Codes**

Rotation codes allow you to rotate a programmed shape around a rotation origin. You can rotate a shape on any plane, one plane at a time. Use the Rotation code to modify an NC program when a work piece has been rotated from the programmed position on the machine.

In this example, G68 rotates a shape 90° from the original.
G68  Invokes rotation
G69  Cancels rotation

Here is an example of an NC program using Rotation (the Rotation codes are in bold):

N0G0Z.5
N1X1Y1.5
N2G1Z-.1F10

Rotation Origin

Counterclockwise Positive Rotation Value

Clockwise Negative Rotation Value
**IMPORTANT!**

When combining the scale and rotate features, always scale the part first, before rotating it.

Notice that in this program the P Code is used to reference the first block of the subprogram (not shown in this example). The subprogram contains the code that creates each part.

The X and Y values in line N5 are the coordinates of the rotation origin; the rotation occurs around this point. The R value represents the absolute value of the rotation angle. The G69 in line N11 cancels the rotation.

Note that positive R values represent counterclockwise rotation angles; negative R values represent clockwise rotation angles.

---

**Combining Scaling and Rotation Codes**

You can combine scaling and rotation in the same NC program. The portion of the NC program below combines the scaling and rotation codes necessary to machine the following part (the actual subprogram to cut the shield (O100) is not listed here).

N1; DO THE ORIGINAL FIRST
N2M98P100

In this example, scaling and rotation are combined to produce different sized shapes that are scaled and rotated from the original.
N3; NOW SCALE BY 1/2 AND ROTATE 90 CCW
N4G51X1.583Y0Z0I.5J.5K1; SCALING ON
N5G68X1.583Y1.5R90; ROTATION ON
N6M98P100; SECOND PART
N7; NOW MIRROR AND SCALE BY 1/2, AND ROTATE 90 CCW
N8G69G50
N9G51X1.583Y0Z0I-.5J.5K1
N10G68X1.583Y1.5R90
N11M98P100; THIRD PART
N12; NOW SCALE BY 1/2 AND ROTATE BY 90 CW
N13G69G50
N14G51X1.583Y0Z0I.5J.5K1
N15G68X1.583Y1.5R-90
N16M98P100; FOURTH PART
N17; END OF PROGRAM

Multiple Tool Programming

The proLIGHT Machining Center allows you to define up to 20 different tools for use during milling operations. If your machine is equipped with an optional Automatic Tool Changer (ATC), multiple tool programs require very little user intervention, other than setup.

You will need to define tools, configure the ATC, and write the tool changes into the NC program. For defining tools and ATC configuration, the easiest method is to use the Setup Tool Wizard under the Tools menu. This will walk the user through all the setup steps.

Even if your machine is not equipped with the ATC, you may use the Wizard. Defining tools is explained in the tutorial on page D-8 of this
guide. Programming codes, reference tools, offsets, and testing are described below.

### Using Multiple Tool Codes

The T code is used in the NC program to offset the cutter so that the NC program becomes independent of the cutter length, which is set up in Tool Definitions. This means you can replace a worn tool with a tool of a different length without changing the NC program, just by entering new offsets. (Any actual tool change is performed manually.) The T code can be located anywhere within the block of NC code, but it is normally placed after the G code.

When you place T codes in your program for tool changes, you should also use the M06 code to retract and shut off the spindle. The M06 code is placed after the T code. This code instructs the Machining Center to shut off and retract the spindle to the top of the vertical column, where it pauses until you manually change the tool. Pressing the Return key will turn the spindle back on and move it back to the previous position to continue with the NC program.

### Establishing the Reference Tool

When using multiple tools, a reference tool, normally Tool #1, is set to zero for the Z axis. This establishes a reference tool position which is used as a reference point for additional tools. For demonstration purposes, we will use Tool #1 as the reference tool and Tool #2 as the additional tool.

To set the reference tool:

1. Decide on a reference point (a point on the workpiece, or on a gauge, where you will jog the tip of each tool).
2. Install a tool into the spindle.
3. From the Tools Menu, choose Select Tool. If the tool is not already defined in the pull down menu, see page D-8 to define the tool.
4. Choose the tool you are using, then click Select Tool.
5. If you are using a sensor, place it on the cross slide or other conductive surface.
6. Using the Jog Control Panel, jog tool #1 to the tip of the sensor until the lights come on.

---

**CAUTION**

If you are manually changing tools, do not use collets for tool changing. Use the Quick Change Tooling option to make sure the tool length protruding from the spindle does not vary each time you load a tool into the spindle.
7. Select Set Position from the Setup Menu, set the Z axis value to zero, and click OK.

Tool #1 is now established as the reference tool.

---

**Establishing Tool Offsets**

Now that the reference tool is established, additional tools can be assigned offsets. You can move the tool and accept its current Z axis position as the offset value, or you can manually enter offset values.

To set the offset for Tool #2:

1. Install tool #2 in the spindle.
2. From the Tools Menu, choose Select Tool. If the tool is not already defined in the pull down menu, see page A-60 to define the tool.
3. Choose the tool you are using, then click Select Tool.
4. Jog tool #2 to the tip of the sensor until the lights come on.
5. Select Setup, and then Offsets from the pull down menu.
6. Choose the correct tool (the description that matches the tool you installed) from the list, and click on the Current Z button at the bottom of the window. Select OK to save the value.
7. Repeat this process for each additional tool.

The offset for Tool #2 is now established.

---

**Testing Your Multiple Tool Program**

After setting all of the tool offsets, test run your program without a workpiece mounted and with the spindle speed turned down.

1. After installing Tool #1, close the safety shield, put on your safety glasses, and complete the safety checklist.
2. Select the Run/Continue command from the Program Menu. Enter zero as the start line and select Start. Throughout the test, be prepared to press the emergency stop switch on the machining center, or
the space bar on the computer keyboard in case of a tool crash. The computer will run the program until it reaches the M06 code. If your machine is equipped with an ATC, the tool change will take place automatically, and you may ignore steps 3-7. The M06 stops and retracts the spindle.

3. When the spindle has completely stopped and the Pause message appears on the screen, push in the emergency stop button on the machining center.

4. Open the safety shield.

5. Remove Tool #1 and install Tool #2, making certain it is securely fastened to the spindle.

6. Close the shield, and pull out the emergency stop button. Press the Return key on the computer keyboard. The spindle turns on and moves to the previous position. Operation continues as programmed until the next M06 code is encountered.

7. At each pause, repeat Steps 3 through 6, installing the appropriate tool at the appropriate points in the program.

8. Edit the program, if required. When you are satisfied that the program works correctly, mount the workpiece, set the spindle speed, and run your multiple tool program.

Understanding Coordinate Systems

For a beginning user, understanding coordinate systems can be difficult. The first thing to remember is, before performing most machining operations, you are required to set the machine to “home” position. This returns the machine to the machine zero point, and acts as a reference point for all operations. It is a good idea to home the machine at power on.

Machine Coordinates

Machine Zero is the extreme negative end of travel on the X and Y axes, and the extreme positive end of travel on the Z axis. This is a fixed point on the machine, and cannot be changed. The machine uses this as a starting point for all operations. If the machine is not homed (set to the machine zero) it cannot coordinate the position of the Automatic Tool Changer, or accurately locate the workpiece on the cross slide. The machine is homed by selecting Set/Check Home under the Setup menu, and choosing the Set Home button; or by using a G28 code in the NC program.
**Work Coordinates**

Once home is set, you load an NC program into the computer. Your program will need a point of origin to start from. Setting a point of origin will establish the work coordinates. Work coordinates relate to the workpiece, and are usually set from the top of the front left corner of the workpiece mounted on the cross slide. Once the stock is mounted on the cross slide, jog the spindle to the top front left corner of the workpiece. From the Setup Menu, select Set Position. The spindle coordinates appear in the dialog box. Click on OK to set the current tool position as the point of origin on the workpiece.

**Multiple Coordinate Systems**

For more advanced operations, such as machining multiple parts, you can set up multiple coordinate systems. For example, three or four workpieces are attached to a pallet, and the pallet is secured to the cross slide. Set the work coordinate point of origin \((0,0)\) at the corner of the pallet using the Set Position dialog box from the Setup Menu. After setting the corner of the pallet as the origin, select Coordinate Systems from the Setup menu. The Setup Coordinate Systems dialog box appears. Select a “User CS”, enter the coordinates for the first workpiece, and click on Apply. Repeat this procedure for as many User CS’ as necessary. (For a detailed description of the Setup Coordinate Systems procedure, see page E-47.)

---

**Using Tool Length Offset Codes**

Tool length offsets are included in the Tool Setup procedure on page E-36. When you command a tool change in the program and the tool is loaded, the offset is automatically read as part of the tool information that was entered when the tool was defined.
However, if you are programming in Fanuc mode, that information is not recognized. Use the tool length offset codes to adjust the machine for variations in tool lengths. The tool length offset codes are:

- **G43**: Compensate for a longer tool.
- **G44**: Compensate for a shorter tool.
- **G49**: Cancel tool length offset.
- **H**: Specifies the offset number from the offset table. (The Offset Table you use for Tool Length Offset H values is the same table you use for Cutter Compensation and Tool Offset Adjust D values.)

The G43 compensates for a longer tool by retracting the spindle away from the cross slide. The G44 compensates for a shorter tool by moving the spindle closer to the cross slide.

The T code normally specifies the tool, its diameter, and offset value. When you include a G43 or G44, the computer ignores the T code offset value and uses the offset you assign to H.

Here is an example of the tool length offset code used in an NC program:

```
M06
G43T2H1
```

The M06 code stops the machine. The G43 compensates for a tool that is longer than the reference tool. The T2 refers to the tool number and the tool diameter, but not the offset value. The H1 represents the offset value set in the Offset Table.
Using Tool Offset Adjust Codes

Use these codes for making critical dimension adjustments to the offset values. When you specify tool offset adjust codes, you can increase or decrease the movement distance of the specified axis by the offset value (D). The tool offset adjust codes are:

- **G45** Increases the movement amount by the value stored in the offset table
- **G46** Decreases the movement amount by the value stored in the offset table
- **G47** Increases the movement amount by twice the value stored in the offset table
- **G48** Decreases the movement amount by twice the value stored in the offset table

D Offset value

You must command a motion for tool offset adjust codes to adjust the offset values. Following are examples of the motions caused by tool offset adjust codes.

**G45**

1. The offset value increases the actual movement by 1.5 beyond the commanded movement.
General Machining Information

Feed Rate and Depth of Cut

Spindle Speeds

Feed Rate and Spindle Speed Selection

Lubricants and Coolants

Tool Types

Sharpening Tools
Two terms used in general machining are *feed* and *cut*.

Normal machining on the machining center involves removing material from the surface of the workpiece. This is accomplished by advancing the cutting tool into the workpiece by an appropriate amount (depth of cut).

The rate of tool travel is called the feed rate. On machines like the proLIGHT Machining Center, the tool does not advance into the workpiece; instead, the cross slide moves the workpiece beneath the tool. However, the same feed rate principle applies.

The depth of cut is set by the vertical column (Z axis) drive motor and the feed is controlled by the X and Y axis drive motors. The depth of cut and feed rate you select should depend on the turning speed of the spindle, the type of material and lubricant used, and the type of cutting tool used for the operation.

Excessive depth of cut and high feed rates place greater strain on the spindle, may bind the tool and workpiece, or produce a poor surface finish on the part.
Spindle Speeds

The relative hardness of the material and the type of cutting tool (end mill or drill) affect spindle speed. The harder the material is, the slower the speed should be.

High spindle speeds may produce excess heat which causes the workpiece to expand. If the workpiece expands, the cutting tool will rub rather than cut the material, resulting in a poor surface finish. Slow spindle speeds cause no harm, but may be inappropriate for finishing certain types of materials.

The load put on the spindle motor must also be taken into account. Heavy cuts at low speeds will make the motor run hotter than lighter cuts at higher speeds. The selected feed rate and depth of cut should not cause the spindle motor to greatly lose speed or cause the tool to chatter against the workpiece.

Feed Rate and Spindle Speed Selection

Feed rate selection for machining parts on the proLIGHT Machining Center depends on factors such as: type of material, type of cut, depth of cut, and spindle speed. The type of tool chosen to make the cuts also affects the depth of cut and, therefore, the feed rate. Consult your machinist’s handbook for selecting a feed rate based on spindle speed and material type. Experience and experimentation will enable you to establish feed rates best suited to particular applications.

Lubricants and Coolants

Lubricants remove heat from the tool and workpiece and are often used when high production rates are required or when cutting very hard materials, such as stainless steel. A mixture of one part soluble oil to six parts water may be used on steel to assist in producing a smoother finish and to reduce tool chatter. Aluminum and aluminum alloys may require the use of paraffin, oil or kerosene to prevent chips from welding to the tool’s cutting edge. Brass and cast iron are always milled dry.

When lubrication is necessary, small amounts of water-soluble cutting fluids are recommended for use on the proLIGHT Machining Center. Lubricants should be wiped from the machine after use, because some petroleum-based fluids may deteriorate the electrical wiring insulation, the plastic safety shield, or the computer enclosure.
Tool Types

Cutting tools are usually made from hardened steel and are ground to various shapes. The clearances ground behind cutting edges are adjusted for the type of material the tool will cut and the direction the tool will be fed along the workpiece.

Insufficient clearance behind the cutting edge will cause the tool to rub. Excessive clearance will produce a ridged or wavy finish due to the small length of tool edge in contact with the workpiece. Standard tool types are: end mills, center drills, drills and boring tools. Tools are often ground to shape by the operator to suit a particular cutting requirement.

End Mills

End mills come in two types: flat end mills and ball end mills. They should be sharp and must run true. Holding end mills in a drill chuck is a poor practice; use collets instead. Be certain the spindle speed is set correctly for the type of material being machined. An end mill can be instantly damaged if a cut is attempted at excessive speed.

When plunging into the workpiece, use a center cutting end mill. Center cutting end mills have teeth at the end of the mill going into the center of the mill.

Begin with light cuts and progressively increase cuts until satisfactory results are obtained. End mills should not be used for drilling holes, but they can be used to enlarge holes.

Center Drills

Center drills are used to drill holes in a workpiece. The workpiece is mounted in a vise or on the cross slide.

Use small amounts of cutting lubricant with center drills. Clear the drill frequently, otherwise the tip may clog and twist off even in soft materials.

Boring Tools

Boring tools are used to enlarge or modify a drilled or cored hole in a workpiece. The workpiece is mounted in a vise or on the cross slide. Clearance must be maintained behind the cutting point of the tool.

A slow feed rate and frequent tool withdrawals are required with boring tools because chips cannot freely escape from the hole. Depth of cut and feed rates must be reduced to avoid chatter.
Sharpening Tools

A cutting tool must be sharpened regularly to preserve its original cutting angle and shape. Longer tool life will be obtained from cutting edges if they are finished with a small oilstone. Only the cutting end and sides of the tool should be ground as required. Never grind the top face of the tool.
Safe Machining Center Operation

- Safety Rules
- Safety Checklist
- Lista de Seguridad
- Emergency Stops
Safety Rules

The following safety rules should be reviewed and practiced by all operators of the proLIGHT 1000 Machining Center.

Wear Safety Glasses

Foresight is better than no sight. During operation any power tool can throw foreign objects and harmful chemicals into your eyes. Always put on safety glasses or eye shields before starting up the Machining Center. Safety glasses or shields should provide full protection at the sides, as well as the front of the eyes.

Know Your Machine Tool

Read this guide carefully before you use the Machining Center and keep it readily accessible for quick reference. Know the intended applications and limitations of the Machining Center as well as its hazards.

Ground All Tools

The Machining Center has an AC power cord terminated by a three-prong plug. The power cord should be plugged into a three-hole, grounded receptacle. If a grounding adapter is used to accommodate a two-prong receptacle, the adapter wire must be attached to a known ground. Never remove the third prong from the plug on the AC power cord.

Keep the Safety Shield in Place

The safety shield should remain in place whenever the spindle motor is on or the cross slide is moving.
Remove Adjusting Keys and Wrenches

Make it a habit to check that keys and adjusting wrenches are removed from the Machining Center before turning on the machine.

Keep the Work Area Clean

Cluttered work areas and bench tops invite accidents.

Avoid a Dangerous Environment

Don’t use the Machining Center in damp or wet locations. Never operate electrical equipment in the presence of volatile and flammable petroleum-based solvents and lubricants.

Keep Untrained Visitors Away from the Equipment

Children, and visitors unfamiliar with the hazards of rotating machinery, should always be kept away from the work area.

Prevent Unauthorized Users from Operating the Machining Center

Lock and remove the key from the Machining Center control panel when the system is not in use.

Do Not Force a Tool

Select the feed rate and depth of cut best suited to the design, construction and purpose of the cutting tool. It is always better to take too light a cut than too heavy a cut.
### Use the Right Tool

Select the type of cutting tool best suited to the milling operation. Don’t force a tool or attachment to do a job it wasn’t designed to do.

### Dress Appropriately

Don’t wear loose clothing or jewelry which can get caught in moving parts. Wear a hat or net, or tie your hair back to keep it away from moving parts.

### Secure the Workpiece

Be certain that you have firmly secured the workpiece in the vise and the cutting tool to the collet before turning on the spindle motor.

### Do Not Overreach

Keep your footing and balance at all times so you won’t fall into or grab the moving machine.

### Maintain Cutting Tools In Top Condition

Keep cutting tools sharp and clean. Lubricate and clean machining center components on a regular basis.

### Disconnect Tools Before Servicing

Always use the emergency stop switch to disconnect power and disable the spindle motor before mounting or removing the workpiece, or changing tools. *Do not* rely solely on a programmed Pause command to disable machining center operation.
Avoid Accidental Starting

Make sure the power switch on the control box is off before plugging in the Machining Center power cord.

Use Recommended Accessories

To avoid stressing the Machining Center and creating a hazardous machining environment, use only those accessories designed for use with the proLIGHT 1000 Machining Center, available through Light Machines Corporation.

Tighten All Holding, Locking and Driving Devices

Tighten the collet. Do not over-tighten tool holding devices. Over-tightening may damage threads or warp parts, thereby reducing accuracy and effectiveness.

Keep Coolant Away from Electrical Components

Do not allow coolant to splash into or near the computer.

Do Not Operate the Machine Under the Influence of Alcohol or Drugs

Alcohol or drugs may impair your judgement and reaction time, which could contribute to an on-the-job accident.

Avoid Distractions While Running the Machine

Use simple common sense and pay attention while operating any piece of machinery.
Safety Checklist

Before you enter the work area:
- Put on safety glasses.
- Tie back loose hair and clothing.
- Remove jewelry including rings, bracelets and wristwatches.

Before machining a part:
- Make sure you have the correct tool for the job.
- Secure the tool properly.
- Make sure all tool positions have been properly initialized.
- Verify the NC program on the computer before machining.
- Remove all loose parts and pieces from the machine.
- Remove adjusting keys and wrenches from the machine.
- Close the safety shield.
- Only operate the machine after being properly trained in its use.
- Perform a dry run:
  - Set the spindle motor switch to lowest manual speed setting.
  - Make certain there is no workpiece in place.
  - Run the NC program to make sure all the moves make sense before running the program with a workpiece in place.
  - After completing the dry run, properly secure the workpiece to the machine.
  - Keep fluids away from all electrical connections, electronic or electrical devices, the computer and nearby electrical outlets.

While machining a part:
- Do not touch moving or rotating parts.
- Press the Emergency Stop button before opening the safety shield.
- Only open the safety shield after the spindle has stopped rotating.
- Press the Emergency Stop button whenever changing tools or mounting or removing a workpiece.
- Pull the Emergency Stop button out only after closing the safety shield.
- Keep all unauthorized persons away from the work area.
### Lista de Seguridad

**Antes de entrar en el área de trabajo:**
- Use sus lentes de seguridad.
- Procure recogerse el cabello y no usar ropa floja.
- No use joyería como: anillos, pulseras y relojes.

**Antes de trabajar a máquina una pieza:**
- Utilice la herramienta correcta para el trabajo. Asegurela de forma correcta en el husillo con una boquilla.
- Asegúrese que la posición de la herramienta de corte ha sido inicializada correctamente.
- Remueva todas las partes sueltas y coloquelas lejos de la Fresadora. Limpie todos los residuos de la Fresadora después de cada corrida.
- Cierre la guarda de seguridad antes de ejecutar cualquier operación en la Fresadora.
- Corra los programas por primera vez con el motor del husillo apagado y sin pieza de trabajo. Asegúrese que todos los movimientos sean correctos.
- Asegure la pieza de trabajo a la mesa. Quite las herramientas y llaves antes de cerrar la guarda de seguridad.
- Asegúrese que todos los contactos de corriente A.C. estén aterrizados.
- Mantenga los líquidos refrigerantes lejos de la Caja de Control, Computadora y cualquier Suministro Eléctrico.

**Mientras trabaja a máquina una pieza:**
- Nunca levante la guarda de seguridad mientras que la Computadora este ejecutando un programa. Presione siempre primero el botón de “Paro de Emergencia”.
- Presione siempre el botón de “Paro de Emergencia” cuando se cambie una herramienta, se coloque o remueva una pieza de trabajo. Jale el botón de “Paro de Emergencia” después de haber puesto la guarda de seguridad.
- Mantenga fuera del área de trabajo a toda persona no autorizada.
Emergency Stops

All proLIGHT 1000 operators must be fully aware of how to shut down the machine quickly, should the need arise.

- In an emergency, you should always use the red Emergency Stop button on the Machining Center.
- You can also stop it by pressing the Control and Space keys on the computer keyboard, or by clicking on the stop buttons on the screen with the mouse. In an emergency, always use the Emergency Stop button on the machine.
proLIGHT G and M Codes

G Codes by Group
M Codes by Group
# G Codes by Group

## Interpolation Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>G00</td>
<td>Rapid traverse</td>
</tr>
<tr>
<td>G01</td>
<td>Linear interpolation</td>
</tr>
<tr>
<td>G02</td>
<td>Circular interpolation (clockwise)</td>
</tr>
<tr>
<td>G03</td>
<td>Circular interpolation (counterclockwise)</td>
</tr>
</tbody>
</table>

## Programming Mode Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>G90</td>
<td>Absolute coordinate programming (Fanuc uses U,W): All X, Y and Z axes coordinates are relative to a (0,0) location on a mill.</td>
</tr>
<tr>
<td>G91</td>
<td>Incremental coordinate programming: Each command is relative to the one before it in the program.</td>
</tr>
</tbody>
</table>

## Units Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>G70</td>
<td>Inch: Used to instruct the mill that inches are the unit of measure for the part program. (Fanuc G20)</td>
</tr>
<tr>
<td>G71</td>
<td>Metric: Used to instruct the mill that millimeters are the unit of measure for the part program. (Fanuc G21)</td>
</tr>
</tbody>
</table>

## Wait Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>G04</td>
<td>Dwell (wait): Equals the value of the feed rate (F code) in seconds (used primarily for robotic operations). G04 excludes motion commands with a new feed rate on the same line (block).</td>
</tr>
<tr>
<td>G05</td>
<td>Pause: Used for operator intervention. The order of action for the pause and dwell codes in one NC block is G05, G04 (pause, dwell).</td>
</tr>
<tr>
<td>G25</td>
<td>Wait for robot input to be high: Used in conjunction with H code, which specifies input number. Used for robot synchronization (see Appendix F).</td>
</tr>
<tr>
<td>G26</td>
<td>Wait for robot input to be low: Used in conjunction with H code, which specifies input number. Used for robot synchronization (see Appendix F).</td>
</tr>
<tr>
<td>G31</td>
<td>Linear to specified coordinate. Stop short if specified input goes High (if H is positive) or Low (if H is negative).</td>
</tr>
</tbody>
</table>
### Polar Programming Group

- **G15** Polar programming cancel.
- **G16** Begin polar programming.

### Coordinate System Group

- **G53** Rapid traverse to specified coordinates in the Machine Coordinate System. (e.g. G53X0Y0Z0 rapids to machine reference point)
- **G54** Use coordinate system one.
- **G55** Use coordinate system two.
- **G56** Use coordinate system three.
- **G57** Use coordinate system four.
- **G58** Use coordinate system five.
- **G59** Use coordinate system six.

### Canned Cycle Group

- **G80** Canned cycle cancel.
- **G81** Canned cycle drilling.
- **G82** Canned cycle straight drilling with dwell.
- **G83** Canned cycle peck drilling.
- **G84** Canned cycle tapping.
- **G85** Canned cycle boring.
- **G86** Canned cycle boring with spindle off (dwell optional).
- **G89** Canned cycle boring with dwell.

### Preset Position Group

- **G27** Check reference point: This code moves the tool to its home position on the Machining Center to check the calibration of the axes. Compares reported position against zero to see if position has been lost.
- **G28** Set reference point: This code moves the tool and calibrates the axes. The Machine Coordinate System origin is located at this home position.
- **G29** Return to reference point: Moves the tool to a coordinate specified by XYZ. Typically used after a G27 or G28 code.
- **G92** Set position: This code works like the Set Position function under the Setup Menu (see Section E). The X, Y and Z coordinates following a G92 code define the new current position of the tool.
- **G98** Rapid move to initial tool position after canned cycle complete (Section G).
### Plane Selection Group

- **G99**: Rapid move to point R (surface of material or other reference point) after canned cycle complete (Section G).
- **G17**: Select the X,Y plane for circular interpolation. This is the default plane for circular interpolation. Use this code to switch back to the X,Y plane after circular moves on the X,Z or Y, Z planes. The arc center coordinates are given by I for the X axis and J for the Y axis.
- **G18**: Select the X,Z plane for circular interpolation. Use this code to perform circular interpolation on the X,Z plane. The arc center coordinates are given by I for the X axis and K for the Z axis.
- **G19**: Select the Y,Z plane for circular interpolation. Use this code to perform circular interpolation on the Y,Z plane. The arc center coordinates are given by J for the Y axis and K for the Z axis.

### Scaling Group

- **G50**: Cancel scaling.
- **G51**: Invoke scaling. Use this code to scale axes with independent factors around a fixed origin. The default is 1.

### Rotation Group

- **G68**: Invoke rotation. Use this code to rotate a geometry from its origin by an arbitrary angle. Rotation works on any plane, one plane at a time.
- **G69**: Cancel rotation.

### Cutter Compensation Group

- **G39**: Corner offset in circular interpolation.
- **G40**: Cancel cutter compensation.
- **G41**: Invoke cutter compensation left.
- **G42**: Invoke cutter compensation right.
- **D**: Specifies the offset number from the Offset Table.

### Tool Length Offset Group

- **G43**: Shifts Z axis in a positive direction by a value specified by H.
- **G44**: Shifts Z axis in a negative direction by a value specified by H.
- **G49**: Cancel Tool Length Offsets.
- **H**: Specifies the offset number from the Offset Table.

### Tool Length Adjust Group

- **G45**: Increases the movement amount by the value of D.
- **G46**: Decreases the movement amount by the value of D.
- **G47**: Increases the movement amount by twice the value of D.
- **G48**: Decreases the movement amount by twice the value of D.
- **D**: Specifies the offset number from the Offset Table.
### M Codes by Group

#### Program Stop/End Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>M00</td>
<td>Pause: Allows you to place a pause in your code. Acts like a G05 pause.</td>
</tr>
<tr>
<td>M01</td>
<td>Optional Stop: Allows you to place an optional stop in your code. Place an M01 in the block of code where you would like to pause. With Optional Stop on, the M01 works like a G05. With Optional Stop off, the M01 code is ignored, the other codes on the block are executed as usual.</td>
</tr>
<tr>
<td>M02</td>
<td>End of Program: Takes effect after all motion has stopped; turns off drive motors, spindle and accessory outlets.</td>
</tr>
<tr>
<td>M30</td>
<td>Program stop: Same as M02.</td>
</tr>
</tbody>
</table>

#### Spindle Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>M03</td>
<td>Spindle Motor On: Activated concurrently with motion specified in the program block; remains in effect until superseded by M05.</td>
</tr>
<tr>
<td>M05</td>
<td>Spindle Motor Off: Activated after the motion specified in the program block; remains in effect until superseded by M03.</td>
</tr>
</tbody>
</table>

#### Tool Change Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>M06</td>
<td>Tool Change: Used in conjunction with a T code to perform multiple tool operations. See Section H.</td>
</tr>
</tbody>
</table>

#### Accessories On/Off Group

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>M08</td>
<td>ACC1 On: Turns on accessory ACC1 outlet concurrently with the motion specified in the program block; remains in effect until superseded by M09.</td>
</tr>
<tr>
<td>M09</td>
<td>ACC1 Off: Turns off accessory ACC1 outlet after the motion specified in the program block; remains in effect until superseded by M08.</td>
</tr>
<tr>
<td>M10</td>
<td>Clamp ACC2: Turns on ACC2. Closes air vise accessory concurrently with the motion specified in the program block; remains in effect until superseded by M11.</td>
</tr>
<tr>
<td>M11</td>
<td>Unclamp ACC2: Turns off ACC2. Opens air vise accessory after the motion specified in the program block; remains in effect until superseded by M10.</td>
</tr>
</tbody>
</table>
Program Management Group

M20  

*Chain to Next Program:* This code appears at the end of a part program and is followed on the next line by the file name of another program which is executed when all motion stops. Here’s an example of a part program chain to another program:

```
N37 Z.2
N38 M20
PROGRAM TWO
```

If the two programs you are chaining are not in the same directory, you must specify the full pathname for each file. If the specified file is not found, the Open dialog box appears so you can locate it.

M22  

*Output to file:* Outputs information to a file. The first time the Control Program encounters an M22 code, it opens the specified file. You must enclose the name of the file in parentheses for the Control Program to recognize it.

The proper format for using this code is: M22(filename.ext [,.A]) [text and macros]. Items in brackets [ ] are optional, except that a filename is required for the first M22. If no text is specified to be output to the file, the current axis positions are output. M22 automatically adds a tilde (~) to the output text, so the next M22 starts on a new line in the file.

If you use more than one M22, only the first occurrence must have the filename in the parentheses. The remaining M22’s may have empty parentheses, ( ). If you want to generate more than one file at a time you must include the filename each time you specify M22. If a filename is not specified, the first file opened is used.

Following is a list of special codes that can be used with M22 to generate run-time reports.

- @X Current X position (in current coordinate system)
- @Y Current Y position (in current coordinate system)
- @Z Current Z position (in current coordinate system)
- (~) New line (starts a new line in the file)
- @TD Time of day (12hour): “11:59:59AM”
- @TC Time (elapsed) for cycle: “99:11:59” (0’s trimmed from left)
- @TT Time total (of program run): “99:11:59”
- @TA Time Average (per cycle): “99:11:59” (“?:?:?” if first part)
- @TL Current tool number: “5”
- @C Cycle number (current pass): “3”
- @D Date: “12/31/94”
- @FN Current file (without path): “PART.NC” (“UNTITLED.NC” if untitled)
- \t Tab
- \\ Outputs a single backslash character to the file

The M22 code supports multiple output files. The first occurrence of a filename opens the file. In the name M22(FILE.OUT,.A) TEXT... the output is appended to the file (if it exists). Each unique filename opens a separate file. For backward compatibility, empty parentheses M22( ) TEXT... cause the M22 output to go to the first file that was opened with an M22.
**Program Management Group -continued**

M47 | **Rewind:** Restart the currently running program; takes effect after all motion comes to a stop. Use the L code to repeat a finite number of times. The L code defines the number of times to run. For example, M47L2 rewinds twice.

M98 | **Call to subprogram**

M99 | **Return from subprogram:** Returns you to the block following the initial M98 command.

**Go to:** Used with P code. P code defines N code destination. Goes to first occurrence of N code within the main program. The N code can not follow any subprogram (O code).

**I/O Group**

M25 | **Set robot output:** Used for robot synchronization. Used in conjunction with H code to specify output number.

M26 | **Set robot output:** Used for robot synchronization. Used in conjunction with H code to specify output number.
Robotic Integration

The proLIGHT Machining Center has a simple interface for interacting with common robots, like those used for automatic part loading between machining operations. The Machining Center and the robot communicate by way of an interface connector (labeled I/0) located on the rear panel of the Machining Center.

How it Works

The method of communication between the Machining Center and robot is very basic. They are both able to transmit and receive high or low signals. Since communication signals are typically 0 and 5 volts, a high signal is 5 volts (or 3.5 volts or greater); and a low signal is 0 volts (or 1.5 volts or less). See the figure below.

There are NC codes that you can place in a part program to instruct the Machining Center to transmit a high or low signal to the robot. There are also codes that instruct the Machining Center to wait for a high or low signal from the robot.
Signals sent out are referred to as outputs, while signals coming in are called inputs. Any signals that the Machining Center transmits to the robot are transmitted through an output pin on the interface connector. Outputs can drive a maximum load of 1mA. Any signals that the Machining Center receives from the robot come in through an input pin on the interface connector.

Examples of input and output wiring are shown in the schematic below.

**Input Configuration**

**Output Configuration**
The Interface Connector

The 9 pin I/O connector on the rear panel provides a number of ways for the Machining Center to communicate with robots and other external mechanisms, such as an additional limit switch. Most of the Machining Center Controller inputs and outputs are located on this connector.

Some of the inputs and outputs are not free for robotic interfacing, they already have dedicated uses; inputs 7 and 8 for example. The inputs and outputs on the Machining Center are designated as follows.

<table>
<thead>
<tr>
<th>Pin</th>
<th>Function</th>
<th>I/O Levels</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Input 1</td>
<td>+5V</td>
<td>INP 1L</td>
</tr>
<tr>
<td>2</td>
<td>External Limit</td>
<td>0 or +5V</td>
<td>ELim</td>
</tr>
<tr>
<td>3</td>
<td>Output 2</td>
<td>+1V to +3.5V</td>
<td>OUTPUT 2</td>
</tr>
<tr>
<td>4</td>
<td>Output 1</td>
<td>+1V to +3.5V</td>
<td>OUTPUT1</td>
</tr>
<tr>
<td>5</td>
<td>Common</td>
<td></td>
<td>GND</td>
</tr>
<tr>
<td>6</td>
<td>Input 2</td>
<td>0 or +5V</td>
<td>INPUT 2</td>
</tr>
<tr>
<td>7</td>
<td>Input 1H</td>
<td>See Note</td>
<td>INPUT 1H</td>
</tr>
<tr>
<td>8</td>
<td>Input 2H</td>
<td>See Note</td>
<td>INPUT 2H</td>
</tr>
<tr>
<td>9</td>
<td>Common</td>
<td></td>
<td>GND</td>
</tr>
</tbody>
</table>

You can check the status of each input and output by using the toolbars in the Control Program.

Notes: Grounding pins 1 and 6 will cause the input to be true.

Inputs 1H and 2H are only used in isolated input mode, and the Controller Box must be specifically configured.
Other Input/Output Notes:

- All User outputs are disabled by an ESTOP condition.
- Never apply a negative voltage or an AC voltage to an input.
- Do not connect to pins 7 or 8. These are for special applications.
- Outputs are set to source current only. Max load on each output is 1mA.
- Do not operate relays, motors or other inductive loads with the I/O outputs. This will damage the machine. You may however, run an optical relay.

The NC Codes

The NC codes used in robotic communication are:

- G25 - wait for High signal
- G26 - wait for Low signal
- M25 - transmit High signal
- M26 - transmit Low signal
- H# - specifies the input or output (default is H5)

The H code is used in conjunction with the wait codes and transmit codes. For example, G25H3 tells the Machining Center to wait until the state at input #3 goes high.

Assuming the robot’s initial output state is low, if you place this line of code at the beginning of your program, the Machining Center waits until input #3 goes high, then executes the next line of code.

If the external device sends a low signal, nothing happens because the Machining Center is waiting for a high signal. If there’s no change to a high signal, the Machining Center does not execute the next line of NC code in the program.

When the robot sends a high signal, the Machining Center responds by continuing with the NC program. If the Machining Center does not respond to the robot as you have programmed it to, check that you have correctly wired the robot to the interface, and that the robot’s initial output state was not changed to high during the connection of the robot.
A Sample of Mill/Robot Communication

As previously explained, communication between the Machining Center and robot is very simple. They only use and recognize high or low signals. Once the Machining Center sends a signal to the robot, it goes into a wait state and continues to wait until the robot sends the appropriate signal back. When the signal is recognized, the Machining Center executes the next instruction in the part program. After executing the instruction, it sends a signal to the robot. The robot, which has been in a wait state since its last transmission, receives the signal, performs as it has been programmed, then again signals the Machining Center.

This reciprocal system of communication is made possible by the placement of G and M codes in the part program. The G codes provide the wait instructions to the inputs, while the M codes provide the transmit instructions to the outputs.

The following sequence is typical of communication between the Machining Center and a robot. Since the robot’s initial output state is low, the mill’s inputs have already been pulled down to a low state. The Machining Center is equipped with an air vise.

1. The mill opens the air vise (M11), transmits a high signal (M25) to the robot, and waits for a high (on) signal (G25).
2. The robot places a work piece in the vise and transmits a high signal to the mill indicating that it is okay to close the vise.

3. The mill receives the signal, closes the air vise (M10), then signals (M26) the robot that the vise is closed. The mill then waits (G26) for a low signal from the robot.

4. The robot releases the work piece and leaves the work area. It transmits a low signal when it is away from the work area.

5. The mill receives the low signal from the robot and begins to mill the part.
6. When the mill has finished the part, it signals the robot (M25) to come take the part and waits (G25) for a high signal.

7. When the robot receives the signal, it approaches the mill, grasps the part and sends the high signal to the mill.

8. When the mill receives the high signal, it opens the vise (M11) to release the finished part, signals the robot (M26) and waits (G26, low).

9. The robot removes the finished part from the work area, and places the part in another area according to its own program. When the robot has cleared the mill’s work area, it sends a low signal to the mill.

10. At this point, the cycle begins again (M47).
Section L: Robotic Integration

**Robot Handshaking**

This program illustrates one way to use G, M and H codes to interface with a robot. The codes inserted for robot interfacing are in bold.

**NC Program**

N0; THIS FILE FOR PLM-2000 MILL
N1; USE 3" X 2" MACHINABLE WAX
N2G05
N3S1500M03
N4G0Z0.0700
N5G0X1.0000Y0.3140
N6G0Z0.0050
N7G1Z-0.1000F4.0
N8G3X1.5830Y1.3330I-0.5990J1.0190F12.0
N9X0.4170I-0.5830J-1.0190
N10X1.0000Y0.3140I1.1820J0.0000
N11G0Z0.0700
N12S1500.00
N13G0X0.8000Y0.7330
N14G0Z0.0050
N15G1Z-0.1000F4.0
N16G3X0.9330Y0.6670I0.1330J0.1010F12.0
N17G1X1.0670
N18G3Y1.0010I0.0000J0.1670
N19G1X0.9330Y1.0000
N20G2Y1.3340I0.0000J0.1670
N21G1X1.0670Y1.3330
N22G2X1.1997Y1.2668I0.0000J-0.1660
N23G0Z0.0700
N24M02

**Robot Handshaking**

N0M11; OPEN VISE
N1M25H5; TRANSMIT HIGH SIGNAL THROUGH OUTPUT 2
N2G25H5; WAIT FOR HIGH SIGNAL THROUGH INPUT 1
N3M10; CLOSE VISE
N4M26H5; TRANSMIT LOW SIGNAL THROUGH OUTPUT 2
N5G26H5; WAIT FOR LOW SIGNAL THROUGH INPUT 1
N6M47L3; CYCLE BACK TO N0
N7M2; END OF PROGRAM
Index

A
About Benchmark 4000 E-56
Absolute coordinate programming code K-2
Accessories J-5
Accessory off code K-5
Accessory on code K-5
Address character F-2
Administrator Mode E-53
Advanced Panel E-65
Air vise 5
After existing tool E-35
Arc Centers Incremental E-42
Arrange Icons E-54
Assign tool station E-36
ATC Control Toolbar E-9
ATC Settings E-65
Auto-refresh E-45
AutoSave E-52

B
Backlash E-51
Benchman 4000 Interface E-2
Blocks
  maximum number per program F-2
  of NC code F-2
Boring cycle B-11
Boring cycle code B-7
Boring cycle with dwell code B-7
Boring cycle with spindle off code B-7
Boring Tools I-4
Buttons E-46

C
Call to subprogram code B-13
Canned cycle
  boring B-11
  cancel B-7
  codes K-3
  dwell B-9
  G codes B-7
  peck drilling B-9
  programming B-7, K-4
  straight drilling B-8
  tapping threads B-10
Cascade E-54
Center Drills I-4
Centerline Options E-45
Chain to next program K-6
Check Home E-46
Circular interpolation B-4, H-14
  clockwise, code for K-2
  counterclockwise, code K-2
Circular interpolation programming B-3
Clamp ACC2 code K-5
Clear E-22
Close Command E-15
compensation offset E-49
Computer System Requirements A-10
Configure ATC E-36
Context Help E-8
Control Panel E-64
Control Program
  Installation A-11
  screens C-4
  starting C-2
Coordinate System
codes K-3
  Command E-47
Coordinate Systems, understanding H-27
Copy E-21
Corner offset circular interpolation H-14
Corner offset code K-4
Crosspad E-11
Ctrl + C E-61
Ctrl + F E-61
Ctrl + G E-61
Ctrl + H E-61
Ctrl + L E-61
Ctrl + N E-61
Ctrl + O E-61
Ctrl + P E-61
Ctrl + R E-61
Ctrl + S E-61
Ctrl + Shift + Z E-61
Ctrl + Space E-61
Ctrl + T E-61
Ctrl + V E-61
Ctrl + X E-61
Ctrl + Y E-61
Ctrl + Z E-61
Customer Service Department A-3
Cut E-21
Cutter compensation H-6
  canceling H-15
  codes K-4
  UK vectors H-10
  setting offsets H-11
  starting H-6, H-7
Cycle Stop E-12

D
Default Values for Speed E-40
Delete E-22
Depth of Cut
defined I-2
docked screen component E-4
Door Interlock Switch D-3
Door, safety J-2
Dwell code K-2
E
Edit Menu E-20
Edit Tool Materials E-34
Edit Window C-8
  moving E-3
Editor Preferences E-52
Emergency Stop D-3
Emergency Stop Button D-3
Enable Soft Limits E-51
Enable Subprograms E-42
End Mills 1-4
End of program K-5
Estimate Runtime E-31, E-58
Exit command E-19
F
F1 E-61
F3 E-61
F5 E-61
F6 E-61
F8 E-61
Feed Rate
defined I-2
Feed Rate Override E-12
Feed Rate Settings E-65
Feedhold E-32
File Default E-52
File Menu E-14
Find E-22
floating screen component E-4
Font Settings E-27
G
G&M codes 5
G92 E-48
General Panel E-64
Glasses J-2
Go to code K-7
Goto Line E-24
Goto Offset E-48
Goto Position E-47
H
H code K-5
Hardware Installation A-4
Helical interpolation B-5
Help Index
  Menu, Command E-55
Home E-46
Homing
  commands H-3
Hot Keys E-61
I
Inch programming code K-2
Incremental coordinate programming code K-2
Initial Tool Position E-45
Initialize Station Location E-37
Inputs Toolbar C-7, E-9
Insert N Codes E-24
Insert or Remove Spaces E-25
Insert Tool E-36
Interface Card
  Installing A-4
Interface Card Panel E-64
interlock switch D-3
Interpolation
circular B-3
linear B-2
J
Jog Control E-28
Jog Control Panel E-11
  Pop-up Menu commands E-60
Jog Distance E-40
Jog Settings E-39
Jog Speed E-40
L
L code B-13
limit switches D-3
Linear interpolation
code K-2
  programming B-2
Lineal motion code K-2
Lock E-26
Loop counter code B-13
M
Machine Coordinates H-27
Machine Info Window E-6
Maximum blocks per program F-2
Menu Bar C-4, E-13
Message Bar E-5
Metric code K-2
Mill/robot communication K-6
More Advanced Panel E-66
Multiple Coordinate Systems H-27
Multiplier E-34
N
NC code
  for robotic communication K-5
NC part programs F-2
negative limit D-4
New Command E-14
Num Teeth E-34
O
  O code B-13
  Offset
    number E-49
    number code K-4
    sides, changing H-13
    values, changing H-12
  Offset Table E-49, K-4
  Open Command E-14
  Opening a Recent Program E-18
  Operator Panel E-12, E-28
  Optional
    Skip E-41
    Stop E-12, E-42, K-5
  Options Panel E-45
  Origin E-44
  Output to file code K-6
  Outputs Toolbar C-6, E-10

P
  P code, calling subprograms B-13
  Password
    changing, creating E-53
  Paste E-21
  Pause E-32
    G code for K-5
  Pause code K-2
  Peck drilling code B-7
  Peck drilling cycles B-9
  Plane selection codes K-4
  Polar programming H-2
    cancel code K-3
  polar programming
    code K-3
  Pop-Up Menu E-57
  Position E-27
  Position Readout C-11
  Position Window E-7
  Pop-up menu commands E-58
  Positioning Information Areas E-2
  Positioning Toolbars E-2
  positive limit D-4
  Preferences E-52
    exiting E-53
    Security E-53
  Preset View E-44
  Preview Window E-45
  Print E-17
  Print Setup E-18
  Program Edit Window E-5
    Pop-up menu commands E-57
  Program Menu E-29
  Program stop code K-5
  Programming
    suggestions F-23

Q
  Quick Home E-46
  QuickRun E-58
  QuickVerify E-58

R
  Rapid motion codes K-3
  Rapid to initial position code B-7
  Rapid to point R code B-7
  Rapid traverse
    code K-2, K-3
    programming B-6
  Redraw E-59
  Reference Point Tolerance E-64
  Remove Comments E-26
  Remove N Codes E-26
  Renumber E-24
  Renumbering and Subprograms E-25
  Replace E-23
  Reset Override E-50
  Resonance Settings E-65
  Restore Settings E-56
  Restore Unit Mode E-42
  Return from subprogram code B-13
  Return to reference point code K-3
  Rewind K-7
  robot synchronization codes K-2
  Robots
    communication K-6
  Rotation
    and scaling H-23
codes for H-21
  Rotation codes K-4
  Rules, Safety J-1, J-2
  Run Program Dialog Box E-30
  Run Settings E-30, E-41
  Run/Continue E-29, E-32
  Running a Sample NC Program D-5, D-14

S
  Safety D-2
  Safety Door J-2
    interlock switch D-3
  Safety Glasses J-2
  Safety Rules D-2, J-1, J-2
  Save As ... E-16
  Save As Dialog Box E-16
  Save Command E-16
  Save Settings E-55
  Scaling
    and rotation H-23
codes for H-18
  creating mirror images with H-20
each axis H-19
  Scaling codes K-4
select an existing coordinate system E-47
Select Font E-27
Select Tool E-35
Selecting Commands
  Pop-up Menus E-57
Set
  robot output K-7
Set Position E-39
Set reference point code K-3
Set/Check Home E-46
Setting
  offsets H-11
  soft limits H-4
Setup Library E-33
Setup Menu E-38
Setup Program E-63
Setup Tool D-8
Sharpening Tools I-5
Shift Z axis code K-4
Show Tool E-45
Simulation Mode E-66
Single Step E-12, E-41
slider bars E-45
slider button E-45
Soft Limits E-51
Solid Options E-45
Specify depth of cut code B-7
Specify starting reference point code B-7
spectraCAM. 5
Spindle E-50
  motor off code K-5
  motor on code K-5
Spindle Settings E-65
Spindle Speed Override E-12
Standard Toolbar C-4, E-8
Starting Block E-30
Status Bar E-13
Stock Dimensions E-44
Stock Panel E-44
Stop E-12, E-32
Stop Redraw E-59
Straight drilling B-8
Straight drilling code B-7
Straight drilling with dwell code B-7
Style E-44
Subprogram
  call to K-7
Subprogram reference block code B-13
Subprogram, return from code K-7
Subprograms B-13
  nested B-13

T

  Tapping threads B-10
Technical Support A-13
Tile E-54

Tip of the Day E-56
Tool
  change code K-5
  Change Settings E-66
  length offset H-29
  length offset code K-4
  offset adjust H-29
Tool Library E-34
Tool Type E-34, I-4
Tool Wizard E-35
Toolbars E-28
Tools J-4
  Creating E-34
  Tools Menu E-33

U

Unclamp air chuck code K-5
Undo E-20
Uniform scaling H-18
Units E-47
Unpacking A-3
Using Help E-55

V

Verify E-30
  While Running E-43
Verify Settings D-6, E-30, E-43
Verify Type E-46
Verify Window C-11, E-6, E-28
  Pop-up Menu commands E-59
View Menu E-27
View Panel E-44

W

Warnings as Errors E-42
Warranty A-13
Welcome Panel E-63
Window List E-54
Window Menu E-54
Words, NC F-2
Work Coordinates H-27
Wrenches J-3

Z

Zero Position E-39
Zoom E-44
Machining Center Options

The following options are available for the proLIGHT Machining Center:

◆ **Machining Center Machinist Kit (ACC-5110)** The Machinist Kit includes a 3” milling vise with hold-down clamps, a 4-piece R8 collet set, a 7-piece high-speed end mill set (including 2 ball end mills), a 52-piece hold-down set, a Jacob’s chuck, an R8 to 2JT arbor, an edge finder, a 3/8” x 12” cushion-grip T-handle flex key, and ball screw lubricant.

◆ **Quick Change Tooling (ACC-5141)** Quick Change Tooling provides an easy way of integrating multiple tools within one NC program. It comes with the tool body, five tool holders, a tool holder stand, three allen keys and an electronic tool height offset sensor.

◆ **Low-Profile Clamping Kit (ACC-5180)** This kit includes a custom rail and stop with four clamps for work holding.

◆ **CAD Engraver Program (CAM-6511)** The CAD Engraver is a 2 1/2-axis CNC milling program for machining text and CAD drawings.

◆ **Digitizing Package (ACC-5261)** The ACC-5261 Digitizing Package includes a digitizing probe and software that lets you digitize existing parts and models to capture 3-D surface data. The easy-to-use PC-driven package provides reverse engineering capabilities with your proLIGHT series machining center. It can generate files in three different formats; an NC part program, an ASCII text file with XYZ data points, and a DXF 3-D mesh file. The Digitizing Package includes a touch signal probe, a probe interface cable with 15-pin and 9-pin adapters, a 20-mm-long stylus with 3-mm diameter head, a 20-mm stylus extension, the Digitizing Package User’s Guide, the Digitizing Package software on 3-1/2” and 5-1/4” diskettes, and an 8 mm R8 Collet.

◆ **Vacuum System (ACC-5730)** The ACC-5730 Vacuum System is designed for use with the proLIGHT Series Machining Centers. It includes a vacuum with noise reduction features, a GFT hose, a 1-1/2” diameter nozzle mounting assembly, and an electrical relay.

◆ **spectraCAM for Windows (CAM-6721)** spectraCAM for Windows is Light Machines’ CAD/CAM package. The spectraCAM Milling software generates G&M code NC programs that can be used on the proLIGHT Machining Center. spectraCAM includes spectraCAD which can export DXF files. You can import part geometries from CAD programs, such as spectraCAD, that export DXF files.

◆ **Air Vise (PNU-4115)** The Air Vise has jaws that open to a maximum of 3.0 inches. The vise comes with a solenoid valve and all the tubing required to interface with 1/4” pipe fittings from filtered and regulated shop air (50-125 psi).